Le Forum francophone communautaire des utilisateurs de Kali linux

Kali linux => Installation => Discussion démarrée par: Linuxien le 29 avril 2020 à 20:16:41

Titre: [Résolu] | Problème de port forwarding ?
Posté par: Linuxien le 29 avril 2020 à 20:16:41
Bonjour je n’arrive pas à ouvrir mes ports l’environnement est le suivant:
Je dispose d’un vpn (mullvad sur Windows) et d’un vpn sur kali sous Vmware avec une ip dédié .

Lorsque je passe Vmware en NAT le réseau passe bien par Mullvad puis par le VPN sur kali jusque là aucun soucis..

J’aimerai savoir comment ouvrir mes ports à partir de l’ip dédié sur kali sans enlever le réseau en NAT de Vmware sachant que je dispose d’une carte SIM 3g à l intérieur d’un routeur 3g qui est le TP-Link MR6400.

Merci à ceux qui voudront bien m’aide parce que je suis un peu perdu
Bonne journée à tous.
Titre: Re : Problème de port forwarding ?
Posté par: Snk le 29 avril 2020 à 20:37:16
Sous machine virtuelle donc... NAT, donc ton hote, est, la passerelle. Ben, ouvrir le port de ta box qui fait passer ton vpn, ne suffit pas? Depuis le panneau de controle de ta box via firefox, plus depuis Kali un petit:
echo 1 > /proc/sys/net/ipv4/ip_forward
cat /proc/sys/net/ipv4/ip_forward
Le premier pour l'activer et le second pour vérifier... Avant tu peux faire un:
ss -ant
Pour voir ce qui est ouvert (443), ou avec nmap en scannant ta kali, ton windobe (baahhh) et ta box.
Titre: Re : Problème de port forwarding ?
Posté par: Linuxien le 29 avril 2020 à 21:03:55
Re merci de ta réponse ;)
Alors le truc c est que la box en questions est une box 4g, (http://)
Je vais dans la partie virtual serveurs comme renseigne sur le site de tp Link et lorsque je clique sur save ça donne ->> The ip adress is not on thé same subnet with LAN IP adress. Please input another one.
Titre: Re : Problème de port forwarding ?
Posté par: Snk le 29 avril 2020 à 21:11:58
Je suis pas spécialiste des mv, mais là, il te parle d'ip locale, ça c'est geré par ton hote qui va faire la translation pour ta Kali en mv... Je pense que tu dois juste ouvrir le bon port sur la box pour que ton windobe gére le truc. En NAT, ça doit etre du genre 10.0.2.15... Si 10.0.2.2 est ta box, tu tapes ça dans firefox, parametre, autoriser le windobe avec le port 443, a moins qu'il en utilise un autres a vérifier quand même, et de Kali tu l'actives avec la commande que je t'ai donné...
Titre: Re : Problème de port forwarding ?
Posté par: Linuxien le 29 avril 2020 à 21:17:28
Ok je vois mais bon dans la théorique je comprends mais dans la pratique je suis perdu sur ce que tu viens de dire, je tiens à préciser que j’arrive a me connecter tous nickel en bridge mais pas en nat, mais faut que je me connecte uniquement en nat sur kali sous Vmware parce que le vpn de Windobb ahah (mullvad) se répand sur kali uniquement en NAT..
Merci de ton aide ;)
Titre: Re : Problème de port forwarding ?
Posté par: Snk le 29 avril 2020 à 21:24:30
Je connais pas assez les mv avec un vpn, mais je pense que ton windobe vu que c'est du nat, gére ta Kali, fouille dans le win pour voir si un truc ne bloque pas... Ouvres le port de la box et y'a pas de raison si tu as bien install ce qu'il faut pour se connecter... (genre: network-manager-openvpn openvpn network-manager-openvpn-gnome)
En bridge c'est normal, car dhcp donne une ip locale, a ton win et a ta Kali. La carte réseau virtuelle est "pontée" à une carte réseau physique de l'hôte. La carte aura 2 ip. En nat c'est pas pareil, la carte a une ip et le win fait la translation de l'hote vers l'invité.
En tout cas, chez moi, kali en dur, fonctionne trés bien avec openvpn ou avec tor.
Attends une reponse d'un membre qui sera plus catégorique que moi. En espérant ne pas avoir dit trop de bétises...
Bon, si tu veux vraiment etre anonyme, install tails sur une clé, y'a pas mieux... Sinon essaies Sn3rpOS, qui est conf d'origine pour etre anonyme. Moi je préfére les install en dur, surtout pour Linux, les win et machine test en mv, ça okay, bien que je me fais souvent une install en dur a la place... (reformater prend 2s)
Titre: Re : Problème de port forwarding ?
Posté par: Linuxien le 29 avril 2020 à 21:27:21
Ok sa marche je vais attendre alors, en espérant pouvoir régler sa je m arrache les cheveux dessus depuis ce matin  :o
Titre: Re : Problème de port forwarding ?
Posté par: Linuxien le 30 avril 2020 à 03:18:44
Alors j’ai trouvé le hic dans tous ça c est que enfaite avec la 4g + routeur je n’ai pas d’ip publique a proprement parle donc impossible de faire de la redirection de port le seul moyen apparement ce serai de créer à partir d’un VPS un tunnel VPN pour ouvrir les ports.
Ça s’annonce un peu compliqué j’ai pas de très bonnes notions en réseau ... j’en t en dis plus demain dans la journée ou j’en suis ..
Bonne journée .
Linuxien.
Titre: Re : Problème de port forwarding ?
Posté par: ZeR0-@bSoLu le 30 avril 2020 à 06:42:19
Si tu veux port forwarder en NAT ça semble compliqué sauf si tu passes par le menu de vmware qui te permets de le faire.
En fait je sais que sous Vbox c'est faisable mais pas je pense que ça doit l'etre sur Vmware bien que je ne l'utilises pas.

Je pensais quand tu t'inscrivais que tu avais les bases en réseau... :( Faut revoir les bases :P

Je pense qu'en bridged ça t'aiderais déjà mieux non..? ;) vu que comme tu l'a toi même constater, cela fonctionne. (ce qui est normal vu que ça ne peux fonctionner que comme tel)

Renseigne toi simplement sur ce qu'est le NAT en fait, tu comprendras normalement de toi même pourquoi ça peut pas marcher (du moins sans l'aide de vmware)


De plus on t'aide car on est sympas mais ton sujets n'a clairement aucun rapport avec la cybersécurité la c'est plutot un sujet à demander sur le forum de vmware pour le coup. Puisque non lié à kali. De ce fait tu trouverais surement plus d'informations sur le forum de vmware pour le coup. Je dis ça pour toi ^^'


P.S sur virtualbox cela se trouve ici, après comme je disais, je n'utilise pas VMWare donc... ^^':

(http://pix.toile-libre.org/upload/img/1588226942.png) (http://pix.toile-libre.org/?img=1588226942.png)


Ceci étant dit oui le système d'adressage des adresses sur une box 4g est différente et n'aidera pas pour rectifier cela.
Titre: Re : Problème de port forwarding ?
Posté par: _john_doe le 30 avril 2020 à 15:49:06
Je plussois sur la réponse de Zer0.
Avant de pouvoir t'aider plus avant 2 questions :
- pourquoi utiliser 2 VPN ?
-pourquoi souhaiter du NAT et non du bridge ?

Titre: Re : Problème de port forwarding ?
Posté par: Linuxien le 30 avril 2020 à 18:02:15
Salut _john_doe merci de l’intérêt que tu porte à l’égard du Topic je souhaite simplement utiliser 2 vpn pour être anonyme ce qui contribuerai à mon apprentissage personnel, le fait d’utiliser du NAT me permettrais d’avoir les 2 VPN qui passent par mon réseau .. Ce qui n’est pas possible en bridge..
 ;D
Linuxien.
Titre: Re : Problème de port forwarding ?
Posté par: Linuxien le 01 mai 2020 à 11:00:34
Bonjour à tous, je suis entrain de suivre ce tuto cependant je bloque à l’identification de openvpn sur l’ip du vps:943/admin/ il ne reconnaît pas le mdp précédemment entrer avec passwd openvpn.
https://www.nas-forum.com/forum/topic/63719-tuto-vps-openvpnnginx-pour-l’ouverture-de-ports-en-4g/

Je pense que ça vient de l’installation de openvpn via ssh, je dispose d’un message d’erreur à la fin de l installation, ci joint la photo du message d erreur:


Titre: Re : Problème de port forwarding ?
Posté par: ZeR0-@bSoLu le 01 mai 2020 à 11:04:07
Suffit de lire ton terminal. De plus ça n'a aucun rapport avec ton sujet d'origine.
Titre: Re : Problème de port forwarding ?
Posté par: Linuxien le 01 mai 2020 à 11:22:17
Je comprends bien qu’il faut lire le terminal mais je n’arrive pas à trouver de solution :(
Titre: Re : Problème de port forwarding ?
Posté par: ZeR0-@bSoLu le 01 mai 2020 à 11:25:33
Dans ce cas fait une demande d'aide sur un helpdesk de openvpn et/ou de nginx pour qu'ils puissent t'aider. Vu que tu as un broken package. Surement que si tu installes des dépendances ça se passera mieux hein... ^^'
Titre: Re : Problème de port forwarding ?
Posté par: Snk le 01 mai 2020 à 12:52:06
Si je puis me permettre, copie-colle ton message d'erreur dans gogol, si tu l'as pas deja fait, il te dira quel paquet il te manque ou lequel est cassé et a réinstaller...
Et avec --fix-broken ?  merci le man...
"Qui cherche, Trouve"

Edit: Ceux qui disent qu'il faut savoir attaquer pour se defendre, ben en faite, c'est une grosse connerie, ou une excuse pour faire des trucs illégal... Certes, c'est amusant d'attaquer une de tes machines, c'est fun, mais ce n'est pas obligatoire pour savoir comment se defendre. Ce qu'il faut surtout, c'est comprendre comment ça marche, pour se defendre efficacement, c'est tout... 8)

Tiens, un petit cour te fera du bien:
- https://www.informatiweb.net/tutoriels/informatique/virtualisation/virtualbox-modes-d-acces-reseau-d-une-machine-virtuelle.html
- https://www.commentcamarche.net/contents/527-nat-translation-d-adresses-port-forwarding-et-port-triggering
Titre: Re : Problème de port forwarding ?
Posté par: ZeR0-@bSoLu le 01 mai 2020 à 12:52:45
Best tuto by Snk :D xD

EDIT: Ah je suis pas le seul à dire ça :P