Auteur Sujet: Problème installation Asus A6  (Lu 33682 fois)

0 Membres et 2 Invités sur ce sujet

Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Problème installation Asus A6
« Réponse #60 le: 05 septembre 2015 à 00:13:31 »
J'ai appuyé sur OK et 2ème écran bleu avec "le pilote n'est pas configuré; il doit être activé dans le fichier xorg.conf afin d'être utilisé.

A mon avis je dois faire toute la procédure et démarrer à la fin. OUI ?

Je viens de lire ton post avant le mien donc OK, je fais la procédure jusqu'au bout sans rebooter.


Hors ligne trude

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 148
  • +13/-11
Re : Re : Problème installation Asus A6
« Réponse #61 le: 05 septembre 2015 à 00:14:54 »
J'ai appuyé sur OK et 2ème écran bleu avec "le pilote n'est pas configuré; il doit être activé dans le fichier xorg.conf afin d'être utilisé.
C'est la commande nvidia-xconfig qui va s'en charger

Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Re : Re : Problème installation Asus A6
« Réponse #62 le: 05 septembre 2015 à 00:35:32 »
J'ai appuyé sur OK et 2ème écran bleu avec "le pilote n'est pas configuré; il doit être activé dans le fichier xorg.conf afin d'être utilisé.
C'est la commande nvidia-xconfig qui va s'en charger

Voilà fait les 2 patchs + reconfigure. tout c'est bien passé. Je reboote pas, je continue ?

Prochaine étape installation du driver apt-get install  nvidia-legacy-304xx-driver

Hors ligne trude

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 148
  • +13/-11
Re : Problème installation Asus A6
« Réponse #63 le: 05 septembre 2015 à 00:37:02 »
logiquement il t'a modifié les modules noyau et le boot de grub donc tu peux quand même déjà rebooter

Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Re : Problème installation Asus A6
« Réponse #64 le: 05 septembre 2015 à 00:39:16 »
logiquement il t'a modifié les modules noyau et le boot de grub donc tu peux quand même déjà rebooter


OK je reboote.

Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Problème installation Asus A6
« Réponse #65 le: 05 septembre 2015 à 00:43:20 »
"le pilote n'est pas configuré; il doit être activé dans le fichier xorg.conf afin d'être utilisé."

c'était pas grave que le Xorg.conf n'était pas configuré ? on verra bien.


Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Problème installation Asus A6
« Réponse #66 le: 05 septembre 2015 à 00:46:46 »
je continue, tu veux pas voir le Xor.0.log avant ?

Hors ligne trude

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 148
  • +13/-11
Re : Problème installation Asus A6
« Réponse #67 le: 05 septembre 2015 à 00:50:19 »
Tant que l'install du driver nvidia n'est pas faite et qu'il n'a pas blacklister le driver NOUVEAU, c'est toujours le driver NOUVEAU qui doit être loadé
Tant que le driver n'est pas déclaré dans xorg.conf par la commande nvidia-xconfig il n'est pas chargé.

Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Problème installation Asus A6
« Réponse #68 le: 05 septembre 2015 à 00:52:42 »
OK, je te mets quand même le Xorg.0.log à cette étape :

[    45.998]
X.Org X Server 1.17.2
Release Date: 2015-06-16
[    45.999] X Protocol Version 11, Revision 0
[    45.999] Build Operating System: Linux 3.16.0-4-amd64 i686 Debian
[    46.000] Current Operating System: Linux kali 4.0.0-kali1-686-pae #1 SMP Debian 4.0.4-1+kali2 (2015-06-03) i686
[    46.000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.0.0-kali1-686-pae root=UUID=09650290-62ae-43ea-8bb6-30fd101e0574 ro initrd=/install/gtk/initrd.gz quiet
[    46.000] Build Date: 01 July 2015  05:17:45PM
[    46.000] xorg-server 2:1.17.2-1 (http://www.debian.org/support)
[    46.000] Current version of pixman: 0.32.6
[    46.000] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[    46.000] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    46.000] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Sep  5 00:43:42 2015
[    46.001] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    46.001] (==) No Layout section.  Using the first Screen section.
[    46.001] (==) No screen section available. Using defaults.
[    46.001] (**) |-->Screen "Default Screen Section" (0)
[    46.001] (**) |   |-->Monitor "<default monitor>"
[    46.004] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[    46.004] (==) Automatically adding devices
[    46.004] (==) Automatically enabling devices
[    46.004] (==) Automatically adding GPU devices
[    46.004] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    46.004] Entry deleted from font path.
[    46.004] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    46.004] Entry deleted from font path.
[    46.004] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    46.004] Entry deleted from font path.
[    46.004] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    46.004] Entry deleted from font path.
[    46.004] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    46.004] Entry deleted from font path.
[    46.004] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[    46.004] (==) ModulePath set to "/usr/lib/xorg/modules"
[    46.004] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[    46.004] (II) Loader magic: 0xb77d3700
[    46.004] (II) Module ABI versions:
[    46.004] X.Org ANSI C Emulation: 0.4
[    46.004] X.Org Video Driver: 19.0
[    46.004] X.Org XInput driver : 21.0
[    46.004] X.Org Server Extension : 9.0
[    46.004] (II) xfree86: Adding drm device (/dev/dri/card0)
[    46.006] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Invalid argument
[    46.009] (--) PCI:*(0:1:0:0) 10de:01d7:1043:1212 rev 161, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xfc000000/16777216, BIOS @ 0x????????/131072
[    46.010] (II) LoadModule: "glx"
[    46.010] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    46.081] (II) Module glx: vendor="NVIDIA Corporation"
[    46.081] compiled for 4.0.2, module version = 1.0.0
[    46.082] Module class: X.Org Server Extension
[    46.082] (II) NVIDIA GLX Module  304.125  Mon Dec  1 20:21:57 PST 2014
[    46.083] (==) Matched nouveau as autoconfigured driver 0
[    46.083] (==) Matched nv as autoconfigured driver 1
[    46.083] (==) Matched modesetting as autoconfigured driver 2
[    46.083] (==) Matched fbdev as autoconfigured driver 3
[    46.083] (==) Matched vesa as autoconfigured driver 4
[    46.083] (==) Assigned the driver to the xf86ConfigLayout
[    46.083] (II) LoadModule: "nouveau"
[    46.083] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    46.088] (II) Module nouveau: vendor="X.Org Foundation"
[    46.088] compiled for 1.17.1, module version = 1.0.11
[    46.088] Module class: X.Org Video Driver
[    46.088] ABI class: X.Org Video Driver, version 19.0
[    46.088] (II) LoadModule: "nv"
[    46.088] (WW) Warning, couldn't open module nv
[    46.088] (II) UnloadModule: "nv"
[    46.088] (II) Unloading nv
[    46.088] (EE) Failed to load module "nv" (module does not exist, 0)
[    46.088] (II) LoadModule: "modesetting"
[    46.088] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    46.089] (II) Module modesetting: vendor="X.Org Foundation"
[    46.089] compiled for 1.17.2, module version = 1.17.2
[    46.089] Module class: X.Org Video Driver
[    46.089] ABI class: X.Org Video Driver, version 19.0
[    46.089] (II) LoadModule: "fbdev"
[    46.089] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    46.089] (II) Module fbdev: vendor="X.Org Foundation"
[    46.089] compiled for 1.17.1, module version = 0.4.4
[    46.089] Module class: X.Org Video Driver
[    46.089] ABI class: X.Org Video Driver, version 19.0
[    46.089] (II) LoadModule: "vesa"
[    46.089] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    46.089] (II) Module vesa: vendor="X.Org Foundation"
[    46.089] compiled for 1.17.1, module version = 2.3.3
[    46.089] Module class: X.Org Video Driver
[    46.089] ABI class: X.Org Video Driver, version 19.0
[    46.089] (II) NOUVEAU driver Date:   Thu Aug 28 03:57:48 2014 +0200
[    46.089] (II) NOUVEAU driver for NVIDIA chipset families :
[    46.089] RIVA TNT        (NV04)
[    46.089] RIVA TNT2       (NV05)
[    46.089] GeForce 256     (NV10)
[    46.089] GeForce 2       (NV11, NV15)
[    46.090] GeForce 4MX     (NV17, NV18)
[    46.090] GeForce 3       (NV20)
[    46.090] GeForce 4Ti     (NV25, NV28)
[    46.090] GeForce FX      (NV3x)
[    46.090] GeForce 6       (NV4x)
[    46.090] GeForce 7       (G7x)
[    46.090] GeForce 8       (G8x)
[    46.090] GeForce GTX 200 (NVA0)
[    46.090] GeForce GTX 400 (NVC0)
[    46.090] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    46.090] (II) FBDEV: driver for framebuffer: fbdev
[    46.090] (II) VESA: driver for VESA chipsets: vesa
[    46.090] (++) using VT number 7

[    46.100] (EE) [drm] KMS not enabled
[    46.100] (WW) Falling back to old probe method for modesetting
[    46.100] (II) Loading sub module "fbdevhw"
[    46.100] (II) LoadModule: "fbdevhw"
[    46.100] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    46.101] (II) Module fbdevhw: vendor="X.Org Foundation"
[    46.101] compiled for 1.17.2, module version = 0.0.2
[    46.101] ABI class: X.Org Video Driver, version 19.0
[    46.101] (EE) open /dev/fb0: No such file or directory
[    46.101] (WW) Falling back to old probe method for fbdev
[    46.101] (II) Loading sub module "fbdevhw"
[    46.101] (II) LoadModule: "fbdevhw"
[    46.101] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    46.101] (II) Module fbdevhw: vendor="X.Org Foundation"
[    46.101] compiled for 1.17.2, module version = 0.0.2
[    46.101] ABI class: X.Org Video Driver, version 19.0
[    46.101] (EE) open /dev/fb0: No such file or directory
[    46.101] vesa: Ignoring device with a bound kernel driver
[    46.101] (WW) Falling back to old probe method for vesa
[    46.103] (EE) Screen 0 deleted because of no matching config section.
[    46.103] (II) UnloadModule: "modesetting"
[    46.103] (EE) Screen 0 deleted because of no matching config section.
[    46.103] (II) UnloadModule: "fbdev"
[    46.103] (II) UnloadSubModule: "fbdevhw"
[    46.103] (EE) Screen 0 deleted because of no matching config section.
[    46.103] (II) UnloadModule: "vesa"
[    46.103] (EE) Device(s) detected, but none match those in the config file.
[    46.103] (EE)
Fatal server error:
[    46.103] (EE) no screens found(EE)
[    46.103] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[    46.103] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    46.103] (EE)
[    46.105] (EE) Server terminated with error (1). Closing log file.

Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Problème installation Asus A6
« Réponse #69 le: 05 septembre 2015 à 00:54:44 »
Prochaine étape installation du driver apt-get install  nvidia-legacy-304xx-driver.

Il me dit est déjà la plus récente version disponible. Il a rien installé ? là je plane.

Je continue apt-get install nvidia-xconfig . OK


« Modifié: 05 septembre 2015 à 01:01:08 par monteur1234 »

Hors ligne trude

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 148
  • +13/-11
Re : Problème installation Asus A6
« Réponse #70 le: 05 septembre 2015 à 00:58:31 »
Là, surveille bien tout les messages à l'écran pour voir si il y a une erreur

Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Problème installation Asus A6
« Réponse #71 le: 05 septembre 2015 à 01:04:18 »
le Xorg.0.log est le même que dans la  Réponse #68

Hors ligne monteur1234

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 219
  • +10/-6
Re : Problème installation Asus A6
« Réponse #72 le: 05 septembre 2015 à 01:07:24 »
Qu'est ce que je fait je continue,  apt-get install nvidia-xconfig ?

Hors ligne trude

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 148
  • +13/-11
Re : Problème installation Asus A6
« Réponse #73 le: 05 septembre 2015 à 01:09:20 »
Mais aucun messages d'erreur sur l'apt-get install?

Le fichier Xorg.0.log n'est mis à jour que lors d'un boot ou du relancement de l'interface graphique (gdm3)

Après install du driver il y bien un fichier qui blacklist le driver nouveau dans /etc/modprobe.d ?

Il faut avant de rebooter il faut installer et lancer nvidia-xconfig pour crée le fichier /etc/X11/xorg.conf

Hors ligne trude

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 148
  • +13/-11
Re : Re : Problème installation Asus A6
« Réponse #74 le: 05 septembre 2015 à 01:11:07 »
Qu'est ce que je fait je continue,  apt-get install nvidia-xconfig ?
Oui, et après lancer la commande nvidia-xconfig et vérifier que le fichier /etc/X11/xorg.conf contient bien un ligne Driver "nvidia"