Auteur Sujet: Installation linux-headers-4.6.0-kali1-all-i386 impossible  (Lu 3194 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Sylvestre

  • Nouvel inscrit
  • Messages: 7
  • +1/-0
Installation linux-headers-4.6.0-kali1-all-i386 impossible
« le: 25 janvier 2017 à 15:25:07 »
Bonjour,
Après maintes tentative je n'arrive vraiment pas à installer linux headers et je me demande d'ou pourrait venir le problème
j'ai procédé de la manière suivante:
d'abord j'ai mis les repo officiel de kali dans la source.list
leafpad /etc/apt/sources.list j'ai tapé puis enregistré ## Regular repositories
deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
## Source repositories
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

ensuite: apt-get updateapt-get upgrade ce qui m'a installé sysvinit
et là je tape root@kaliente:~# apt-get install -y linux-headers-$(uname -r)Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet linux-headers-4.6.0-kali1-686-pae
E: Couldn't find any package by glob 'linux-headers-4.6.0-kali1-686-pae'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-headers-4.6.0-kali1-686-pae »
root@kaliente:~#
bon alors je tentesudo apt-get install linux-headers et j'obtiens Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet linux-headers n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « linux-headers » n'a pas de version susceptible d'être installée
je précise que je désire installer linux headers pour installer virtualbox
Quelqu'un saurait-il pourquoi? Y aurait-il une erreur ou un oubli de ma part?
merci des vos réponses


« Modifié: 25 janvier 2017 à 15:27:42 par Sylvestre »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3779
  • +266/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Installation linux-headers-4.6.0-kali1-all-i386 impossible
« Réponse #1 le: 25 janvier 2017 à 17:58:08 »
Ton système n'est pas à jour, le kernel utilisé est 4.8

fait un apt-get update && apt-get dist-upgrade avant.

PS: upgrade ne met pas à jour le kernel voir man apt-get
« Modifié: 25 janvier 2017 à 18:01:40 par coyotus »

Hors ligne Sylvestre

  • Nouvel inscrit
  • Messages: 7
  • +1/-0
Re : Installation linux-headers-4.6.0-kali1-all-i386 impossible
« Réponse #2 le: 25 janvier 2017 à 21:21:23 »
Merci!  :) rien de bien sorcier en effet