Auteur Sujet: [Résolu] | graphic install inexistant  (Lu 11464 fois)

0 Membres et 3 Invités sur ce sujet

Hors ligne Navy

  • Membre Junior
  • *
  • Messages: 46
  • +0/-5
Re : graphic install inexistant
« Réponse #45 le: 09 juin 2019 à 11:32:52 »
Oui j’ai bien enlever vt-d dans le bios.

J’ai essayé avec et sans.

Toujours pareil.

Je n’ai plus d’idée.

J’ai l’impression que c’est le driver Nvidia (418.74) qui bug mais c’est juste une impression.

Je ne sais vraiment pas d’ou ça viens.

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2972
  • +172/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : graphic install inexistant
« Réponse #46 le: 09 juin 2019 à 13:27:33 »
On a déjà répondu à ce problème sur le forum (il y a pas tres longtemps) je te laisse chercher un peu tu devrais avoir les solutions ;)
Mess  with the bests.
Die like the rest.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : graphic install inexistant
« Réponse #47 le: 09 juin 2019 à 18:32:54 »
Après la manip, as-tu fais un update-grub avant de rebooter?   :P
Que le fichier ne corresponde pas tout a fait, c'est possible, mais il devrait quand même, y avoir une ligne avec BusID "PCI:xx:x:x"  ??? 
Effaces bien tout:
apt-get remove --purge nvidia*
rm -rf /etc/X11/xorg.conf

Sinon on peux essayer voir si les drivers de la 1050 sont prit en charge par nvidia-driver...   ::)
Une fois tout effacé, tu reboot, puis:
Mise a jour du système:
apt update
apt dist-upgrade
Ensuite:
apt install linux-headers-$(uname -r)
apt install nvidia-kernel-dkms
On désactive nouveau et on met grub a jour:
sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub
update-grub
Enfin:
apt install -y ocl-icd-libopencl1 nvidia-xconfig nvidia-driver nvidia-cuda-toolkit
Tu recrées ton xorg-conf avec:
nvidia-xconfig
Un update-grub je pense, et reboot en vérifiant que l'hyperV soit off. C'est juste pour voir si cela peux marcher comme ça...

Si ça ne fonctionne pas tu re-éffaces tout et retentes comme le tuto que je t'ai envoyé...  :P
Deux personnes que j'ai aidé ici, y sont arrivé avec, pas de la première fois, mais au bout de quelques tentatives (si ça peut te rassurer!!)
Bon courage!   8)
« Modifié: 05 juillet 2019 à 21:09:02 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2972
  • +172/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : graphic install inexistant
« Réponse #48 le: 09 juin 2019 à 19:33:58 »
La légende raconte que au bout de 64684685486 tenta Snk arriva a installer Kali :P
Mess  with the bests.
Die like the rest.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : graphic install inexistant
« Réponse #49 le: 09 juin 2019 à 19:40:13 »
J'deviens fou!!   ;D  :-\
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2972
  • +172/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : graphic install inexistant
« Réponse #50 le: 09 juin 2019 à 19:46:32 »
Tu es déjà fou mais tu ne le sais pas encore xD
Mess  with the bests.
Die like the rest.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : graphic install inexistant
« Réponse #51 le: 09 juin 2019 à 19:52:09 »
D'ou la définition d'un fou! S'il le savait, il ne le serait pas vraiment.  :-\
"Un fou au milieu de mecs intelligents, ça a tendance a rendre les autres fous, par contre un mec intelligent au milieu de quelques fous, ben, non ça rend pas les autres plus intelligents!!"
« Modifié: 09 juin 2019 à 19:54:47 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2972
  • +172/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : graphic install inexistant
« Réponse #52 le: 09 juin 2019 à 19:55:44 »
En effet !
Mess  with the bests.
Die like the rest.

Hors ligne Navy

  • Membre Junior
  • *
  • Messages: 46
  • +0/-5
Re : graphic install inexistant
« Réponse #53 le: 10 juin 2019 à 06:49:37 »
Ok merci,

Je réessaye,je lache pas l’affaire.

Il faut que je sois la 3ème personne qui réussit.

A +


En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2972
  • +172/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : graphic install inexistant
« Réponse #54 le: 10 juin 2019 à 07:13:24 »
Bonne chance on attend ton retour
Mess  with the bests.
Die like the rest.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : graphic install inexistant
« Réponse #55 le: 20 juin 2019 à 00:02:32 »
Salut Navy   ;D

Tu nous a toujours pas donné de retour... Je suppose que ça n'a pas marché. J'ai trouvé un autre truc que j'ai traduit et arrangé, toujours tiré du super tuto de Tiger11, un poil de c.. différent.
Bon je te décris le truc en espérant que cela fonctionne pour toi (ton retour m'intéresse, car c'est ma prochaine carte graph, alors hésites pas a me dire ce qu'il en est)

Étape 1: Vérifiez que vous avez des graphiques hybrides:

lspci | grep -E "VGA|3D"
Il doit y avoir deux lignes, une pour vga et une pour 3D.

Étape 2: Désactiver le nouveau:

echo -e "blacklist nouveau\noptions nouveau modeset=0\nalias nouveau off" > /etc/modprobe.d/blacklist-nouveau.conf
update-initramfs -u && reboot

Étape 3: le système redémarre et nouveau doit être désactivé. Vérifiez si nouveau est désactivé:

lsmod |grep -i nouveau
Si ne montre rien, donc nouveau est désactivé avec succès.

Étape 4: Installez le pilote nvidia à partir du dépôt Kali:

apt install  nvidia-driver nvidia-xconfig
Vous pouvez également télécharger le dernier fichier .run du site Web de Nvidia. Exécuter et procéder à l'installation. Que ce soit du repo de Kali ou du site Web de Nvidia, la procédure est la même. Code pour installer le fichier .run:

sudo sh ./Nvidia-driver-filename.run
Étape 5: On doit trouver l’identifiant de bus de notre carte nvidia:

nvidia-xconfig --query-gpu-info | grep 'BusID : ' | cut -d ' ' -f6
il devrait montrer:

PCI:1:0:0
Ceci est notre identifiant de bus.

Étape 6: Maintenant, nous générons le fichier /etc/X11/xorg.conf avec cet ID de bus conformément au guide de Nvidia:


Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "**PCI:1:0:0**"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
   Identifier "intel"
   Driver "modesetting"
EndSection

Section "Screen"
   Identifier "intel"
   Device "intel"
EndSection

Remplacez la chaîne à l'intérieur "** **" par votre ID de bus et enregistrez-la dans /etc/X11/xorg.conf
« Modifié: 20 juin 2019 à 00:20:16 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : graphic install inexistant
« Réponse #56 le: 20 juin 2019 à 00:16:06 »
Bon ben, impossible d'envoyer mon message en entier... Même en plusieurs fois... Pourtant j'ai vu des tutos plus long ici!   :-\ Comprends pas, ça fait deux fois.
Donc voila la fin:

Étape 7: Nous devons maintenant créer des scripts en fonction de notre gestionnaire d’affichage. Pour Kali Linux par défaut, GDM, créer deux fichiers: /usr/share/gdm/greeter/autostart/optimus.desktop /etc/xdg/autostart/optimus.desktop avec le contenu suivant:

[Desktop Entry]
Type=Application
Name=Optimus
Exec=sh -c "xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto"
NoDisplay=true
X-GNOME-Autostart-Phase=DisplayServer

Étape 8: Maintenant, redémarrez et vous devriez utiliser le pilote Nvidia. Vérifiez si tout va bien: installez mesa-utils s'il n'a pas déjà été installé.

apt install mesa-utils

glxinfo | grep -i "direct rendering"
direct rendering: Yes

Étape 9: Maintenant, vous pouvez installer les kits d’outils et les pilotes cuda.

apt install -y ocl-icd-libopencl1 nvidia-driver nvidia-cuda-toolkit
Étape 10: Maintenant notre système doit être prêt à fonctionner, vérifions que les pilotes ont été chargés correctement. Pour vérifier cela exécuter l'outil nvidia-smi.

nvidia-smi
Et vérifier.

Après avoir démarré avec succès avec Nvidia Driver, on peux rencontrer un problème de déchirement de l'écran, par exemple: problèmes lors de la lecture de vidéos dans VLC, vidéos Youtube sur Chrome / Firefox, etc. Heureusement, nous pouvons résoudre ce problème en activant PRIME Sync .

1.Vérifier si PRIME est désactivé:

xrandr --verbose|grep PRIME
il devrait produire quelque chose comme ceci:

PRIME Synchronization: 0
PRIME Synchronization: 1

Le premier est notre écran connecté. La synchronisation PRIME est donc désactivée.

2. Éditez /etc/default/grub et ajoutez:

nvidia-drm.modeset=1 dans GRUB_CMDLINE_LINUX_DEFAULT après quiet. Comme celà:

...
GRUB_CMDLINE_LINUX_DEFAULT="quiet nvidia-drm.modeset=1"
...

3. Enregistrez les modifications et mettez à jour grub à l'aide de la commande suivante:

update-grub
4. Redémarrez votre système.

5.Vérifiez si PRIME est activé:

xrandr --verbose|grep PRIME
Maintenant, il devrait sortir:

PRIME Synchronization: 1
PRIME Synchronization: 1

S'il affiche toujours 0, il y a probablement un problème avec la configuration système/noyau. Comme il s’agit encore d’une fonctionnalité expérimentale de Nvidia, c'est pas de chance...

Si ça ne fonctionne pas,
Retour en arrière de ce que l'on a fait fait jusqu'à présent:

apt remove --purge nvidia-*
rm -rf /etc/X11/xorg.conf

Supprimez les fichiers du gestionnaire d’affichage créés pour GDM:

rm -rf /usr/share/gdm/greeter/autostart/optimus.desktop
rm -rf /etc/xdg/autostart/optimus.desktop

Maintenant, redémarrez. On devrait revenir à votre ancien système.

Voili-voilou, J'espére que tu y arriveras avec cela...    ::) :P
Tchao
!Snk
« Modifié: 20 juin 2019 à 00:18:50 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2972
  • +172/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : graphic install inexistant
« Réponse #57 le: 20 juin 2019 à 09:46:23 »
Merci pour ce petit tuto :)
Je pense à l'épingler... qu'en penses -tu ?
Mess  with the bests.
Die like the rest.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : graphic install inexistant
« Réponse #58 le: 20 juin 2019 à 10:41:53 »
Salut.   :)

Ben, pourquoi pas, si tu veux.   8)
PS: pourquoi donc les messages long ne veulent plus être envoyé?? C'est bizarre, j'ai été obligé de le couper en 4 parties pour arriver a mes fins.
« Modifié: 20 juin 2019 à 10:44:13 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2972
  • +172/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : graphic install inexistant
« Réponse #59 le: 20 juin 2019 à 10:49:09 »
Je vais voir ce que je peux faire ;)

aucune idée de pourquoi mais je pense que c'est volontairement set dans le CMS, je vais regarder

P.S limité a 150.000 caractères pour chaque message
« Modifié: 20 juin 2019 à 10:55:59 par ZeR0-@bSoLu »
Mess  with the bests.
Die like the rest.