Le Forum francophone communautaire des utilisateurs de Kali linux

Développement => Vos créations => Discussion démarrée par: Hedbangz le 08 juin 2013 à 13:01:29

Titre: Module python phply et w3af
Posté par: Hedbangz le 08 juin 2013 à 13:01:29
Bonjour à tous,
Tout d'abord je ne savait pas trop ou ranger ce post qui relève d'un problème avec un module python alors je l'ai mis içi, n'hésitez pas à le déplacer si sa place n'y est pas.
Je vous expose mon problème:
Cela fait un moment que j'essaye de packager w3af pour le mettre dans les dépots, ainsi, j'ai installé toutes les dépendances:
Depends: python2.7-dev libsqlite3-dev python-setuptools python-pipEnsuite, je dois installer selon les instructions donnés au lancement, des dépendances python grâce à pip:
sudo pip install clamd PyGithub GitPython pybloomfiltermmap esmre nltk pdfminer futures guess-language cluster msgpack-python python-ntlm xdotET ensuite (voilà le problème), je dois installer grâce à cette commande:sudo pip install -e git+git://github.com/ramen/phply.git#egg=phply phply depuis git.
Le premier lancement est une réussite, je peut utiliser w3af, mais à chaque relancement, il me dit que la dépendance phply n'est pas satisfaite et que je dois la réinstaller, ce que je fais.
J'en apelle donc à une personne ayant plus d'éxpérience avec python et ses modules pour m'éclairer sur ce drôle de problème.

Merci d'avoir pris le temps de lire ce post,
Hedbangz

Edit: Le lancement de la commande avec sudo crée un dossier src protégé en écriture dans le répertoire courant.