Messages récents

Pages: « 1 2 3 4 5 6 7 8 9 10 »
41
Vrac / Re : Problème au démarrage de « drozer » : ne trouve pas le path de java
« Dernier message par ZeR0-@bSoLu le 26 février 2020 à 11:55:22 »
Je sais que mes messages passent souvent à la trappe et que tout le monde ne me lis pas mais xD

Es-tu sur que la version de java attendu est la bonne par rapport à la version que tu as toi ?

et un :

netstat -tulpn
te montrera quelque chose (ou non du coup) seulement si tu arrives à faire démarrer la console drozer justement.

42
Vrac / Re : Problème au démarrage de « drozer » : ne trouve pas le path de java
« Dernier message par nonsolum le 26 février 2020 à 11:07:47 »
Pour moi, utiliser Linux est un choix, une mentalité et une alternative. Avec tout ce qui a été fait, il y en a pour tout les goûts, tout les niveaux, et toutes les utilisations...


Je suis entièrement d’accord.
Toutes mes excuses pour ma saute d’humeur

Je reviens à mon sujet Drozer :
J’ai à nouveau le message que j’avais au tout début et qui a motivé l’ouverture de cette discussion.

PS P:\androtest\androtools\drozer> .\drozer.bat console connect

Could not find java. Please ensure that it is installed and on your PATH.
If this error persists, specify the path in the ~/.drozer_config file:
    [executables]
    java = C:\path\to\java
There was a problem connecting to the drozer Server.
Things to check:
 - is the drozer Server running?
 - have you set up appropriate adb port forwards?
 - have you specified the correct hostname and port with --server?
 - is the server protected with SSL (add an --ssl switch)?
 - is the agent protected with a password (add a --password switch)?
Debug Information:
[Errno 10061] Aucune connexion nÆa pu Ûtre Útablie car lÆordinateur cible lÆa expressÚment refusÚe

PS P:\androtest\androtools\drozer>

A nouveau « Could not find java. »
J’ai eu beau de refaire, comme suggéré par le message, le fichier « .drozer_Config » avec le chemin de l’exécutable java.
Rien à faire. Retour au point de départ.

Concernant l’ouverture des ports.
J’ai ouvert sur mon pare-feu le port ad hoc (31415)

Puis je teste :
Bienvenue dans le client Telnet Microsoft
Le caractère d’échappement est 'CTRL+$’
Microsoft Telnet> o 192.168.1.62:31415
Connexion à 192.168.1.62:31415...Impossible d’ouvrir une connexion à l’hôte, sur le port 23: Échec lors de la connexion
Microsoft Telnet>

Je teste aussi :

PS P:\androtest\sdk\platform-tools> netstat -abn | select-string -Pattern ":31415" 
PS P:\androtest\sdk\platform-tools>

(pour les linuxiens : netstat | grep -w 31415)

Conclusion : Malgré l’ouverture du port 31415 sur le pare-feu (Norton Internet Security) celui-ci reste obstinément fermé sur Windows 10.
J’en conclus que mon appli Drozer n’a pu être lancée comme le laissait présager le message d’erreur cité plus haut.

Je vais poursuivre mes investigations et vous tiendrai informés de l’état d’avancement.
Merci pour votre aide.

43
Utilisation des outils fournis par Kali linux / Re : Error setting monitor mode on wlan0 ?
« Dernier message par Snk le 26 février 2020 à 07:30:22 »
Et si c'est bloqué: (choisi celle que tu veux!)
rfkill unblock all
rfkill unblock wifi
44
Une présentation pour respecter les règles du forum serait bien quasar :)
45
Utilisation des outils fournis par Kali linux / Re : Error setting monitor mode on wlan0 ?
« Dernier message par ZeR0-@bSoLu le 26 février 2020 à 06:46:42 »
et tu as un truc dans ? :

rfkill list
De plus tu as fais une mauvaise commande d'après ce que je vois, tu as mis 'check kil' au lieu de 'check kill' (avec deux L)
46
Utilisation des outils fournis par Kali linux / Re : Error setting monitor mode on wlan0 ?
« Dernier message par Snk le 26 février 2020 à 00:04:50 »
Ton interface est up ou down?
Fais voir:
ifconfig -a
iwconfig
Une fois up envoies le retour de:
airmon-ng --verbose
47
Utilisation des outils fournis par Kali linux / Re : Error setting monitor mode on wlan0 ?
« Dernier message par cdevl37 le 25 février 2020 à 22:59:11 »
je reçois ceci avec : root@kali:~# iwconfig wlan0 mode monitor

Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Operation not permitted.
root@kali:~#
48
Utilisation des outils fournis par Kali linux / Re : Error setting monitor mode on wlan0 ?
« Dernier message par Snk le 25 février 2020 à 22:42:34 »
Si tu avait commencé par
airmon-ng check kill
Ou stopper network-manager, tu aurais gagné du temps...

Check kill, interface down, mode monitor, interface up.

Ps: penses à te servir de la fonction recherche du forum. Au moins 200 sujets t'expliquent cela...
49
Y'a une deuxième partie pour bien écraser saved rip (ou eip ) sinon je sais qu'il y a quelque imprécision mais mon article essayais de s'addresser au plus débutant voilà voilà :)
50
Utilisation des outils fournis par Kali linux / Re : Error setting monitor mode on wlan0 ?
« Dernier message par cdevl37 le 25 février 2020 à 22:05:28 »
j'ai bien le mode monitor :

root@kali:~# iw list
Wiphy phy1
        max # scan SSIDs: 9
        max scan IEs length: 2304 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Supported Ciphers:
                * WEP40 (00-0f-ac:1)
                * WEP104 (00-0f-ac:5)
                * TKIP (00-0f-ac:2)
                * CCMP-128 (00-0f-ac:4)
                * CMAC (00-0f-ac:6)
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * monitor


root@kali:~# sudo airmon-ng start wlan0

Found 2 processes that could cause trouble.
Kill them using 'airmon-ng check kill' before putting
the card in monitor mode, they will interfere by changing channels
and sometimes putting the interface back in managed mode

    PID Name
    436 NetworkManager
    562 wpa_supplicant

PHY     Interface       Driver          Chipset

phy1    wlan0           rtl8192eu       TP-Link TL WN823N RTL8192EU

Newly created monitor mode interface wlan0mon is *NOT* in monitor mode.
Removing non-monitor wlan0mon interface...

WARNING: unable to start monitor mode, please run "airmon-ng check kill"


je fais en suite ceci :

airmon-ng check kil

root@kali:~# airmon-ng check kil

Found 2 processes that could cause trouble.
Kill them using 'airmon-ng check kill' before putting
the card in monitor mode, they will interfere by changing channels
and sometimes putting the interface back in managed mode

    PID Name
    436 NetworkManager
    562 wpa_supplicant
Pages: « 1 2 3 4 5 6 7 8 9 10 »