Auteur Sujet: [Traité] Ecran noir après installation de drivers Nvidia  (Lu 6347 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Parazitenew
  • Nouvel inscrit
  • Messages: 2
  • +0/-0
Bonjour,

Hier j'ai installé Kali linux 64 sous VM Workstation, il marchait très bien. Pour un souci d'espace je voulais voir si je pouvais le faire fonctionner en surround avec mes 3 écrans alors j'ai voulu installé les driver de ma GTX650Ti. À l'aide de ce tuto:

Citer
Commencez par faire une mise à jour du système:

apt-get update
Et suivez la procédure suivante:

#on installe le bon linux header correspondant à celui de votre kernel
apt-get install linux-headers-$(uname -r)
 
#on desactive le driver Nouveau depuis le grub et on le met àjour
sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub
update-grub
 
#Driver Nvidia et nvidia-xconfig
apt-get install nvidia-kernel-dkms
apt-get install nvidia-xconfig
 
#On recreait un fichier config de Xorg
nvidia-xconfig
 
#On redemarre
reboot
Apres redémarrage, vérifiez ensuite la présence de l'accélération graphique avec cette commande:

1
glxinfo | grep rendering
Vous pouvez aussi vérifiez votre benchmark et classement avec le test des roues dentées:

1
glxgears

J'ai suivi les étapes jusqu'à "Reboot", à ce moment là, écran noir et curseur blanc en haut à gauche. Je ne peux rien faire à part relancer la machine virtuelle et retomber sur l'écran noir.

Etant donné qu'elle est virtuelle je pourrais toujours en créer une autre, mais j'ai installé tellement de packages (vsftp, ssh, eclipse-kde, eclipse-jdt, etc.) que ça m’ennuierais de tout refaire.

Merci.
« Modifié: 13 juin 2015 à 19:48:56 par Parazitenew »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3781
  • +270/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Ecran noir après installation de drivers Nvidia
« Réponse #1 le: 13 juin 2015 à 17:41:06 »
utilise cette méthode http://smxi.org/

cd /usr/local/bin && wget -Nc smxi.org/sgfxi && chmod +x sgfxi && sgfxi
« Modifié: 13 juin 2015 à 17:44:03 par coyotus »

Hors ligne Parazitenew
  • Nouvel inscrit
  • Messages: 2
  • +0/-0
Re : Ecran noir après installation de drivers Nvidia
« Réponse #2 le: 13 juin 2015 à 19:48:33 »
Merci pour la réponse. Je m’apprêtais à poster un commentaire, pour dire que j'ai opté pour une nouvelle VM. Entre temps j'ai désinstallé les drivers depuis l'écran de dépannage, mais ça n'a rien changé. J'ai choisi donc la solution radicale.

Merci.