Auteur Sujet: [réglé] kali 2.0: problème armitage  (Lu 13124 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne nonsolum

  • Membre régulier
  • **
  • Messages: 132
  • +7/-6
[réglé] kali 2.0: problème armitage
« le: 15 août 2015 à 21:04:34 »
Bonjour à tous,

Je suis en train de tester la nouvelle version 2.0 de kali et ses outils.
j'ai des soucis avec armitage tournant sur la denière distribution kali 2.0

Lorsque je lance armitage et que je me connecte

j'obtiens une erreur sur l'interface de connexion


org.mspack.Unpack Exception parse error
Armitage refuse alors, à l'issue de la progression de connexion, de s'ouvrir.

A noter lorsque je lance indépendamment d'Armitage, le framework metasploit tout se passe bien

Metasploit s'active sans erreur


« Modifié: 16 août 2015 à 16:44:54 par nonsolum »

Hors ligne Teeknofil

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 368
  • +28/-6
    • https://www.youtube.com/watch?v=R-zrnglcNuA&list=PLeu60bO1b61HE25L8Sz-cC7xjFupaSuWc
Re : kali 2.0: problème armitage
« Réponse #1 le: 15 août 2015 à 22:40:29 »
Tu a essayé de démarré metasploit comme on fait avec l’ancienne version de kali. Sinon l'histoire du parse sa pu l'erreur dans le code source, faudrait demandé à WarLocG qui connais le javas.

service metasploit start # http://fr.docs.kali.org/general-use-fr/demarrarer-metasploit-framework
Hacking Debutant - Black Hat Ackademy : https://www.udemy.com/draft/2365526/?couponCode=PROMOTION

Hors ligne WarLocG

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 474
  • +68/-0
  • Spé Code Python Java Bash
Re : kali 2.0: problème armitage
« Réponse #2 le: 15 août 2015 à 23:06:45 »
Citer
org.mspack.Unpack Exception parse error

Salut,

C'est l'erreur complète que tu donnes où tu as plus de précisions ? (En général les Exceptions donnent le fichier et la ligne où ca se produit, sauf si le dev a voulu sortir un petit message perso lors du catch de l'Exception - maintenant si il avait sorti "coucou" on aurait été bien avancé..)
Maintenant, je n'utilise pas encore kali 2.0, j'attend qu'elle gagne un peu en maturité avant de l'utiliser, je vais qd même jeter un oeil en vm sur cette erreur.
« Modifié: 15 août 2015 à 23:08:38 par WarLocG »
A lire avant de poser vos questions : http://www.linux-france.org/article/these/smart-questions/smart-questions-fr.html
Pour les questions de base sous debian : https://debian-facile.org/index-df.php
Veuillez utiliser la fonction Rechercher avant de poster.

Hors ligne Teeknofil

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 368
  • +28/-6
    • https://www.youtube.com/watch?v=R-zrnglcNuA&list=PLeu60bO1b61HE25L8Sz-cC7xjFupaSuWc
Re : kali 2.0: problème armitage
« Réponse #3 le: 15 août 2015 à 23:22:40 »
Mois je l'ai pas, une mise à jour peu t'être. Au passage je te reprend sur crisis des que j'ai installer mono sus mon système, je vais faire chauffer l'ide cette nuit.
Hacking Debutant - Black Hat Ackademy : https://www.udemy.com/draft/2365526/?couponCode=PROMOTION

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Re : kali 2.0: problème armitage
« Réponse #4 le: 16 août 2015 à 09:36:46 »
Tu a essayé de démarré metasploit comme on fait avec l’ancienne version de kali. Sinon l'histoire du parse sa pu l'erreur dans le code source, faudrait demandé à WarLocG qui connais le javas.

service metasploit start # http://fr.docs.kali.org/general-use-fr/demarrarer-metasploit-framework

Cette doc est pour la version 1 pour la version 2.0 il faut utiliser la commande

msfdbinit

Hors ligne nonsolum

  • Membre régulier
  • **
  • Messages: 132
  • +7/-6
Re : kali 2.0: problème armitage
« Réponse #5 le: 16 août 2015 à 11:46:06 »
Je n'ai pas de problème avec metasploit
Tout fonctionne correctement

Par contre lorsque je lance armitage (qui lance  de son côté metasploit) j'ai ceci



Au préalable j'avais bien démarré le service de la base de données
service postgresql start
« Modifié: 16 août 2015 à 12:00:52 par nonsolum »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : kali 2.0: problème armitage
« Réponse #6 le: 16 août 2015 à 13:04:20 »
Je ne me souviens pas avoir rencontré ce souci.

Essaye de réinstaller armitage.

Hors ligne nonsolum

  • Membre régulier
  • **
  • Messages: 132
  • +7/-6
Re : kali 2.0: problème armitage
« Réponse #7 le: 16 août 2015 à 16:44:12 »
Tout est OK
J'ai réinstallé armitage:
apt-get remove armitage
apt-get update
apt-get upgrade
apt-get install armitage

Et cette fois-ci armitage se lance et est fonctionnel

Toutefois je retrouve la même erreur non bloquante que j'avais à ma précédente version

Mais pas de problème ça marche

Donc affaire résolue
« Modifié: 16 août 2015 à 20:25:31 par nonsolum »

Hors ligne MrSable

  • Nouvel inscrit
  • Messages: 2
  • +0/-0
Re : [réglé] kali 2.0: problème armitage
« Réponse #8 le: 25 août 2015 à 00:52:10 »
Salut,

Alors je relance le sujet car j'ai un problème au niveau de réinstaller armitage, je tape : apt-get remove armitage
et voila ce qu'il me répond "E: Impossible de trouver le paquet armitage".

Merci d'avance ! :D

Hors ligne nonsolum

  • Membre régulier
  • **
  • Messages: 132
  • +7/-6
Re : [réglé] kali 2.0: problème armitage
« Réponse #9 le: 26 août 2015 à 13:45:06 »
@ MrSable

Essaye cela:

apt-get --reinstall install armitage

Hors ligne MrSable

  • Nouvel inscrit
  • Messages: 2
  • +0/-0
Re : [réglé] kali 2.0: problème armitage
« Réponse #10 le: 26 août 2015 à 13:57:31 »
Merci ça marche !