Auteur Sujet: Metasploit framework  (Lu 5118 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Futur

  • Idiot
  • Membre Junior
  • *
  • Messages: 20
  • +0/-2
Metasploit framework
« le: 06 novembre 2015 à 18:39:10 »
Hi,
après avoir installé Metasploit framework  je tente de démarrer  le service PostgreSQL, je n'ai aucun résultat et quand je tape ss -ant c'est le port 631 qui là au lieu de 5432.
comment remédier à tout ça?

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Metasploit framework
« Réponse #1 le: 06 novembre 2015 à 19:35:26 »
Le port 631 c'est le service cups

service postgresql status te répond quoi ?
« Modifié: 06 novembre 2015 à 19:36:57 par coyotus »

Hors ligne Futur

  • Idiot
  • Membre Junior
  • *
  • Messages: 20
  • +0/-2
Re : Metasploit framework
« Réponse #2 le: 07 novembre 2015 à 10:35:31 »
ci-joint le resultat

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Metasploit framework
« Réponse #3 le: 07 novembre 2015 à 13:48:32 »
Ben voilà, c'est bon ou est le problème ???

Hors ligne Futur

  • Idiot
  • Membre Junior
  • *
  • Messages: 20
  • +0/-2
Re : Metasploit framework
« Réponse #4 le: 07 novembre 2015 à 14:32:46 »
Metasploit n'arrive pas à ce connecter avec la base de donnée à cause du port. raison pour laquelle je veux changer le port decrit plus haut. ci-joint le resultat.

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Metasploit framework
« Réponse #5 le: 07 novembre 2015 à 15:59:16 »
msfdb init

...

Hors ligne Futur

  • Idiot
  • Membre Junior
  • *
  • Messages: 20
  • +0/-2
Re : Metasploit framework
« Réponse #6 le: 07 novembre 2015 à 16:20:12 »
A database appears to be already configured, skipping initialization

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Metasploit framework
« Réponse #7 le: 07 novembre 2015 à 16:44:47 »
db_connect te répond quoi ?

Hors ligne Futur

  • Idiot
  • Membre Junior
  • *
  • Messages: 20
  • +0/-2
Re : Metasploit framework
« Réponse #8 le: 07 novembre 2015 à 22:13:40 »
Aucun effet.
« Modifié: 07 novembre 2015 à 22:55:14 par Futur »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Metasploit framework
« Réponse #9 le: 08 novembre 2015 à 00:17:05 »
Pas d'erreur donc ?

essaye de vois que répond la commande  db_hosts
il devrait te répondre localhost normalement

sinon load bd_postgresql

Hors ligne Futur

  • Idiot
  • Membre Junior
  • *
  • Messages: 20
  • +0/-2
Re : Metasploit framework
« Réponse #10 le: 08 novembre 2015 à 13:35:00 »
ci-joint les resultats

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Metasploit framework
« Réponse #11 le: 08 novembre 2015 à 14:44:11 »
Je vois, je devrais faire des test sur ma machine pour vérifier si ce comportement est normal ou pas, car je n'ai pas encore testé metasploit sur la V2.0 de Kali.
Je te tien au jus, en att si quelqu'un d'autre a une idée.

Hors ligne Futur

  • Idiot
  • Membre Junior
  • *
  • Messages: 20
  • +0/-2
Re : Metasploit framework
« Réponse #12 le: 09 novembre 2015 à 11:31:18 »
j devrais avoir un status online je pense. le problème ne vient 'il pas ici (ci-joint la capture)?

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Metasploit framework
« Réponse #13 le: 10 novembre 2015 à 06:38:16 »
J'ai regardé cette doc https://wiki.postgresql.org/wiki/Using_pg_upgrade_on_Ubuntu/Debian et selon cette doc:
"By default, Ubuntu creates a database cluster named "main" with each installed version."
Essaye
pg_ctlcluster 9.4 main start
PS: je n'ai toujours pas eu le temps de faire un test moi même sur la version 2.0 de kali (taf oblige) donc je ne peux que voir ce que la doc dit sans vérifier.