Auteur Sujet: Reaver : Waiting for beacon from...  (Lu 9443 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Seifer

  • Nouvel inscrit
  • Messages: 4
  • +0/-0
Reaver : Waiting for beacon from...
« le: 07 décembre 2015 à 00:26:45 »
Bonjour tout le monde,

je rencontre un problème lors de l'utilisation de Reaver : Je reste coincé sur :
 root@kali:~# [+] Waiting for beacon from XX:XX:XX:XX:XX:XX
Détail de mon système (installé en dual boot avec un Windows 8.1) :
root@kali:~# uname -a
root@kali:~# Linux kali 4.0.0-kali1-amd64 #1 SMP Debian 4.0.4-1+kali2 (2015-06-03) x86_64 GNU/Linux

Les étapes que j'ai faites :

Dans un premier temps, utilisation de airmon-ng :
root@kali:~# airmon-ng check kill

Killing these processes:

  PID Name
  867 wpa_supplicant
  878 dhclient

root@kali:~# airmon-ng start wlan0

PHY Interface Driver Chipset

phy0 wlan0 iwlwifi Intel Corporation Wireless 3160 (rev 83)

(mac80211 monitor mode vif enabled for [phy0]wlan0 on [phy0]wlan0mon)
(mac80211 station mode vif disabled for [phy0]wlan0)

J’exécute ensuite la commande wash pour trouver mon réseau et voir si WPS est bien utilisé :
root@kali:~# wash -i wlan0mon

Wash v1.5.2 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>
mod by t6_x <t6_x@hotmail.com> & DataHead & Soxrok2212

BSSID                  Channel       RSSI       WPS Version       WPS Locked        ESSID
---------------------------------------------------------------------------------------------------------------
XX:XX:XX:XX:XX:XX       1            108        1.0               No                Toto
XX:XX:XX:XX:XX:XX       6            -123        1.0               No                Tata
XX:XX:XX:XX:XX:XX       6            -123        1.0               No                Blabla
00:11:22:33:44:55      11            -103        1.0               No                Galbadia
XX:XX:XX:XX:XX:XX       1            108        1.0               No                Lalala
XX:XX:XX:XX:XX:XX       1            108        1.0               No                Lolilo
^C

(Mon réseau est celui nommé Galbadia.)

Je poursuis avec la commande airodump-ng :
root@kali:~# airodump-ng wlan0mon

/* Pas mal de lignes vides dans mon terminal ici */

 CH 12 ][ Elapsed: 0 s ][ 2009-01-01 23:51                                         
                                                                                                             
 BSSID              PWR  Beacons    #Data, #/s  CH  MB   ENC  CIPHER AUTH ESSID
                                                                                                             
/* J'affiche que la ligne qui nous intéresse : celle de mon réseau */   
 00:11:22:33:44:55: -31        7        2    0  11  54e  WPA2 CCMP   PSK  Galbadia                 

Enfin, je lance reaver :
root@kali:~# reaver -i wlan0mon -b 00:11:22:33:44:55 -c 11 -vv

Reaver v1.5.2 WiFi Protected Setup Attack Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>
mod by t6_x <t6_x@hotmail.com> & DataHead & Soxrok2212

[+] Switching wlan0mon to channel 11
[+] Waiting for beacon from 00:11:22:33:44:55
/* Après une heure */
^C
[+] Nothing done, nothing to save.


Et voilà où je me retrouve bloqué.
J'ai pas mal cherché mais je ne suis pas parvenu à trouver une solution.

Toute aide est la bienvenue.

Cordialement,
Seifer

Hors ligne Teeknofil

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 368
  • +28/-6
    • https://www.youtube.com/watch?v=R-zrnglcNuA&list=PLeu60bO1b61HE25L8Sz-cC7xjFupaSuWc
Re : Reaver : Waiting for beacon from...
« Réponse #1 le: 07 décembre 2015 à 13:04:02 »
Malheureusement il n'y pas grand chose à faire. Reaver est patché sur toutes les nouvelles AP donc elles sont plus exploitable.
Hacking Debutant - Black Hat Ackademy : https://www.udemy.com/draft/2365526/?couponCode=PROMOTION

Hors ligne Seifer

  • Nouvel inscrit
  • Messages: 4
  • +0/-0
Re : Reaver : Waiting for beacon from...
« Réponse #2 le: 07 décembre 2015 à 13:20:20 »
Oh, donc lorsque le routeur n'est pas vulnérable il est quand même listé par wash et airodump-ng ?

Bloquer sur la ligne 'Waiting for beacon from...' est donc le comportement normal de reaver lorsqu'il tente d'attaquer un routeur patché ?


Y-a-t-il d'autres solutions que reaver susceptibles de fonctionner dans ce cas ?

Hors ligne Checkfx

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 401
  • +28/-3
  • ! Bazinga
    • Kali Québec
Re : Reaver : Waiting for beacon from...
« Réponse #3 le: 07 décembre 2015 à 17:05:59 »
reaver -i wlan0mon -b 00:11:22:33:44:55 -a -s -L  -v  -c 11

Avec ca , ca donne quoi ?

Hors ligne Seifer

  • Nouvel inscrit
  • Messages: 4
  • +0/-0
Re : Re : Reaver : Waiting for beacon from...
« Réponse #4 le: 07 décembre 2015 à 19:47:54 »
reaver -i wlan0mon -b 00:11:22:33:44:55 -a -s -L  -v  -c 11

Avec ca , ca donne quoi ?

Toujours la même chose, j'ai aussi essayé un réseau en WPA (et non WPA2) et rien ne change.

Peut-être que ça vient de ma carte réseau ?
Il est possible de tester dans une situation où on est sûr que ça devrait fonctionner ? Juste histoire de savoir si ça ne vient pas du réseau lui même.

Hors ligne kcdtv

  • Contributeur de Kali-linux.fr
  • Membre VIP
  • *****
  • Messages: 640
  • +60/-3
    • crack-wifi.com
Re : Reaver : Waiting for beacon from...
« Réponse #5 le: 08 décembre 2015 à 03:58:02 »
Tu habilites et active le WPS,  tu lances reaver avec ton PIN par défaut et tu verras comme ça marche.  :D
wash ne fait que te digérer les probes. Les probes ne révèlent que ce qu'elles révèlent et c'est selon le bon vouloir du fabricant.
Un router peut être visible dans wash  mais ne pas avoir le WPS en mode PIN dument activé...
ET il n'y a pas vraiment de moyen de le savoir (à part en regardant dans son interface)
Par exemple : Ce routeur est vulnérable est ceci est ce qu'il annonce dans les probes WPS
Extended capabilities: BSS Transition
WPA: * Version: 1
* Group cipher: TKIP
* Pairwise ciphers: CCMP TKIP
* Authentication suites: PSK
* Capabilities: 16-PTKSA-RC 1-GTKSA-RC (0x000c)
WPS: * Version: 1.0
* Wi-Fi Protected Setup State: 2 (Configured)
WMM: * Parameter version 1
* u-APSD
* BE: CW 15-1023, AIFSN 3
* BK: CW 15-1023, AIFSN 7
* VI: CW 7-15, AIFSN 1, TXOP 3008 usec
* VO: CW 3-7, AIFSN 1, TXOP 1504 usec
WPS version 1.0 et il n'est pas fermé : le routeur sort comme bojn dans wash (et dans ce cas c'est bon)

maintenant un autre router non vulnérable parceque le WPS en mode PIN n'est pas dument activé
WPA: * Version: 1
* Group cipher: CCMP
* Pairwise ciphers: CCMP
* Authentication suites: PSK
RSN: * Version: 1
* Group cipher: CCMP
* Pairwise ciphers: CCMP
* Authentication suites: PSK
* Capabilities: 1-PTKSA-RC 1-GTKSA-RC (0x0000)
WMM: * Parameter version 1
* BE: CW 15-1023, AIFSN 3
* BK: CW 15-1023, AIFSN 7
* VI: CW 7-15, AIFSN 2, TXOP 3008 usec
* VO: CW 3-7, AIFSN 2, TXOP 1504 usec
WPS: * Version: 1.0
* Wi-Fi Protected Setup State: 2 (Configured)
C'est exactement la même sortie au niveau des PROBES WPS (très peu d'info) et dans un cas le WPS mode PIN fonctionne vraiment et dans l'autre non...
Configuré ne veut pas dire Activé (enabled)


par rapport à ce que tu fais :
 : lances le scan airodump-ng avec filtre canal et bssid... ça évitera des éventuels conflits entre airodump-ng qui bloque sur un canal parceque reaver veut prendre la main sur un autre et tu éviteras les autres lignes
 
« Modifié: 08 décembre 2015 à 04:18:45 par kcdtv »