Auteur Sujet: airbase-ng : Network is down  (Lu 6199 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne f0cks

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
airbase-ng : Network is down
« le: 12 février 2016 à 17:35:09 »
Bonjour à tous,

J'essaye désespérément de faire fonctionner correctement l'outil "airbase-ng"...

J'utilise la dernière image arm de kali (sur une raspberry, bah ouais quand on peut faire des trucs marrants  :P):
Linux kali 4.0.9 #1 PREEMPT Thu Jan 28 21:18:26 CST 2016 armv6l GNU/Linux
(avec l'update et l'upgrade)

Lorsque je crée mon AP avec airbase-ng, tout semble bien se passer:
root@kali:~# airbase-ng -e TEST wlan0
16:14:23  Created tap interface at0
16:14:23  Trying to set MTU on at0 to 1500
16:14:23  Trying to set MTU on wlan0 to 1800
16:14:23  Access Point with BSSID 00:C0:CA:4F:15:44 started.
(C'est écrit "wlan0" mais ma carte est bien en moniteur)

J'arrive même à m'y connecter :
16:15:11  Client XX:XX:XX:XX:XX:XX associated (unencrypted) to ESSID: "TEST"
Seulement voilà, dès que j'essaye de générer du trafic avec l'appareil connecté (avec les règles iptables et le dhcp qui vont bien), BOOM :
read failed: Network is down
wi_read(): Network is down
Error: Got channel -1, expected a value > 0.
write failed: No such device or address
wi_write(): No such device or address
Error sending beacon!
write failed: No such device or address
wi_write(): No such device or address
write failed: No such device or address
wi_write(): No such device or address
write failed: No such device or address
wi_write(): No such device or address
write failed: No such device or address
wi_write(): No such device or address
write failed: No such device or address
wi_write(): No such device or address
(En fait la carte sort du mode moniteur ...)

J'ai essayé un peu tout ce que j'ai pu trouver sur le net à ce sujet:
  • Changer le câble USB pour en mettre plus court
  • Ne pas monter la carte en moniteur avec airmon-ng mais avec iwconfig
  • Préciser directement le canal utilisé au moment du passage en mode moniteur

Rien à faire, j'ai toujours ce problème...
Est ce que quelqu'un sait d'où vient ce problème et comment le régler ?
Vous êtes mon ultime recours  :D

Merci pour votre aide!

ps: Je vois que je l'ai pas précisé, ma carte wifi est une AWUS036H
PHY     Interface       Driver          Chipset

phy0   wlan0           rtl8187         Realtek Semiconductor Corp. RTL8187
« Modifié: 12 février 2016 à 18:07:59 par f0cks »

Hors ligne Sghost1405

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 488
  • +27/-1
  • Je suis ce que je sais.
Re : airbase-ng : Network is down
« Réponse #1 le: 12 février 2016 à 18:52:43 »
mais l'interface est bien wlan0 mais l'interface monitor c'est autre chose genre tape:

airmon-ng start wlan0
et tu verras quelle interface en monitoring il a créé, typiquement moi c'est wlan0mon, alors après j'utilise pour suivre mes wifis à portée avec Dump.
Airodump-ng wlan0mon
et ça fonctionne.

EDIT:

Si jamais j'ai fait un tuto sur le wifi et le crack PSK

http://www.kali-linux.fr/forum/index.php/topic,2569.0.html
« Modifié: 12 février 2016 à 18:56:30 par Sghost1405 »

Hors ligne f0cks

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
Re : airbase-ng : Network is down
« Réponse #2 le: 12 février 2016 à 18:58:38 »
@Sghost1405 Merci pour ta réponse.
Cependant je ne pense pas avoir de problème au niveau moniteur. En fait elle s'appelle "wlan0" parceque je la monte en moniteur comme ceci  :
ifconfig wlan0 down
iwconfig wlan0 mode monitor
ifconfig wlan0 up
Elle est en mode moniteur mais s'appelle toujours "wlan0"  ;)

Effectivement, si je la monte avec airmon-ng:
airmon-ng start wlan0Elle s’appellera "wlan0mon".

Mais j'ai essayé airbase dans les deux situations, et le problème reste le même  :-\

Attention, c'est avec airbase-ng que j'ai un problème : ma carte ne reste pas en mode moniteur.
Je n'ai aucun souci avec le reste des logiciels de la suite aircrack (aircrack, airodump etc ... fonctionnent sans problème).
« Modifié: 12 février 2016 à 19:09:46 par f0cks »

Hors ligne Sghost1405

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 488
  • +27/-1
  • Je suis ce que je sais.
Re : airbase-ng : Network is down
« Réponse #3 le: 12 février 2016 à 19:17:40 »
ah ok autant pour moi.

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : airbase-ng : Network is down
« Réponse #4 le: 12 février 2016 à 20:20:48 »
airmon-ng est un script qui non seulement passe la carte en mode monitor, mais aussi affiche si la carte est compatible, et surtout renomme l'interface pour bien afficher le mode.

Sur la dernière version il y a un bug qui ne renomme pas l'interface en wlan0 si on stoppe le mode monitor.

iwconfig ne fait que changer le mode, voilà pourquoi le nom de l'interface ne change pas

Hors ligne f0cks

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
Re : airbase-ng : Network is down
« Réponse #5 le: 15 février 2016 à 21:10:54 »
Bon je vois que ça n'a pas l'air de parler à quelqu'un ce problème  :-\

Je vais essayer d'approfondir un peu

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : airbase-ng : Network is down
« Réponse #6 le: 16 février 2016 à 06:31:46 »
J'ai pas compris le passage

Citer
Seulement voilà, dès que j'essaye de générer du trafic avec l'appareil connecté (avec les règles iptables et le dhcp qui vont bien), BOOM :

Comment tu génère le trafic et quel sont les rêgles iptables ????

Comme d'hab pas d'info pas de réponses ..... les lecteurs ne sont pas médium.

Hors ligne f0cks

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
Re : Re : airbase-ng : Network is down
« Réponse #7 le: 16 février 2016 à 18:54:38 »
Comment tu génère le trafic et quel sont les rêgles iptables ????
Pour générer du trafic je lance simplement une recherche google avec l'appareil connecté à l'AP.

Pour le serveur DHCP j'utilise cette configuration :

default-lease-time 600;
max-lease-time 7200;
subnet 192.168.2.0 netmask 255.255.255.0
{
        option subnet-mask 255.255.255.0;
        option broadcast-address 192.168.2.255;
        option domain-name-servers 8.8.8.8;
        option routers 192.168.2.1;
        range 192.168.2.20 192.168.2.60;
}

Que je lance avec la commande :
dhcpd -cf /etc/dhcp/dhcpd.conf
Et au préalable, je redirige le trafic provenant de l'interface virtuelle créée par airbase (at0) vers mon port ethernet (eth0) qui est connécté à internet (fonctionnel et testé avec des pings):
ifconfig at0 up
ifconfig at0 192.168.2.1 netmask 255.255.255.0
ifconfig at0 mtu 1500
iptables --flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain
iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
iptables --append FORWARD -j ACCEPT --in-interface at0
echo "1" > /proc/sys/net/ipv4/ip_forward

La je viens de constater qu'au lancement du serveur DHCP j'ai une sorte de warning à la fin:
Copyright 2004-2015 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Config file: /etc/dhcp/dhcpd.conf
Database file: /var/lib/dhcp/dhcpd.leases
PID file: /var/run/dhcpd.pid
Wrote 3 leases to leases file.
Listening on LPF/at0/00:c0:ca:4f:15:44/192.168.2.0/24
Sending on   LPF/at0/00:c0:ca:4f:15:44/192.168.2.0/24

No subnet declaration for eth0 (192.168.1.16).
** Ignoring requests on eth0.  If this is not what
   you want, please write a subnet declaration
   in your dhcpd.conf file for the network segment
   to which interface eth0 is attached. **

Je suis pas certain que le problème de sortie du mode moniteur vienne de là.

EDIT:

J'ai ajouté :
subnet 192.168.1.0 netmask 255.255.255.0
{
}
dans la conf dhcp (je comprends pas bien pourquoi j'ai du le redéfinir mais bon):
Internet Systems Consortium DHCP Server 4.3.3
Copyright 2004-2015 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Config file: /etc/dhcp/dhcpd.conf
Database file: /var/lib/dhcp/dhcpd.leases
PID file: /var/run/dhcpd.pid
Wrote 3 leases to leases file.
Listening on LPF/at0/00:c0:ca:4f:15:44/192.168.2.0/24
Sending on   LPF/at0/00:c0:ca:4f:15:44/192.168.2.0/24
Listening on LPF/eth0/b8:27:eb:10:48:bf/192.168.1.0/24
Sending on   LPF/eth0/b8:27:eb:10:48:bf/192.168.1.0/24
Sending on   Socket/fallback/fallback-net
Le warning a disparu mais le problème de déconnexion persiste...  :-\
« Modifié: 16 février 2016 à 19:15:58 par f0cks »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : airbase-ng : Network is down
« Réponse #8 le: 16 février 2016 à 19:23:41 »
quand tu te connecte, quel passerelle par défaut est renseignée ?

Ta carte est bien compatible, ton adaptateur Wi-Fi doit supporter le mode AP ou Master
« Modifié: 16 février 2016 à 19:25:13 par coyotus »

Hors ligne f0cks

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
Re : Re : airbase-ng : Network is down
« Réponse #9 le: 16 février 2016 à 19:36:04 »
quand tu te connecte, quel passerelle par défaut est renseignée ?
Quand je connecte mon appareil, j'ai cette configuration:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    0      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 at0

Ta carte est bien compatible, ton adaptateur Wi-Fi doit supporter le mode AP ou Master
D'après le manuel utilisateur, on peut la mettre en mode AP avec une IHM (page 25) donc "oui"  :)
http://www.allendale-stores.co.uk/docs/wifi/man/AWUS036H%20User%20Guide.pdf
« Modifié: 16 février 2016 à 19:42:34 par f0cks »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : airbase-ng : Network is down
« Réponse #10 le: 17 février 2016 à 06:27:58 »
Alors je vois pas, il faudrait que je monte un labo pour tester, mais actuellement j'ai trop de travail pour le faire.
Je passe la main.

Hors ligne f0cks

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
Re : airbase-ng : Network is down
« Réponse #11 le: 17 février 2016 à 11:39:41 »
Pas de souci.
Je commence à croire de plus en plus que c'est un problème avec airbase-ng (peut être la version ARM).
Je pense que je vais ouvrir un ticket chez aircrack pour voir un peu ce qu'ils me répondent.
Merci pour ton aide en tout cas.