Auteur Sujet: depot kali install impossible  (Lu 5100 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne dumdum

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
depot kali install impossible
« le: 27 février 2016 à 12:20:34 »
Bonjour
 Voici ma version de kali :

3.14-kali1-686-pae
et ce que renvoie lsb_release -a :
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux Kali Linux 1.0.9
Release:   Kali Linux 1.0.9
Codename:   n/a.

Mon problème : je ne peux plus rien installer avec des dépendances non satisfaites, et un message d'erreur de ce type :
Les paquets suivants contiennent des dépendances non satisfaites :
 libstdc++6 : Casse: dff (<= 1.3.0+dfsg.1-4.1+b3) mais 1.3.0+dfsg.1-4kali1 devra être installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Voici mon sources.list ( je n'ai gardé que le dernier et mis un # sur les autres sources car ça bloquait...mais ça bloque toujours malgré l'update et l'upgrade.

#

#
# deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot i386 LIVE/INSTALL Binary 20141002-12:53]/ kali contrib main non-free
#
# # Security updates
# deb http://security.kali.org/kali-security kali/updates main contrib non-free

# deb http://http.kali.org/kali kali main non-free contrib
# deb-src http://http.kali.org/kali kali main non-free contrib

## Security updates
# deb http://security.kali.org/kali-security kali/updates main contrib non-free

## Depots 12_11_15
# deb http://http.kali.org/kali sana main non-free contrib
# deb http://security.kali.org/kali-security/ sana/updates main contrib non-free

# deb http://deb.torproject.org/torproject.org wheezy main
# deb http://deb.torproject.org/torproject.org wheezy main


deb http://http.kali.org/kali kali-rolling main contrib non-free


Merci de m'aider !!!  :-[





Hors ligne Sghost1405

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 488
  • +27/-1
  • Je suis ce que je sais.
Re : depot kali install impossible
« Réponse #1 le: 27 février 2016 à 12:42:51 »
Tu as essayer la procédure de mise à niveau de kali rolling?

Hors ligne dumdum

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
Re : depot kali install impossible
« Réponse #2 le: 28 février 2016 à 10:55:33 »
Bonjour
D'abord merci de me répondre.

J'ai essayé le dépot kali rolling. Puis update et upgrade mais sans succès.

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3793
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : depot kali install impossible
« Réponse #3 le: 28 février 2016 à 12:17:20 »
poste le retour complet de la commande "apt-get update"

Hors ligne dumdum

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
Re : depot kali install impossible
« Réponse #4 le: 28 février 2016 à 13:48:33 »
Bonjour,
Voici ce que cela donne :


Réception de : 1 http://http.kali.org kali-rolling Release.gpg [819 B]
Réception de : 2 http://http.kali.org kali-rolling Release [19,4 kB]
Réception de : 3 http://http.kali.org kali-rolling/main i386 Packages [13,4 MB]
Ign http://http.kali.org kali-rolling/contrib Translation-fr_FR       
Ign http://http.kali.org kali-rolling/contrib Translation-fr                   
Ign http://http.kali.org kali-rolling/contrib Translation-en           
Ign http://http.kali.org kali-rolling/main Translation-fr_FR           
Ign http://http.kali.org kali-rolling/main Translation-fr             
Ign http://http.kali.org kali-rolling/main Translation-en                     
Ign http://http.kali.org kali-rolling/non-free Translation-fr_FR               
Ign http://http.kali.org kali-rolling/non-free Translation-fr         
Ign http://http.kali.org kali-rolling/non-free Translation-en                 
Réception de : 4 http://http.kali.org kali-rolling/contrib i386 Packages [87,5 kB]
Réception de : 5 http://http.kali.org kali-rolling/non-free i386 Packages [135 kB]
13,6 Mo réceptionnés en 3min 23s (66,9 ko/s)                                   
Lecture des listes de paquets... Fait
W: Ignoring Provides line with DepCompareOp for package libjpeg62
W: Ignoring Provides line with DepCompareOp for package php-psr-http-message-implementation
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.

Merci.

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3793
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : depot kali install impossible
« Réponse #5 le: 28 février 2016 à 18:02:12 »
apparemment tu ne peut pas passer d'une moto directement en rolling
voir: http://stackoverflow.com/questions/31280032/w-ignoring-provides-line-with-depcompareop-for-package

Soit tu réinstalle, soit tu passe par un upgrade en sana et ensuite d'une sans vers une rolling.

Hors ligne dumdum

  • Nouvel inscrit
  • Messages: 8
  • +0/-0
Re : depot kali install impossible
« Réponse #6 le: 28 février 2016 à 18:31:07 »
Ok, merci pour ta recherche.
Je vais essayer.  ;)