Auteur Sujet: E: Impossible de trouver le paquet libssh  (Lu 39277 fois)

0 Membres et 2 Invités sur ce sujet

Hors ligne HassToub

  • Membre Junior
  • *
  • Messages: 12
  • +1/-1
E: Impossible de trouver le paquet libssh
« le: 30 mai 2016 à 18:22:25 »
Bonjour
Je suis entrain d'essayé l'outil Hydra dans le but d'un pentesting, j'ai tapé cette commande sur mon Kali 1.0 " hydra -l user -P /usr/share/wordlists/rockyou.txt ftp://192.168.0.1 " elle m'a affiché ce message d'erreur " [ERROR] Compiled without LIBSSH v0.4.x support, module is not available! ", par conséquent j'ai essayé d'installer le paquet LIBSSH, mais malheureusement ça n'a pas marché " E: Impossible de trouver le paquet LIBSSH ", quelqu'un peut m'aider s'il vous plait ? merci par avance.

Hors ligne LinK

  • Membre régulier
  • **
  • Messages: 146
  • +14/-0
Re : E: Impossible de trouver le paquet libssh
« Réponse #1 le: 31 mai 2016 à 12:39:42 »
C'est normal car aucun paquet LIBSSH existe  :-\ , ce qu'il faut faire c'est de l'installer depuis la source

wget https://red.libssh.org/attachments/download/195/libssh-0.7.3.tar.xz tar xvf libssh-0.7.3.tar.xzmkdir -p build/libssh
cd build/libssh
cmake -DCMAKE_INSTALL_PREFIX=/usr/local/ ~/libssh-0.7.3 make install
« Modifié: 31 mai 2016 à 15:38:53 par LinK »

Hors ligne HassToub

  • Membre Junior
  • *
  • Messages: 12
  • +1/-1
Re : E: Impossible de trouver le paquet libssh
« Réponse #2 le: 31 mai 2016 à 15:02:56 »
Bonjour
Merci infiniment pour votre réponse et interet, j'ai tapé le code voilà ce qui m'a affiché.

Hors ligne LinK

  • Membre régulier
  • **
  • Messages: 146
  • +14/-0
Re : E: Impossible de trouver le paquet libssh
« Réponse #3 le: 31 mai 2016 à 15:33:26 »
Install cmake avec apt-get , mais avant fait un apt-get update

Hors ligne LinK

  • Membre régulier
  • **
  • Messages: 146
  • +14/-0
Re : Re : E: Impossible de trouver le paquet libssh
« Réponse #4 le: 31 mai 2016 à 15:40:30 »
cmake -DCMAKE_INSTALL_PREFIX=/usr/local/ ~/libssh-0.7.3

J'avais fait une erreur dans cette ligne , libssh-0.7.3 au lieu de libssh-0.6

Hors ligne HassToub

  • Membre Junior
  • *
  • Messages: 12
  • +1/-1
Re : E: Impossible de trouver le paquet libssh
« Réponse #5 le: 31 mai 2016 à 17:44:47 »
Je m'excuse de t'avoir dérangé avec mes questions, mais je viens de constater que j'ai un probléme au niveau de la connexion wifi, il marchait hier mais aujourd'hui elle fonctionnait plus, je crois par ce que hier j'ai modifié sources.list. qu'est ce qu'il faut faire à votre avis merci encore une autre fois

Hors ligne LinK

  • Membre régulier
  • **
  • Messages: 146
  • +14/-0
Re : E: Impossible de trouver le paquet libssh
« Réponse #6 le: 31 mai 2016 à 17:55:10 »
Premierement quelle version de Kali ulises-tu ?

Hors ligne HassToub

  • Membre Junior
  • *
  • Messages: 12
  • +1/-1
Re : E: Impossible de trouver le paquet libssh
« Réponse #7 le: 31 mai 2016 à 17:57:26 »
Kali 1.0 sur VirtualBox

Hors ligne LinK

  • Membre régulier
  • **
  • Messages: 146
  • +14/-0
Re : E: Impossible de trouver le paquet libssh
« Réponse #8 le: 31 mai 2016 à 18:02:28 »
Faut aussi changer tes source list

deb http://http.kali.org/kali sana main non-free contrib
deb http://security.kali.org/kali-security/ sana/updates main contrib non-free

PS : Envoie moi un message en privé pour le probleme de connexion ou ouvre un autre sujet.

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : E: Impossible de trouver le paquet libssh
« Réponse #9 le: 31 mai 2016 à 20:29:03 »
Gros soupir ??? apprenez les bases de debian par pitié ou allez poser vos question sur doudoulinux...


Hors ligne HassToub

  • Membre Junior
  • *
  • Messages: 12
  • +1/-1
Re : Re : E: Impossible de trouver le paquet libssh
« Réponse #10 le: 01 juin 2016 à 12:19:15 »
Gros soupir ??? apprenez les bases de debian par pitié ou allez poser vos question sur doudoulinux...


Gros soupir ??? Apprenez à repondre ceux qui posent des questions surtout les débutants...
« Modifié: 01 juin 2016 à 14:39:47 par HassToub »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Re : Re : E: Impossible de trouver le paquet libssh
« Réponse #11 le: 01 juin 2016 à 17:32:20 »
Gros soupir ??? Apprenez à repondre ceux qui posent des questions surtout les débutants...
Quand on débute on commence avec une debian ou on apprend les bases de debian.

C'est comme en bagnole tu achètes pas une formule 1 pour demander ou se trouvent l'embrayage.

PS: je pense que je vais désactiver mon compte sur ce forum, y'a trop de c... qui veulent que ça viennent tout cuit dans leur bec

Et après ça frime "moi y'en a être un gros haxor, je comprend rien j'ai suivi des tutos ou j'ai juste copier collé bêttement des commande, chui tro for"

Hors ligne HassToub

  • Membre Junior
  • *
  • Messages: 12
  • +1/-1
Re : Re : Re : Re : E: Impossible de trouver le paquet libssh
« Réponse #12 le: 01 juin 2016 à 18:32:46 »
Gros soupir ??? Apprenez à repondre ceux qui posent des questions surtout les débutants...
Quand on débute on commence avec une debian ou on apprend les bases de debian.

C'est comme en bagnole tu achètes pas une formule 1 pour demander ou se trouvent l'embrayage.

PS: je pense que je vais désactiver mon compte sur ce forum, y'a trop de c... qui veulent que ça viennent tout cuit dans leur bec

Et après ça frime "moi y'en a être un gros haxor, je comprend rien j'ai suivi des tutos ou j'ai juste copier collé bêttement des commande, chui tro for"
Merci pour ta politesse et gentillesse le trop fort, heureusement j'ai pu trouvé la solution sans avoir besoin de ton aide, ce qui prouve que je fais pas parti de ceux qui veulent que ça viennent tout cuit dans leur bec.

Hors ligne HassToub

  • Membre Junior
  • *
  • Messages: 12
  • +1/-1
Re : E: Impossible de trouver le paquet libssh
« Réponse #13 le: 01 juin 2016 à 18:34:18 »
Pour ceux qui peuvent avoir besoin de la solution, là voilà :

apt-get purge hydra
apt-get install cmake libssl-dev

cd /usr/local/src
wget http://www.libssh.org/files/0.4/libssh-0.4.8.tar.gz
tar zxf libssh-0.4.8.tar.gz
cd libssh-0.4.8
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Debug -DWITH_SSH1=ON ..
make
make install

cd /usr/local/src
wget http://freeworld.thc.org/releases/hydra-6.3-src.tar.gz --no-check-certificate
tar zxf hydra-6.3-src.tar.gz
cd hydra-6.3-src
./configure
make
make install
« Modifié: 01 juin 2016 à 18:36:02 par HassToub »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3794
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : E: Impossible de trouver le paquet libssh
« Réponse #14 le: 01 juin 2016 à 19:36:59 »
Pour ceux qui veulent une solution sans passer par le mode bourrin en recompilant libssh (présent dans les dépôts) et sans recompiler hydra (également présent dans les dépôts) il suffit de vérifier la présence du paquet libssh-4

car comme vous pouvez le voir sur ma capture d'écran ci-dessous cela fonctionne très bien chez moi



j'avais donné une piste sur la capture d'écran d'un de mes post précédent mais vu qu'on préfère l'ignorer, j'abandonne ce forom de merde ou il faut encore s'excuser d'être malpoli auprès de noob qui ne se sortent pas les doigt du cul et je serais bien curieux de savoir ou tu as trouvé ta soluce, car je parie que tu ne la pas sorti de ta cervelle.

Sur ce je vais cloturer mon compte sur le forum car vous me les briser menu, et mon dieu que je regrette l'époque ou backtrack était basé sur slax sans installeur automatique, ça nous épargnait tout les kiddies qui veulent se la jouer hacker en installant une distro prémachée.