Auteur Sujet: [Résolu] Activer gestionnaire de connection au démarage  (Lu 15755 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Maeva
  • Membre Junior
  • *
  • Messages: 10
  • +1/-0
Bonjour à tous,

Suite à je ne sais pas trop quoi, le système démarre en mode ligne de commande, me demandant login et password... Une fois connectée je me connecte au bureau (cinnamon) et lancant la commande :
startx
Après cela tout est normal, sans problème, mais j'aimerais activer le gestionnaire de connection par défaut. J'ai essayer de suprimer xinit, qui d'après ce que je sais serait responsable de startx, mais je reste jusque bloquée après le login...
Mais quand la session se met en vielle, l'écran de re-connexion est normal...

Pouvez vous m'aidez s'il vous plait ?

Merci d'avance

Maëva
« Modifié: 13 juin 2016 à 14:58:18 par Maeva »

Hors ligne WarLocG

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 477
  • +70/-0
  • Spé Code Python Java Bash
Re : Activer gestionnaire de connection au démarage
« Réponse #1 le: 09 juin 2016 à 00:18:05 »
Bonjour,

Qu'as-tu supprimé exactement ? le dossier /etc/X11/xinit ? Le paquet xinit ? Tu utilises quelle version de kali ?
La commande update-alternatives --config x-<tab><tab> (deux appuis sur la touche tabulation) te montre-t-il quelque chose ressemblant à :
Citer
warlocg@linux:~$ sudo update-alternatives --config x-
x-session-manager    x-terminal-emulator  x-window-manager     x-www-browser
As-tu un gestionnaire de session de déjà installé ? Ca devrait être gdm3 ou lightdm par défaut sous kali?
Citer
warlocg@linux:~$ dpkg -l | awk '{print $1" "$2}' | egrep '^[cipru]{2}\ (.*dm3?|slim)$'
ii mdm
ii slim
(Il y a encore moyen d'affiner la recherche mais c'est déjà pas mal avec cela)

Vérifie avec systemctl status gdm3.service et systemctl status lightdm.service
Tente de le réinstaller via apt-get install -reinstall gdm3 (ou lightdm) voir si ca va te recréer des fichier que tu aurais effacé.
Pour remettre ton gestionnaire de session tu peux également tenter un dpkg-reconfigure gdm3 (ou lightdm selon ton gestionnaire de session), tu devrais tomber sur un menu ncurse te permettant de choisir parmi tes gestionnaire de session installé.

Ca fait beaucoup de questions mais je suis un peu fatigué et pas trop inspiré ce soir, alors je vais commencer par tenter de voir plus clair sur ton souci avec ces pistes-là. Je regarderai encore demain avec l'esprit plus limpide.

Je n'utilise plus kali (j'ai migré de kali 1.1.0 vers debian 8 ), également j'utilise un gestionnaire de session différent de ces deux là donc j'attendrai de lire tes retours avant d'aller plus loin.

Bien à toi.
« Modifié: 09 juin 2016 à 00:23:27 par WarLocG »
A lire avant de poser vos questions : http://www.linux-france.org/article/these/smart-questions/smart-questions-fr.html
Pour les questions de base sous debian : https://debian-facile.org/index-df.php
Veuillez utiliser la fonction Rechercher avant de poster.

Hors ligne Maeva
  • Membre Junior
  • *
  • Messages: 10
  • +1/-0
Re : Activer gestionnaire de connection au démarage
« Réponse #2 le: 09 juin 2016 à 20:25:28 »
Bonjour,

Merci de ta réponse.  Je suis sous Kali-rolling-1.
J'avais supprimé le paquet xinit, mais je l'ai ré-installé car c'était la seule façon de me connecter. Le dossier /ect/x11/xinit est toujours présent avec les deux fichiers xinitrc et xserverrc .

La comande update-alternatives --config x me donne exactement :
Citer
x-cursor-theme       x-session-manager    x-www-browser
xdvi.bin             x-terminal-emulator 
xjc                  x-window-manager   

La commande  dpkg -l | awk '{print $1" "$2}' | egrep '^[cipru]{2}\ (.*dm3?|slim)$' me renvoie:
Citer
maeva@kali-maeva:~$  dpkg -l | awk '{print $1" "$2}' | egrep '^[cipru]{2}\ (.*dm3?|slim)$'
rc gdm3

Etrangement, synaptic m'indique que gdm3 (par défaut) n'est pas installé ...

Pourtant systemctl status gdm3.service renvoie:
Citer
maeva@kali-maeva:~$ systemctl status gdm3.service
● gdm3.service - LSB: GNOME Display Manager
   Loaded: loaded (/etc/init.d/gdm3; generated; vendor preset: disabled)
   Active: active (exited) since jeu. 2016-06-09 15:19:45 CEST; 3h 34min ago
     Docs: man:systemd-sysv-generator(8 )
  Process: 783 ExecStart=/etc/init.d/gdm3 start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/gdm3.service
Du coup je vais essayer de l'installer via synaptic, puis le réinstaller par apt-get et dpkg ...
Merci beaucoup de ta réponse, c'est déjà beaucoup ! Je vais essayer tout ça.

Maëva

Hors ligne WarLocG

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 477
  • +70/-0
  • Spé Code Python Java Bash
Re : Activer gestionnaire de connection au démarage
« Réponse #3 le: 09 juin 2016 à 23:35:06 »
Citer
La commande  dpkg -l | awk '{print $1" "$2}' | egrep '^[cipru]{2}\ (.*dm3?|slim)$' me renvoie:
Citer
    maeva@kali-maeva:~$  dpkg -l | awk '{print $1" "$2}' | egrep '^[cipru]{2}\ (.*dm3?|slim)$'
    rc gdm3

Etrangement, synaptic m'indique que gdm3 (par défaut) n'est pas installé ...
rc indique que le paquet est 'removed' donc supprimé mais pas purgé, il reste encore des résidus de configuration. Donc juste le réinstaller devrais je pense régler ton soucis.

Je ne sais pas trop comment fonctionne les script utilisé par systemctl non plus, il semblerait que les <service>.service ne disparaissent pas à la suppression, j'ai moi même encore la commande qui fonctionne avec gdm3.service. Mais ils ne doivent pas s'appeler comme tel car locate ne me trouve aucun fichier gdm3.service, c'est donc géré autrement.
Citer
warlocg@linux:~$ sudo systemctl status gdm3.service
Password (warlocg):
● gdm3.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
Le <tab><tab> me repère le gdm3.service et même pour xdm.service bien qu'aucun des deux ne soient installés. Ca fait un mystère à élucider, ca motive à chercher (et comme ca je purge ce que je n'ai pas besoin par la même occasion) :)

Ravi d'avoir pu aider.

Bien à toi.
A lire avant de poser vos questions : http://www.linux-france.org/article/these/smart-questions/smart-questions-fr.html
Pour les questions de base sous debian : https://debian-facile.org/index-df.php
Veuillez utiliser la fonction Rechercher avant de poster.

Hors ligne Maeva
  • Membre Junior
  • *
  • Messages: 10
  • +1/-0
Re : Activer gestionnaire de connection au démarage
« Réponse #4 le: 13 juin 2016 à 14:54:14 »
Bonjour,

En fait l'installation de gdm3 avait simplement bloqué Kali au démarrage (juste après la ligne "dev/sda5 clean, ......./....... blocs" )
Du coup en recovery mode j'ai suprimé le pacquet gdm3, et installé lightdm à la place...

Et tout marche nickel ! Du coup je vais laisser comme ça, même si j'ai pas tout percuté...  je vais purger tout ça !

En tout cas merci beaucoup de ton aide,
Cordialement,

Maëva