Auteur Sujet: [en cours] Problème de connexion avec le D-Link DWA 131  (Lu 7755 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Loufiat

  • Nouvel inscrit
  • Messages: 4
  • +0/-0
[en cours] Problème de connexion avec le D-Link DWA 131
« le: 19 novembre 2013 à 18:12:21 »
Bonsoir, je fais tourner Kali grâce à VirtualBox, et j'ai un petit problème. J'ai paramétré mon dongle (un D-Link DWA 131) dans la machine afin de l'utiliser comme carte réseau. Mon problème vient du fait que quand je tape airmon-ng dans la console il ne la détecte pas.

Je suis nouveau dans ce domaine, et j'ai passé la journée à essayer de configurer Backtrack5 pour résoudre la même erreur, en vain. J'espère vraiment que vous pourrez m'aider.
« Modifié: 19 novembre 2013 à 22:07:16 par admin »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3799
  • +266/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Problème de connexion avec le D-Link DWA 131
« Réponse #1 le: 19 novembre 2013 à 18:19:40 »
tu la vois avec lsusb

donne la réponse de http://doc.ubuntu-fr.org/wificheck

Hors ligne Loufiat

  • Nouvel inscrit
  • Messages: 4
  • +0/-0
Re : Problème de connexion avec le D-Link DWA 131
« Réponse #2 le: 19 novembre 2013 à 18:35:13 »
Désolé de demander ça mais je démarre vraiment. J'ai téléchargé le fichier pour lancer le diagnostique, mais je ne peux pas le faire dans la VB, comment est-ce que je place le fichier de sorte qu'il soit dans la VB?

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3799
  • +266/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Problème de connexion avec le D-Link DWA 131
« Réponse #3 le: 19 novembre 2013 à 18:49:22 »
Ben télécharge le depuis la machine virtuelle.

Wang Xiang Zhai

  • Invité
Re : Problème de connexion avec le D-Link DWA 131
« Réponse #4 le: 19 novembre 2013 à 19:04:28 »
bonsoir,

@Loufiat

Citer
je fais tourner Kali grâce à VirtualBox

si j'ai bien compris tu as installé kali en VB en ayant Backtrack5 comme machine hôte ?

Hors ligne Loufiat

  • Nouvel inscrit
  • Messages: 4
  • +0/-0
Re : Problème de connexion avec le D-Link DWA 131
« Réponse #5 le: 19 novembre 2013 à 19:20:42 »
>>    cat /etc/lsb-release


>>    lsusb

Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

>>    lspci -k -nn | grep -A 3 -i net

00:03.0 Ethernet controller [0200]: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] [1022:2000] (rev 10)
   Subsystem: Advanced Micro Devices [AMD] PCnet - Fast 79C971 [1022:2000]
   Kernel driver in use: pcnet32
00:04.0 System peripheral [0880]: InnoTek Systemberatung GmbH VirtualBox Guest Service [80ee:cafe]
00:05.0 Multimedia audio controller [0401]: Intel Corporation 82801AA AC'97 Audio Controller [8086:2415] (rev 01)
   Subsystem: Intel Corporation Device [8086:0000]

>>    sudo lshw -C network


>>    lsmod

Module                  Size  Used by
binfmt_misc            12958  1
dm_crypt               18373  0
dm_mod                 63778  1 dm_crypt
joydev                 17318  0
snd_intel8x0           30899  2
snd_ac97_codec        106792  1 snd_intel8x0
snd_pcm                68524  2 snd_ac97_codec,snd_intel8x0
snd_page_alloc         13019  2 snd_intel8x0,snd_pcm
snd_timer              22813  1 snd_pcm
psmouse                69191  0
snd                    53078  8 snd_ac97_codec,snd_intel8x0,snd_timer,snd_pcm
soundcore              13027  1 snd
i2c_piix4              12661  0
processor              28456  0
parport_pc             22410  0
i2c_core               24042  1 i2c_piix4
parport                31902  1 parport_pc
thermal_sys            22342  1 processor
evdev                  17651  5
ac97_bus               12511  1 snd_ac97_codec
serio_raw              12941  0
ac                     12625  0
button                 12945  0
squashfs               31335  1
loop                   22955  2
aufs                  147316  154
nls_utf8               12457  1
isofs                  35130  1
hid_generic            12386  0
usbhid                 40793  0
hid                    81617  2 hid_generic,usbhid
sg                     26096  0
sr_mod                 21946  1
sd_mod                 40550  0
cdrom                  35213  1 sr_mod
crc_t10dif             12349  1 sd_mod
ata_generic            12491  0
ohci_hcd               26687  0
ata_piix               29672  1
ahci                   25061  0
libahci                22919  1 ahci
ehci_hcd               40532  0
microcode              30457  0
libata                141636  4 ahci,libahci,ata_generic,ata_piix
scsi_mod              162399  4 sg,libata,sd_mod,sr_mod
pcnet32                35861  0
usbcore               134001  3 ohci_hcd,ehci_hcd,usbhid
usb_common             12355  1 usbcore
mii                    12676  1 pcnet32
[/code]

>>    iwconfig


>>    ifconfig -a

eth0      Link encap:Ethernet  HWaddr 08:00:27:06:39:28 
          inet6 addr: fe80::a00:27ff:fe06:3928/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4956 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3302 errors:1 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:5944766 (5.6 MiB)  TX bytes:301918 (294.8 KiB)
          Interrupt:19 Base address:0xd020

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1280 (1.2 KiB)  TX bytes:1280 (1.2 KiB)


>>    sudo iwlist scan


>>    uname -r -m

3.7-trunk-amd64 x86_64

>>    cat /etc/network/interfaces

auto lo
iface lo inet loopback


>>    nm-tool


NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            pcnet32
  State:             disconnected
  Default:           no
  HW Address:        08:00:27:06:39:28

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         on



>>    sudo rfkill list



Desole pour le temps. Et non la machine hote est sous windows 7.

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3799
  • +266/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Problème de connexion avec le D-Link DWA 131
« Réponse #6 le: 19 novembre 2013 à 19:46:16 »

Wang Xiang Zhai

  • Invité
Re : Problème de connexion avec le D-Link DWA 131
« Réponse #7 le: 19 novembre 2013 à 20:34:10 »
vu la réponse:

Citer
Desole pour le temps. Et non la machine hote est sous windows 7.

merci  Loufiat.

Hors ligne Loufiat

  • Nouvel inscrit
  • Messages: 4
  • +0/-0
Re : Problème de connexion avec le D-Link DWA 131
« Réponse #8 le: 19 novembre 2013 à 20:51:02 »
Alors j'ai testé ton tuto, au moment de devoir aller dans le répertoire du cd virtuel j'obtiens une erreur "no such file or directory"