Auteur Sujet: [TUTO] lire videos flash player sur kali linux 64 bits.  (Lu 16670 fois)

0 Membres et 1 Invité sur ce sujet

Wang Xiang Zhai

  • Invité
[TUTO] lire videos flash player sur kali linux 64 bits.
« le: 17 novembre 2013 à 00:43:49 »
fonctionne en liveCD et liveUSB aussi.

bonjour,

je passe un peu de temps sur kali linux 64 bits.

faut bien tuer ce temps !

pour pouvoir lire les videos flash:

j'ai télécharger flash player ici: http://get.adobe.com/fr/flashplayer/

Linux 64-bit, Français, Firefox >  .tar.gz pour autres versions linux > télécharger

reçu install_flash_player_11_linux.x86_64.tar.gz  dans /root par défaut:

je décompresse:

root@kali:~# ls
Desktop  install_flash_player_11_linux.x86_64.tar.gz  usr
root@kali:~# tar -zxvf install_flash_player_11_linux.x86_64.tar.gz

tar -zxvf install_flash_player_11_linux.x86_64.tar.gz
entrée.

j'obtiens libflashplayer.so et readme.txt dans /root

root@kali:~# ls
Desktop                                      libflashplayer.so  usr
install_flash_player_11_linux.x86_64.tar.gz  readme.txt
root@kali:~#

j'autorise libflashplayer.so à être exécuté comme un programme (peut être facultatif).

clic droit sur libflashplayer.so > propriétés > permissions > cocher autoriser l'exécution du fichier comme un programme.

je copie, colle libflashplayer.so dans /usr/lib/mozilla/plugins

cp libflashplayer.so /usr/lib/mozilla/plugins
ça marche, vous me direz ce que vous .... !?

@+

« Modifié: 19 novembre 2013 à 22:08:38 par admin »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre VIP
  • *****
  • Messages: 3708
  • Notoriété : +249/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #1 le: 17 novembre 2013 à 09:28:09 »
J'avais modifié un script destiné à backtrack à l'époque, il devrait fonctionner avec Kali je pense, à tester.

#!/bin/bash

#
#  BTflash.sh


#  This program is free software; you can redistribute it and/or modify
#  it under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.

#  This program is distributed in the hope that it will be useful,
#  but WITHOUT ANY WARRANTY; without even the implied warranty of
#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#  GNU General Public License for more details.

#  You should have received a copy of the GNU General Public License
#  along with this program; if not, write to the Free Software
#  Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston,
#  MA 02110-1301, USA.
#
#Source Alien And abortSecurit-E Modified by IceF0x

echo ''' ____ _____ __ _           _     
| __ )_   _/ _| | __ _ ___| |__ 
|  _ \ | || |_| |/ _` / __|  _ \
| |_) || ||  _| | (_| \__ \ | | |
|____/ |_||_| |_|\__,_|___/_| |_|
'''
echo "[+] Valid on 32 & 64 bits GNOME BACKTRACK5 R3"

echo "[+] Clean Old Player"

apt-get purge flashplugin-nonfree flashplugin-installer gnash gnash-common mozilla-plugin-gnash swfdec-mozilla

rm -f /usr/lib/firefox/plugins/*flash*
rm -f /usr/lib/firefox-addons/plugins/*flash*
rm -f /usr/lib/mozilla/plugins/*flash*
rm -f ~/.mozilla/plugins/*flash*so
rm -rfd /usr/lib/nspluginwrapper

cd

echo -n "Press any key for continue >"
read opt

echo "[+] Install Last Player"

mkdir -p ~/.mozilla/plugins

if [ -d "Flash" ]; then
  cd Flash
else
  mkdir Flash
  cd Flash
fi
if [ arch != "i686" ]
then
wget -q http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.i386.tar.gz
else
wget -q http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.x86_64.tar.gz
fi

tar xvfz install_flash_player_11_linux*.tar.gz
cp -f libflashplayer.so ~/.mozilla/plugins/
cp -f libflashplayer.so /usr/lib/mozilla/plugins
cd
rm -rf Flash

echo "[+] Successfully !"

Wang Xiang Zhai

  • Invité
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #2 le: 17 novembre 2013 à 11:28:56 »
salut, je l'ai lancé pour testé.

____ _____ __ _           _     
| __ )_   _/ _| | __ _ ___| |__ 
|  _ \ | || |_| |/ _` / __|  _ \
| |_) || ||  _| | (_| \__ \ | | |
|____/ |_||_| |_|\__,_|___/_| |_|

[+] Valid on 32 & 64 bits GNOME BACKTRACK5 R3
[+] Clean Old Player
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet flashplugin-installer
rm : option non valide -- d
Saisissez « rm --help » pour plus d'informations.
Press any key for continue >
[+] Install Last Player
libflashplayer.so
readme.txt
usr/
usr/bin/
usr/bin/flash-player-properties
usr/share/
usr/share/kde4/
usr/share/kde4/services/
usr/share/kde4/services/kcm_adobe_flash_player.desktop
usr/share/applications/
usr/share/applications/flash-player-properties.desktop
usr/share/icons/
usr/share/icons/hicolor/
usr/share/icons/hicolor/22x22/
usr/share/icons/hicolor/22x22/apps/
usr/share/icons/hicolor/22x22/apps/flash-player-properties.png
usr/share/icons/hicolor/48x48/
usr/share/icons/hicolor/48x48/apps/
usr/share/icons/hicolor/48x48/apps/flash-player-properties.png
usr/share/icons/hicolor/24x24/
usr/share/icons/hicolor/24x24/apps/
usr/share/icons/hicolor/24x24/apps/flash-player-properties.png
usr/share/icons/hicolor/32x32/
usr/share/icons/hicolor/32x32/apps/
usr/share/icons/hicolor/32x32/apps/flash-player-properties.png
usr/share/icons/hicolor/16x16/
usr/share/icons/hicolor/16x16/apps/
usr/share/icons/hicolor/16x16/apps/flash-player-properties.png
usr/share/pixmaps/
usr/share/pixmaps/flash-player-properties.png
usr/lib/
usr/lib/kde4/
usr/lib/kde4/kcm_adobe_flash_player.so
[+] Successfully !

faut que tu le corriges.

@+ de retour vers 22h

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre VIP
  • *****
  • Messages: 3708
  • Notoriété : +249/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #3 le: 17 novembre 2013 à 11:57:19 »
essaye celui-ci

#!/bin/bash

#
#  KaliFlash.sh


#  This program is free software; you can redistribute it and/or modify
#  it under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.

#  This program is distributed in the hope that it will be useful,
#  but WITHOUT ANY WARRANTY; without even the implied warranty of
#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#  GNU General Public License for more details.

#  You should have received a copy of the GNU General Public License
#  along with this program; if not, write to the Free Software
#  Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston,
#  MA 02110-1301, USA.
#
#Source Alien And abortSecurit-E Modified by IceF0x

red='\e[0;31m'
NC='\e[0m'

if [ "$(whoami)" != root ]
then
echo -e "$red Error:$NC Vous devez être root pour pouvoir exécuter ce script !"
exit 1
fi

echo ''' _  __    _    _     ___ _____ _        _    ____  _   _
| |/ /   / \  | |   |_ _|  ___| |      / \  / ___|| | | |
|  '' /   / _ \ | |    | || |_  | |     / _ \ \___ \| |_| |
| . \  / ___ \| |___ | ||  _| | |___ / ___ \ ___) |  _  |
|_|\_\/_/   \_\_____|___|_|   |_____/_/   \_\____/|_| |_|
'''

echo -e "$red [+]$NC Valid on 32 & 64 bits Kali Linux 1.0.5"

echo -e "$red [+]$NC Clean Old Player"

apt-get purge flashplugin* gnash* mozilla-plugin-gnash swfdec*

rm -f /usr/lib/mozilla/plugins/*flash*
rm -f /usr/lib/mozilla/plugins/*flash*
rm -f ~/.mozilla/plugins/*flash*so
rm -rf /usr/lib/nspluginwrapper

cd

echo -en "$red [+]$NC Press any key for continue >"
read opt

echo -e "$red [+]$NC Install Last Player"

mkdir -p ~/.mozilla/plugins

if [ -d "Flash" ]; then
  cd Flash
else
  mkdir Flash
  cd Flash
fi
if [ arch != "i686" ]
then
wget -q http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.i386.tar.gz
else
wget -q http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.x86_64.tar.gz
fi
echo -e "$red [+]$NC Extracting files... "
tar xfz install_flash_player_11_linux*.tar.gz
echo -e "$red [+]$NC Files extracted !"
cp -f libflashplayer.so ~/.mozilla/plugins/
cp -f libflashplayer.so /usr/lib/mozilla/plugins
cd
rm -rf Flash

echo -e "$red [+]$NC Successfully !"

Il faut savoir que adobe ne fait plus de support pour Linux depuis la version 11.2 (version actuelle 11.9) il faut dans la mesure du possible bannir flash de son usage quotidien et lui préférer l'html5
« Modifié: 17 novembre 2013 à 12:23:31 par coyotus »

Wang Xiang Zhai

  • Invité
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #4 le: 18 novembre 2013 à 00:23:16 »
me v'la,

le retour:

_  __    _    _     ___ _____ _        _    ____  _   _
| |/ /   / \  | |   |_ _|  ___| |      / \  / ___|| | | |
|   /   / _ \ | |    | || |_  | |     / _ \ \___ \| |_| |
| . \  / ___ \| |___ | ||  _| | |___ / ___ \ ___) |  _  |
|_|\_\/_/   \_\_____|___|_|   |_____/_/   \_\____/|_| |_|

 [+] Valid on 32 & 64 bits Kali Linux 1.0.5
 [+] Clean Old Player
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de flashplugin-nonfree-pulse pour l'expression rationnelle « flashplugin* »
Note : sélection de flashplugin pour l'expression rationnelle « flashplugin* »
Note : sélection de flashplugin-nonfree pour l'expression rationnelle « flashplugin* »
Le paquet « flashplugin-nonfree-pulse » n'est pas installé, et ne peut donc être supprimé
Le paquet « flashplugin » n'est pas installé, et ne peut donc être supprimé
Note : sélection de gnash-ext-fileio pour l'expression rationnelle « gnash* »
Note : sélection de gnash-cygnal pour l'expression rationnelle « gnash* »
Note : sélection de gnash-opengl pour l'expression rationnelle « gnash* »
Note : sélection de mozilla-plugin-gnash pour l'expression rationnelle « gnash* »
Note : sélection de gnash-ext-lirc pour l'expression rationnelle « gnash* »
Note : sélection de konqueror-plugin-gnash pour l'expression rationnelle « gnash* »
Note : sélection de browser-plugin-gnash pour l'expression rationnelle « gnash* »
Note : sélection de gnash-common pour l'expression rationnelle « gnash* »
Note : sélection de gnash-dbg pour l'expression rationnelle « gnash* »
Note : sélection de gnash-dev pour l'expression rationnelle « gnash* »
Note : sélection de gnash-doc pour l'expression rationnelle « gnash* »
Note : sélection de libgnash0 pour l'expression rationnelle « gnash* »
Note : sélection de gnash-common-opengl pour l'expression rationnelle « gnash* »
Note : sélection de gnash pour l'expression rationnelle « gnash* »
Note : sélection de gnash-tools pour l'expression rationnelle « gnash* »
Note : sélection de python-gtk-gnash pour l'expression rationnelle « gnash* »
Note : sélection de python2.7-gtk-gnash pour l'expression rationnelle « gnash* »
Note : sélection de gnash-ext-mysql pour l'expression rationnelle « gnash* »
Note : sélection de « gnash-common » au lieu de « libgnash0 »
Note : sélection de « python-gtk-gnash » au lieu de « python2.7-gtk-gnash »
Note : sélection de swfdec-mozilla pour l'expression rationnelle « swfdec* »
Note : sélection de swfdec-gnome pour l'expression rationnelle « swfdec* »
Le paquet « browser-plugin-gnash » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-common » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-common-opengl » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-cygnal » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-dbg » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-dev » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-doc » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-ext-fileio » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-ext-lirc » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-ext-mysql » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-opengl » n'est pas installé, et ne peut donc être supprimé
Le paquet « gnash-tools » n'est pas installé, et ne peut donc être supprimé
Le paquet « konqueror-plugin-gnash » n'est pas installé, et ne peut donc être supprimé
Le paquet « mozilla-plugin-gnash » n'est pas installé, et ne peut donc être supprimé
Le paquet « python-gtk-gnash » n'est pas installé, et ne peut donc être supprimé
Le paquet « swfdec-gnome » n'est pas installé, et ne peut donc être supprimé
Le paquet « swfdec-mozilla » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libruby ruby-crack ruby-diff-lcs ruby-rspec ruby-rspec-core
  ruby-rspec-expectations ruby-rspec-mocks ruby-simplecov ruby-simplecov-html
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  flashplugin-nonfree*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 4 non mis à jour.
Après cette opération, 181 ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 292986 fichiers et répertoires déjà installés.)
Suppression de flashplugin-nonfree ...
Purge des fichiers de configuration de flashplugin-nonfree ...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Traitement des actions différées (« triggers ») pour « hicolor-icon-theme »...
Traitement des actions différées (« triggers ») pour « man-db »...
 [+] Press any key for continue >
 [+] Install Last Player
 [+] Extracting files...
 [+] Files extracted !
 [+] Successfully !

au final ça marche pas, mais je sais pourquoi !

c'est simplement tes lignes:

wget -q http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.i386.tar.gz
else
wget -q http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.x86_64.tar.gz

le libflashplayer.so n'est pas bon.

il faut le libflashplayer.so d'ici :  http://get.adobe.com/fr/flashplayer/

j'ai simplement après l'exécution complète de ton script, remplacé le tien par le mien et ça marche.

il faut le install_flash_player_11_linux.x86_64.tar.gz de:

http://get.adobe.com/fr/flashplayer/download/?installer=Flash_Player_11.2_for_other_Linux_(.tar.gz)_64-bit&standalone=1

j'ai modifier 68 et 70 (j'ai tout mis en linux.x86_64 pour être sur d'avoir le bon).

#!/bin/bash

#
#  KaliFlash.sh


#  This program is free software; you can redistribute it and/or modify
#  it under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.

#  This program is distributed in the hope that it will be useful,
#  but WITHOUT ANY WARRANTY; without even the implied warranty of
#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#  GNU General Public License for more details.

#  You should have received a copy of the GNU General Public License
#  along with this program; if not, write to the Free Software
#  Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston,
#  MA 02110-1301, USA.
#
#Source Alien And abortSecurit-E Modified by IceF0x

red='\e[0;31m'
NC='\e[0m'

if [ "$(whoami)" != root ]
then
echo -e "$red Error:$NC Vous devez être root pour pouvoir exécuter ce script !"
exit 1
fi

echo ''' _  __    _    _     ___ _____ _        _    ____  _   _
| |/ /   / \  | |   |_ _|  ___| |      / \  / ___|| | | |
|  '' /   / _ \ | |    | || |_  | |     / _ \ \___ \| |_| |
| . \  / ___ \| |___ | ||  _| | |___ / ___ \ ___) |  _  |
|_|\_\/_/   \_\_____|___|_|   |_____/_/   \_\____/|_| |_|
'''

echo -e "$red [+]$NC Valid on 32 & 64 bits Kali Linux 1.0.5"

echo -e "$red [+]$NC Clean Old Player"

apt-get purge flashplugin* gnash* mozilla-plugin-gnash swfdec*

rm -f /usr/lib/mozilla/plugins/*flash*
rm -f /usr/lib/mozilla/plugins/*flash*
rm -f ~/.mozilla/plugins/*flash*so
rm -rf /usr/lib/nspluginwrapper

cd

echo -en "$red [+]$NC Press any key for continue >"
read opt

echo -e "$red [+]$NC Install Last Player"

mkdir -p ~/.mozilla/plugins

if [ -d "Flash" ]; then
  cd Flash
else
  mkdir Flash
  cd Flash
fi
if [ arch != "i686" ]
then
wget -q http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.327/install_flash_player_11_linux.x86_64.tar.gz
else
wget -q http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.327/install_flash_player_11_linux.x86_64.tar.gz
fi
echo -e "$red [+]$NC Extracting files... "
tar xfz install_flash_player_11_linux*.tar.gz
echo -e "$red [+]$NC Files extracted !"
cp -f libflashplayer.so ~/.mozilla/plugins/
cp -f libflashplayer.so /usr/lib/mozilla/plugins
cd
rm -rf Flash

echo -e "$red [+]$NC Successfully !"

read

là ça marche.

ça ne marche que avec le fichier de:

http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.327/install_flash_player_11_linux.x86_64.tar.gz
si tu veux voir ce que contient l'installateur:

tu fais dans la ligne de l'url:

http://get.adobe.com/fr/flashplayer/download/?installer=Flash_Player_11.2_for_other_Linux_(.tar.gz)_64-bit&standalone=1

"?installer=Flash_Player_11.2_for_other_Linux_(.tar.gz)_64-bit&standalone=1"

entre les ""

tu télécharges l'installateur:

wget http://get.adobe.com/fr/flashplayer/download/"?installer=Flash_Player_11.2_for_other_Linux_(.tar.gz)_64-bit&standalone=1"
tu ouvres avec leafpad

ce qui donne:

    <!doctype html>
    <html>
        <head>
            <meta charset="utf-8">

            <title>Adobe - Installation d'Adobe Flash Player</title>

            <link href="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/css/reset.css" rel="stylesheet">
            <link href="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/css/jquery-ui/jquery-ui.css" rel="stylesheet">
            <link href="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/css/core.css" rel="stylesheet">

            <!--[if lt IE 9]>
                <link href="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/css/ie_fix.css" rel="stylesheet">
            <![endif]-->

            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/jquery/jquery.min.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/jquery/jquery-ui.min.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/jquery/plugins/cookies/cookies.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/jquery/plugins/outside/outside.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/jquery/plugins/string/string.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/jquery/plugins/bxslider/bxslider.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/jquery/plugins/selectBox/selectBox.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/swfobject/swfobject.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/modal.js" type="text/javascript"></script>
            <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/core.js" type="text/javascript"></script>

        <script type="text/javascript" src="//fonts.adobe.com/yoe7ink.js"></script>
            <script type="text/javascript">try{Typekit.load();}catch(e){}</script>
            <script type="text/javascript">
if (!Array.prototype.indexOf)
{
  Array.prototype.indexOf = function(elt /*, from*/)
  {
var len = this.length;

var from = Number(arguments[1]) || 0;
from = (from < 0)
? Math.ceil(from)
: Math.floor(from);
if (from < 0)
  from += len;

for (; from < len; from++)
{
  if (from in this &&
  this[from] === elt)
return from;
}
return -1;
  };
}
            </script>

            <!--[if lt IE 9]>
                <script src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/js/html5shiv.js" type="text/javascript"></script>
            <![endif]-->


           
<script type="text/javascript" src="http://wwwimages.adobe.com/www.adobe.com/uber/js/pdc_s_code.js"></script>
<script type="text/javascript" src="http://wwwimages.adobe.com/www.adobe.com/uber/js/atm/s_code_acdc.js"></script>

         <script>


setTimeout("location.href = 'http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.327/install_flash_player_11_linux.x86_64.tar.gz';", 2000);


$(function() {
$("#whats_new_panels").bxSlider({
controls: false,
auto: true,
pause: 15000
});
});
setTimeout(function(){
$("#download_messaging").hide();
$("#next_button").show();
}, 10000);
</script>
        </script>


<style>
.ui-dialog{ filter: none !important; }
</style>
        <script type='text/javascript'>var locale = 'fr';</script><script type="text/javascript" src="http://wwwimages.adobe.com/www.adobe.com/js/foresee/foresee-trigger-dlc.js"></script></head>

        <body>
            <div class="MainContent" id="AUTO_ID_div_main_content">
<header id="AUTO_ID_singlepage_header">
<div class="header " id="AUTO_ID_singlepage_div_header">
<div class="HeaderContent" id="AUTO_ID_singlepage_div_headerContent">
<span id="AUTO_ID_singlepage_span_home"><a class="HomeLogo" href="http://www.adobe.com" id="AUTO_ID_singlepage_a_home">Accueil</a></span>
<p class="TextStep" id="AUTO_ID_singlepage_span_step">Étape : 1 de 3</p>
</div>
</div>
</header>
<section id="AUTO_ID_singlepage_section">
<div class="section " id="mainSection">
<div id="ContentColumns-left">
            <div class="ContentColumn ContentColumn-1" id="AUTO_ID_columnleft_div_01">

                <h2 class="HeaderFlashPlayer" id="AUTO_ID_columnleft_h2_header">Adobe Flash Player</h2>
                <p id="AUTO_ID_columnleft_p_flash_logo">
<img src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/images/flash_windows.gif" width="316" height="130" alt="Flash logo with screens" id="AUTO_ID_columnleft_img_flash_logo">
</p>
<h3 id="AUTO_ID_db_div_whats_new">Nouveautés ?</h3>
<div id="whats_new_panels">
 <div id="AUTO_ID_db_div_01">
  <h4 class="NoBottomMargin" id="AUTO_ID_db_h4_01"><strong>Rester protéger</strong></h4>
  <p id="AUTO_ID_db_p_01">Assurez-vous que l'installation de Flash Player est sécurisé et à jour. Il suffit de sélectionner « Autoriser Adobe à installer les mises à jour » durant la phase d'installation ou de choisir cette option à tout moment dans le panneau de contrôle de Flash Player. </p>
 </div>
 <div id="AUTO_ID_db_div_02">
  <h4 class="NoBottomMargin" id="AUTO_ID_db_h4_02"><strong>Jeu</strong></h4>
  <p id="AUTO_ID_db_p_02">Optimisez votre prochain niveau de jeu avec les incroyables graphismes en 3D de Flash Player. Des jeux sans heurt, sensibles et incroyablement détaillés sont à un clic de vous. Nous avons même ajouté un soutien supplémentaire pour les Contrôleurs de jeu, alors venez jouer !</p>
 </div>
 <div id="AUTO_ID_db_div_03">
  <h4 class="NoBottomMargin" id="AUTO_ID_db_h4_03"><strong>Haute performance</strong></h4>
  <p id="AUTO_ID_db_p_03">Expérience matérielle accélérée au niveau des vidéos HD grâce au lecteur parfait de Flash Player. Les récentes améliorations permettent au contenu et aux jeux Flash de continuer à fournir des informations sensibles, même si votre unité centrale est utilisée à son maximum..</p>
 </div>
</div>
           
            </div>
        </div>

        <div id="ContentColumns-right">
            <div class="ContentColumn ContentColumn-2-3" id="AUTO_ID_columnright_div_01">
<div id="download_messaging" class="AlignVerticalCenter">
<p class="DownloadMessage SmallBottomMargin AlignCenter" id="AUTO_ID_columnright_p_download_start_text">Votre téléchargement va bientôt commencer.</p>
<p class="AlignCenter" id="AUTO_ID_columnright_p_download_start">
<img src="http://wwwimages.adobe.com/www.adobe.com/downloadcenter/singlepage/live/images/download_start.gif" width="144" height="16" id="AUTO_ID_columnright_img_download_start">
</p>
</div>
<div id="next_button" class="AlignBottom" style="display: none;">
<p class="SmallBottomMargin AlignCenter" id="AUTO_ID_columnright_p_button_next">
<a id="buttonNext" class="Button ButtonYellow" href="/fr/flashplayer/completion/?installer=Flash_Player_11.2_for_other_Linux_(.tar.gz)_64-bit">
Suivant
</a>
</p>
<p class="NoBottomMargin" style="visibility: hidden;" id="AUTO_ID_columnright_p_blank">&nbsp;</p>
</div>
           </div>
        </div>

<noscript><img src="http://stats.adobe.com/b/ss/mxmacromedia/1/H.24.4T/0?pageName=ACDC%5FNoscript&g=http%3A//get.adobe.com/&ch=ACDC%5FNoscript&server=Dylan" height="1" width="1" border="0" alt="" /></noscript><noscript><img src="http://stats.adobe.com/b/ss/adbacdcprod/1/H.24.4T/0?pageName=ACDC%5FNoscript&g=http://get.adobe.com&ch=ACDC%5FNoscript" height="1" width="1" border="0" alt="" /></noscript><!--/DO NOT REMOVE/-->
<!-- End Adobe Digital Marketing Suite Tag Management code -->
         <script>
$("#AUTO_ID_singlepage_span_step").text("Étape : 2 de 3");
</script>
</div>
</section>


<footer id="singlepage_footer">
<div class="footer " id="AUTO_ID_singlepage_div_footer">
</div>
</footer>

            </div>
<div id="dualOfferInstallOptions" style="display: none;" title="Options d’installation"></div>
        </body>
    </html>

regardes ligne 66.

@+







« Modifié: 18 novembre 2013 à 02:24:26 par Wang Xiangzhai »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre VIP
  • *****
  • Messages: 3708
  • Notoriété : +249/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #5 le: 18 novembre 2013 à 06:13:00 »
Pourtant c'est les lien pris d'ici http://www.adobe.com/products/flashplayer/distribution3.html
et mes test en VM étaient bon ?

Le lien de la ligne 66

http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.327/install_flash_player_11_linux.x86_64.tar.gz

le lien de mon script

http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.x86_64.tar.gz

C'est vrai qu'il sont différent mais je ne comprend pas pourquoi il ne fonctionnerais pas
« Modifié: 18 novembre 2013 à 06:18:49 par coyotus »

Wang Xiang Zhai

  • Invité
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #6 le: 18 novembre 2013 à 19:41:16 »
ma config à fortement évolué depuis (je peux lire le flash sans libflashplayer.so maintenant), me demande pas comment.

j'ai tellement didouillé ! ?

j'ai retesté un peu en liveCD (ton script y marche).

la différence, je la vois là !

chez toi, avec ton script:





avec les méthodes manuelles:



en gros avec le script tu as un message, qui te dit tu peux pas lire le flash, mais tu peux le lire quand même au final ?
« Modifié: 18 novembre 2013 à 20:41:12 par Wang Xiangzhai »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre VIP
  • *****
  • Messages: 3708
  • Notoriété : +249/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #7 le: 18 novembre 2013 à 20:32:51 »
Citer
ma config à fortement évolué depuis (je peux lire le flash sans libflashplayer.so maintenant), me demande pas comment.
html5 peut être ?
Citer
en gros avec le script tu as un message, qui te dit tu peux pas lire le flash, mais tu peux le lire quand même au final ?
Le support de GNU/Linux s'est arreté à la version 11.2 alors qu'on est à la version 11.8 ou 11.9 je ne sais plus trop, bref on est encore discriminé par adobe.

bande de dev fainéant

Wang Xiang Zhai

  • Invité
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #8 le: 18 novembre 2013 à 21:28:45 »
en fait je me demande un truc coyotus, le script:

il installerait pas:

http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.i386.tar.gz

parce qu'il passe son libflashplayer.so  en manuel (tu vois ce que je veux dire)  celui là sur 64 bits !

il marche, testé en liveCD.

je suis nul en shell  (else=autre) pourquoi 2 lignes ? (j'ai bien vu que c'est pour les 2 archs).

on peut pas vérifier quel libflashplayer.so a été installé !

fais en un uniquement avec

wget -q http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.327/install_flash_player_11_linux.x86_64.tar.gz
un spéciale 64 et rien d'autre.

plus haut je t'ai dis, j'ai modifié les deux lignes et nickel !

else
  mkdir Flash
  cd Flash
fi
if [ arch != "i686" ]
then
wget -q http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.327/install_flash_player_11_linux.x86_64.tar.gz
else
wget -q http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.327/install_flash_player_11_linux.x86_64.tar.gz
fi
echo -e "$red [+]$NC Extracting files... "
tar xfz install_flash_player_11_linux*.tar.gz
echo -e "$red [+]$NC Files extracted !"

quand j'ai fais cette modif le script sur mon 64 est parfait (parce qu'il n'a plus le choix).

il installerait peut être pas le 64 bits, mais la version 32 bits, c'est ma deuxième hypothèse.

faire un script juste pour 64 bits !

pour 32 bits, ça sert pas à grand chose flashplugin-nonfree fait parfaitement le boulot.

et je reteste !
« Modifié: 18 novembre 2013 à 21:34:21 par Wang Xiangzhai »

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre VIP
  • *****
  • Messages: 3708
  • Notoriété : +249/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #9 le: 18 novembre 2013 à 22:56:27 »
j'ai mis un echo pour savoir si il sélectionnais bien la ligne 386 en 32 bit et j'ai remarqué ou était l'erreur.

j'ai inversé les lignes

il faut soit mettre "if [ arch == "i686" ]" au lieu de "if [ arch != "i686" ]"

soit inverser les liens

if [ arch != "i686" ]
then
wget -q http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.x86_64.tar.gz
else
wget -q http://fpdownload.macromedia.com/get/flashplayer/current/licensing/linux/install_flash_player_11_linux.i386.tar.gz
fi

Wang Xiang Zhai

  • Invité
Re : lire videos flash player sur kali linux 64 bits.
« Réponse #10 le: 19 novembre 2013 à 01:10:35 »
avec if [ arch !== "i686" ]

non

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 [+] Press any key for continue >
 [+] Install Last Player
/root/Desktop/Untitled Document: line 66: [: !==: binary operator expected
 [+] Extracting files...
 [+] Files extracted !

par contre avec l'inversion des liens.

_  __    _    _     ___ _____ _        _    ____  _   _
| |/ /   / \  | |   |_ _|  ___| |      / \  / ___|| | | |
|   /   / _ \ | |    | || |_  | |     / _ \ \___ \| |_| |
| . \  / ___ \| |___ | ||  _| | |___ / ___ \ ___) |  _  |
|_|\_\/_/   \_\_____|___|_|   |_____/_/   \_\____/|_| |_|

 [+] Valid on 32 & 64 bits Kali Linux 1.0.5
 [+] Clean Old Player
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'flashplugin-nonfree-pulse' for regex 'flashplugin*'
Note, selecting 'flashplugin' for regex 'flashplugin*'
Note, selecting 'flashplugin-nonfree' for regex 'flashplugin*'
Package 'flashplugin-nonfree-pulse' is not installed, so not removed
Package 'flashplugin' is not installed, so not removed
Note, selecting 'gnash-ext-fileio' for regex 'gnash*'
Note, selecting 'gnash-cygnal' for regex 'gnash*'
Note, selecting 'gnash-opengl' for regex 'gnash*'
Note, selecting 'mozilla-plugin-gnash' for regex 'gnash*'
Note, selecting 'gnash-ext-lirc' for regex 'gnash*'
Note, selecting 'konqueror-plugin-gnash' for regex 'gnash*'
Note, selecting 'browser-plugin-gnash' for regex 'gnash*'
Note, selecting 'gnash-common' for regex 'gnash*'
Note, selecting 'gnash-dbg' for regex 'gnash*'
Note, selecting 'gnash-dev' for regex 'gnash*'
Note, selecting 'gnash-doc' for regex 'gnash*'
Note, selecting 'libgnash0' for regex 'gnash*'
Note, selecting 'gnash-common-opengl' for regex 'gnash*'
Note, selecting 'gnash' for regex 'gnash*'
Note, selecting 'gnash-tools' for regex 'gnash*'
Note, selecting 'python-gtk-gnash' for regex 'gnash*'
Note, selecting 'python2.7-gtk-gnash' for regex 'gnash*'
Note, selecting 'gnash-ext-mysql' for regex 'gnash*'
Note, selecting 'gnash-common' instead of 'libgnash0'
Note, selecting 'python-gtk-gnash' instead of 'python2.7-gtk-gnash'
Note, selecting 'swfdec-mozilla' for regex 'swfdec*'
Note, selecting 'swfdec-gnome' for regex 'swfdec*'
Package 'browser-plugin-gnash' is not installed, so not removed
Package 'gnash' is not installed, so not removed
Package 'gnash-common' is not installed, so not removed
Package 'gnash-common-opengl' is not installed, so not removed
Package 'gnash-cygnal' is not installed, so not removed
Package 'gnash-dbg' is not installed, so not removed
Package 'gnash-dev' is not installed, so not removed
Package 'gnash-doc' is not installed, so not removed
Package 'gnash-ext-fileio' is not installed, so not removed
Package 'gnash-ext-lirc' is not installed, so not removed
Package 'gnash-ext-mysql' is not installed, so not removed
Package 'gnash-opengl' is not installed, so not removed
Package 'gnash-tools' is not installed, so not removed
Package 'konqueror-plugin-gnash' is not installed, so not removed
Package 'mozilla-plugin-gnash' is not installed, so not removed
Package 'python-gtk-gnash' is not installed, so not removed
Package 'swfdec-gnome' is not installed, so not removed
Package 'swfdec-mozilla' is not installed, so not removed
Package 'flashplugin-nonfree' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 [+] Press any key for continue >
 [+] Install Last Player
 [+] Extracting files...
 [+] Files extracted !



impeccable sur 64 bits, RAS.

nickel chrome !
« Modifié: 19 novembre 2013 à 01:19:19 par Wang Xiangzhai »