Auteur Sujet: OpenVPN qui ne s'installe pas  (Lu 1869 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne FrenchKaneki

  • Nouvel inscrit
  • Messages: 2
  • +0/-0
OpenVPN qui ne s'installe pas
« le: 29 juin 2018 à 22:04:23 »
Bonjour,
J'ai suivi ce tutoriel pour installer OpenVPN et me connecter à mon VPN :
https://www.kali-linux.fr/configuration/installer-open-vpn-sous-kali-linux
J'écris bien toute les commandes :

echo "deb http://ftp.fr.debian.org/debian wheezy main" >> /etc/apt/sources.list
Marche parfaitement

apt-get update
Ign:1 http://ftp.fr.debian.org/debian wheezy InRelease
Atteint:2 http://ftp.fr.debian.org/debian wheezy Release
Atteint:3 http://deb.i2p2.no unstable InRelease       
Lecture des listes de paquets... Fait                 
W: La cible Packages (main/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Packages (main/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Translations (main/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Translations (main/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Translations (main/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible DEP-11 (main/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible DEP-11 (main/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible DEP-11-icons (main/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Packages (main/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Packages (main/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Translations (main/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Translations (main/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Translations (main/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible DEP-11 (main/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible DEP-11 (main/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible DEP-11-icons (main/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Packages (main/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Packages (main/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Translations (main/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Translations (main/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Translations (main/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible DEP-11 (main/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible DEP-11 (main/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible DEP-11-icons (main/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Packages (main/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Packages (main/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Translations (main/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Translations (main/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Translations (main/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible DEP-11 (main/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible DEP-11 (main/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible DEP-11-icons (main/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:13
W: La cible Packages (main/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Packages (main/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Translations (main/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Translations (main/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Translations (main/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible DEP-11 (main/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible DEP-11 (main/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible DEP-11-icons (main/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:14
W: La cible Packages (main/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Packages (main/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Translations (main/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Translations (main/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible Translations (main/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible DEP-11 (main/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible DEP-11 (main/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15
W: La cible DEP-11-icons (main/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:12 et /etc/apt/sources.list:15

(J'ai compris l'essentiel du message, des sources et des cibles sont dupliqués dans /etc/apt/sources.list mais je ne pense pas que cela cause vraiment un problème)

apt-get -y install network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome network-manager-strongswan network-manager-vpnc network-manager-vpnc-gnome
apt-get -y install network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome network-manager-strongswan network-manager-vpnc network-manager-vpnc-gnome
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
network-manager-openvpn est déjà la version la plus récente (0.9.4.0-1).
network-manager-openvpn passé en « installé manuellement ».
network-manager-openvpn-gnome est déjà la version la plus récente (0.9.4.0-1).
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 network-manager-openvpn-gnome : Dépend: libpango1.0-0 (>= 1.14.0) mais ne sera pas installé
 network-manager-pptp : Dépend: pptp-linux mais ne sera pas installé
                        Dépend: ppp (< 2.4.6) mais 2.4.7-2+2 devra être installé
 network-manager-pptp-gnome : Dépend: libpango1.0-0 (>= 1.14.0) mais ne sera pas installé
 network-manager-strongswan : Dépend: gconf-service mais ne sera pas installé
                              Dépend: libart-2.0-2 (>= 2.3.17) mais ne sera pas installé
                              Dépend: libbonobo2-0 (>= 2.15.0) mais ne sera pas installé
                              Dépend: libbonoboui2-0 (>= 2.15.1) mais ne sera pas installé
                              Dépend: libgconf-2-4 (>= 2.31.1) mais ne sera pas installé
                              Dépend: libgnome2-0 (>= 2.17.3) mais ne sera pas installé
                              Dépend: libgnomecanvas2-0 (>= 2.11.1) mais ne sera pas installé
                              Dépend: libgnomeui-0 (>= 2.22.0) mais ne sera pas installé
                              Dépend: libgnomevfs2-0 (>= 1:2.17.90) mais ne sera pas installé
                              Dépend: liborbit2 (>= 1:2.14.10) mais ne sera pas installé
                              Dépend: libpango1.0-0 (>= 1.14.0) mais ne sera pas installé
                              Dépend: strongswan-nm mais ne sera pas installé
 network-manager-vpnc-gnome : Dépend: libpango1.0-0 (>= 1.14.0) mais ne sera pas installé
 ppp : Casse: network-manager-pptp (< 0.9.8.4-3~) mais 0.9.4.0-2 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Comme vous voyez, ça ne marche pas chez moi.  :'(

J'essaye donc apt --fix-broken install
apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  libpango1.0-0
Paquets suggérés :
  ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp
  ttf-arphic-bkai00mp
Les NOUVEAUX paquets suivants seront installés :
  libpango1.0-0
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
10 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/461 ko dans les archives.
Après cette opération, 1 106 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 349924 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libpango1.0-0_1.30.0-1_amd64.deb ...
Dépaquetage de libpango1.0-0:amd64 (1.30.0-1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libpango1.0-0_1.30.0-1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 », qui appartient aussi au paquet libpangoft2-1.0-0:amd64 1.42.0-1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libpango1.0-0_1.30.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ceci a donc un rapport avec mon précédent post : http://www.kali-linux.fr/forum/index.php/topic,5640.0.html
Mais je ne sais pas si le problème est différent.

Merci de m'aider.  ;)