Auteur Sujet: wifi TP-Link WN725N  (Lu 6681 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : wifi TP-Link WN725N
« Réponse #15 le: 09 février 2019 à 02:21:35 »
ok merci à toi je vais essayer de chercher sa je vais encore passer des jours je pense  :-\

Si tu trouve une solution sa serais sympa ca j'ai déjà regarder un petit partout sur le net.

ma connexion dans ma config vmware est en nat c'est bon ?

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : wifi TP-Link WN725N
« Réponse #16 le: 09 février 2019 à 17:25:06 »
Salut,

j'ai trouvé le driver je pense pour le monitor serait il possible de me dire si ceci c'est le bon driver pour que j'ai le monitor actif voici le lien :

https://www.tp-link.com/fr/download/TL-WN725N_V3.html#Driver et la j'ai choisi TL-WN725N(EU)_V3_180510_Linux_beta car il indique que il prend en charge le Mode Monitor.

je l'ai télécharger et deziper sur mon bureau de kali, pouvez vous m'expliquer la procédure pour l'installation ?

j'ai essayer ceci mes j'ai des erreurs :

root@kali:~/Bureau/rtl8188EUS_linux_v5.2.2.4_25483.20171222/rtl8188EUS_linux_v5.2.2.4_25483.20171222# make all
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.0.0-kali1-amd64/build M=/root/Bureau/rtl8188EUS_linux_v5.2.2.4_25483.20171222/rtl8188EUS_linux_v5.2.2.4_25483.20171222  modules
make[1]: *** /lib/modules/4.0.0-kali1-amd64/build: Aucun fichier ou dossier de ce type. Arrêt.
Makefile:1911: recipe for target 'modules' failed
make: *** [modules] Error 2


encore merci de votre aide
« Modifié: 09 février 2019 à 17:30:55 par cdevl37 »

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : wifi TP-Link WN725N
« Réponse #17 le: 09 février 2019 à 21:32:57 »
Salut!

J't'ai envoyé un MP, avec la procedure d'installation...  ;)
Mais c'est quel version de kali que tu as?? Tu devrais avoir un 4.17 ou 4.18...
grep VERSION /etc/os-release && uname -a
Essaies ça pour le kernel:
apt install linux-headers-$(uname -r)
« Modifié: 09 février 2019 à 21:55:44 par snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : wifi TP-Link WN725N
« Réponse #18 le: 09 février 2019 à 21:58:32 »
Tu as donc kali2.0... Trés ancienne version, presque 4 ans...
 Je serais toi je téléchargerais un iso plus récent... Le dernier serais le mieux! ;)
As-tu bien fais:
apt update
apt dist-upgrade
ou
apt -y full-upgrade
Bon sinon le mieux reste quand meme de choper un iso plus récent...
« Modifié: 09 février 2019 à 22:10:01 par snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : wifi TP-Link WN725N
« Réponse #19 le: 09 février 2019 à 22:23:19 »
merci à toi pour ton aide, j'ai installer à l'instant un nouveau iso et je reçois ceci :

root@kali:~# grep VERSION /etc/os-release && uname -a
VERSION="2019.1"
VERSION_ID="2019.1"
Linux kali 4.18.0-kali2-amd64 #1 SMP Debian 4.18.10-2kali1 (2018-10-09) x86_64 GNU/Linux

root@kali:~# apt install linux-headers-$(uname -r)
E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
root@kali:~#

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : Re : wifi TP-Link WN725N
« Réponse #20 le: 09 février 2019 à 22:28:50 »
Tu as donc kali2.0... Trés ancienne version, presque 4 ans...
 Je serais toi je téléchargerais un iso plus récent... Le dernier serais le mieux! ;)
As-tu bien fais:
apt update
apt dist-upgrade
ou
apt -y full-upgrade
Bon sinon le mieux reste quand meme de choper un iso plus récent...

j'ai fais ceci sur ma nouvelle version l'update fonctionne mes l'ugrade ne fonctionne pas :

root@kali:~# apt update
Hit:1 http://ftp.belnet.be/pub/kali/kali kali-rolling InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
321 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@kali:~# apt dist-upgrade
E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
root@kali:~#


Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : wifi TP-Link WN725N
« Réponse #21 le: 09 février 2019 à 22:33:47 »
Normalement, je pense que tu as été trop vite. Relances les commandes, ça doit passer... Sinon un reboot doit arranger le truc!
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : Re : wifi TP-Link WN725N
« Réponse #22 le: 09 février 2019 à 22:38:00 »
Tu as donc kali2.0... Trés ancienne version, presque 4 ans...
 Je serais toi je téléchargerais un iso plus récent... Le dernier serais le mieux! ;)
As-tu bien fais:
apt update
apt dist-upgrade
ou
apt -y full-upgrade
Bon sinon le mieux reste quand meme de choper un iso plus récent...

et avec mon ancienne version de kali j'ai ceci l'update et upgrade fonctionne mes ma version est toujours la même  :

root@kali:~# apt update
Segmentation fault
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
All packages are up to date.

root@kali:~# apt -y full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

root@kali:~# apt install linux-headers-$(uname -r)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet linux-headers-4.0.0-kali1-amd64
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-headers-4.0.0-kali1-amd64 »

root@kali:~# uname -r
4.0.0-kali1-amd64
root@kali:~#

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : wifi TP-Link WN725N
« Réponse #23 le: 09 février 2019 à 22:43:03 »
Avec le 2019.1 c'est mieux... Le noyaux 4.0 est trop ancien...
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : wifi TP-Link WN725N
« Réponse #24 le: 09 février 2019 à 22:45:57 »
j'ai cette version sur le nouvel iso que j'ai installé : l'update fonctionne mes toujours pas l'upgrade

root@kali:~# uname -r
4.18.0-kali2-amd64

root@kali:~# grep VERSION /etc/os-release && uname -a
VERSION="2019.1"
VERSION_ID="2019.1"
Linux kali 4.18.0-kali2-amd64 #1 SMP Debian 4.18.10-2kali1 (2018-10-09) x86_64 GNU/Linux

mes le problème est cette commande qui passe pas ?

apt install linux-headers-$(uname -r)

root@kali:~# apt install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-4.18.0-kali2-amd64
E: Couldn't find any package by glob 'linux-headers-4.18.0-kali2-amd64'
E: Couldn't find any package by regex 'linux-headers-4.18.0-kali2-amd64'
root@kali:~#
« Modifié: 09 février 2019 à 22:47:43 par cdevl37 »

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : Re : wifi TP-Link WN725N
« Réponse #25 le: 09 février 2019 à 22:51:06 »
Salut!

J't'ai envoyé un MP, avec la procedure d'installation...  ;)
Mais c'est quel version de kali que tu as?? Tu devrais avoir un 4.17 ou 4.18...
grep VERSION /etc/os-release && uname -a
Essaies ça pour le kernel:
apt install linux-headers-$(uname -r)

j'ai vu que il y a sur ce site le fichier headers mes je ne sais pas lequel je dois prendre et comment l'installer : https://http.kali.org/kali/pool/main/l/linux/

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : wifi TP-Link WN725N
« Réponse #26 le: 09 février 2019 à 22:56:02 »
Tu dois prendre le méme, 4.18.0-kali2-amd64 donc.
L'update et l'upgrade fonctionne? Ta config reseau est bonne? As-tu bien internet?
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : wifi TP-Link WN725N
« Réponse #27 le: 09 février 2019 à 23:13:57 »
enfin j'ai réussi la mise à jour par les settings de kali j'ai bien la dernière version :)

oui j'ai bien internet avec ma cléf wifi

root@kali:~# uname -r
4.19.0-kali1-amd64
root@kali:~#

par contre j'ai un fichier restart vm tools sur mon bureau comment dois je l'exécuté ?


Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1615
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : wifi TP-Link WN725N
« Réponse #28 le: 09 février 2019 à 23:17:05 »
Cool!! ;D

Si C'est un dossier rentre dedans fais un ls pour voir ce qu'il y a...
Si c'est un fichier ouvre le deja pour voir...
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne cdevl37

  • Membre régulier
  • **
  • Messages: 87
  • +0/-5
Re : wifi TP-Link WN725N
« Réponse #29 le: 09 février 2019 à 23:19:04 »
ok je fais sa merci

j'ai refais un test mes sa fonctionne toujours pas je vois que PHY est NULL et toujours pas d'interface wlan0mon :

root@kali:~# airmon-ng start wlan0

Found 4 processes that could cause trouble.
Kill them using 'airmon-ng check kill' before putting
the card in monitor mode, they will interfere by changing channels
and sometimes putting the interface back in managed mode

   PID Name
   442 NetworkManager
   528 wpa_supplicant
   529 dhclient
   656 dhclient

PHY   Interface   Driver      Chipset

null   wlan0      r8188eu      Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

root@kali:~#