Auteur Sujet: [Résolu] | gnuradio  (Lu 1380 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Le_Hulant

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 361
  • +7/-8
[Résolu] | gnuradio
« le: 19 novembre 2019 à 23:22:58 »
Bonjour,
depuis peu mon logiciel SDR gnuradio n'affiche plus les blocks wx-widgets.
J'ai tenté une install par pybombs afin d'avoir tout les modules mais j'ai cette erreur en fin de compilation :
In file included from qwt_scale_map.h:14,
                 from qwt_abstract_scale_draw.cpp:14:
qwt_transform.h:110:5: error: ‘QT_STATIC_CONST’ does not name a type
  110 |     QT_STATIC_CONST double LogMin;
      |     ^~~~~~~~~~~~~~~
qwt_transform.h:111:5: error: ‘QT_STATIC_CONST’ does not name a type
  111 |     QT_STATIC_CONST double LogMax;
      |     ^~~~~~~~~~~~~~~
make[1]: *** [Makefile:1089: obj/qwt_abstract_scale_draw.o] Error 1
make[1] : on quitte le répertoire « /etc/prefix/default/src/qwt6/src »
make: *** [Makefile:50: sub-src-make_first-ordered] Error 2
PyBOMBS.Packager.source - ERROR - Build failed. See output above for error messages.
PyBOMBS.Packager.source - ERROR - Problem occurred while building package qwt6:
Build failed.
PyBOMBS.install_manager - ERROR - Error installing package qwt6. Aborting.
il semble y avoir un pb avec un paquet.
J'ai install l'équivalent après recherche sur apt search mais cela n'a pas résolu le pb.
root@kali:/etc# apt install python3-pyqt5.qwt
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  python-pyqt5.qwt-doc
Les NOUVEAUX paquets suivants seront installés :
  python3-pyqt5.qwt
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 283 ko dans les archives.
Après cette opération, 1 808 ko d'espace disque supplémentaires seront utilisés.
Réception de :1 http://ftp.free.fr/pub/kali kali-rolling/main amd64 python3-pyqt5.qwt amd64 1.02.00-1+b1 [283 kB]
283 ko réceptionnés en 1s (195 ko/s)       
Sélection du paquet python3-pyqt5.qwt précédemment désélectionné.
(Lecture de la base de données... 458787 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python3-pyqt5.qwt_1.02.00-1+b1_amd64.deb ...
Dépaquetage de python3-pyqt5.qwt (1.02.00-1+b1) ...
Paramétrage de python3-pyqt5.qwt (1.02.00-1+b1) ...

https://docs.wxwidgets.org/3.0/overview_python.html

Je me prends la tete depuis une semaine alors je dois etre tebé j'ai besoin de l'aide de connaisseurs de python dans son fonctionnement. (daemon, modules, python2.7, python3, python3.8...)
« Modifié: 20 novembre 2019 à 14:55:47 par ZeR0-@bSoLu »
Tu me dis j'oublie, tu m'enseignes je retiens, tu m'impliques j'apprends (B. FRANKLIN)

Dans la vie il y a 10 types de gens : ceux qui comprennent le binaire et ceux qui ne le comprennent pas.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1441
  • +100/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : gnuradio
« Réponse #1 le: 20 novembre 2019 à 01:20:51 »
Je suis au boulot, mais a vue d'oeil, je dirais qu'il te manque qwt6, soit avec pip3 soit avec apt...

Edit:
Sinon as-tu bien tout?
root@kali:~# apt depends gnuradio
gnuradio
  Dépend: libcanberra-gtk-module
  Dépend: libcanberra-gtk3-module
  Dépend: libvolk2-bin
  Dépend: python3-click
  Dépend: python3-click-plugins
  Dépend: python3-gi
  Dépend: python3-gi-cairo
  Dépend: python3-lxml
  Dépend: python3-mako
  Dépend: python3-numpy
  Dépend: python3-opengl
  Dépend: python3-pyqt5
  Dépend: python3-pyqtgraph
  Dépend: python3-sip
  Dépend: python3-yaml
  Dépend: python3-zmq
  Dépend: python3 (>= 3~)
  Dépend: <python3:any>
    python3
  Dépend: libboost-program-options1.67.0
  Dépend: libboost-system1.67.0
  Dépend: libboost-thread1.67.0
  Dépend: libc6 (>= 2.14)
  Dépend: libcodec2-0.8.1
  Dépend: libgcc1 (>= 1:3.0)
  Dépend: libgnuradio-analog3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-audio3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-blocks3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-channels3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-digital3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-dtv3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-fec3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-fft3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-filter3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-pmt3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-qtgui3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-runtime3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-trellis3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-uhd3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-video-sdl3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-vocoder3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-wavelet3.8.0 (>= 3.8.0.0)
  Dépend: libgnuradio-zeromq3.8.0 (>= 3.8.0.0)
  Dépend: liblog4cpp5v5
  Dépend: libpython3.7 (>= 3.7.0)
  Dépend: libqt5core5a (>= 5.11.0~rc1)
  Dépend: libqt5widgets5 (>= 5.0.2)
  Dépend: libstdc++6 (>= 9)
  Dépend: libuhd3.14.1 (>= 3.14.1.0)
  Recommande: gnuradio-dev
  Recommande: python3-matplotlib
  Recommande: python3-networkx
  Recommande: <python3-qwt-qt5>
  Recommande: python3-scipy
  Recommande: rtl-sdr
  Recommande: uhd-host
  Suggère: gr-fosphor
  Suggère: gr-osmosdr

Sinon avec notre ami gogol, j'ai trouvé ça et la solution a l'air d'etre là:
https://www.gitmemory.com/issue/gnuradio/gr-recipes/161/538474151
En faite ils ont remove libqwt-dev, donc dans le fichier ~/.pybombs/recipes/gr-recipes/qwt6.lwr, il faut virer le & et mettre ou... (||) Donc:
Ligne31: deb: libqwt-qt5-dev || libqwt-dev >= 6.1
Et ça fonctionnera!!  ;)
Essaies déjà ça, c'est pour kali en plus...

Tchao A+   8)
Snk
« Modifié: 20 novembre 2019 à 07:04:13 par Snk »
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
A l'époque c'était système_D (Comme démerdes-toi!)
Anti GAFAM - Brûlons les tous!

Hors ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2618
  • +144/-4
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : gnuradio
« Réponse #2 le: 20 novembre 2019 à 06:42:32 »
Il suffit d'installer les paquets manquants.
De plus je ne pense pas que ce soit le bon forum pour poster ça Hulant , tu devrais essayer sur un forum dédié à ça tu aurais plus de chance de trouver des solutions.
Pour faire 2 install ça va mais pour la suite ça servira pas à grand chose à mon avis de poster ici.

Citer
PyBOMBS.install_manager - ERROR - Error installing package qwt6. Aborting.

Snk t'a donné probablement la solution :)
« Modifié: 20 novembre 2019 à 06:49:01 par ZeR0-@bSoLu »
Mess  with the bests.
Die like the rest.

Hors ligne Le_Hulant

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 361
  • +7/-8
Re : gnuradio
« Réponse #3 le: 20 novembre 2019 à 14:41:26 »
Merci SNK, j'avais pas trouvé ce lien.
Effectivement changement de && en | a permis de finir l'install.

ZeR0 oui c'est vrai ce n'est probablement pas le bon endroit. Toutes mes excuses.

Mais ce n'a pas résolu mon pb de wx-widgets.
Soit il me manque effectivement un module python
Soit c'est que mon system démarre python2.7 instead of python3, ce dernier contenant les bons modules...je vois avec update-alternatives.

Merci à tous en tout cas pour votre patience et votre générosité
Tu me dis j'oublie, tu m'enseignes je retiens, tu m'impliques j'apprends (B. FRANKLIN)

Dans la vie il y a 10 types de gens : ceux qui comprennent le binaire et ceux qui ne le comprennent pas.

Hors ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2618
  • +144/-4
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : gnuradio
« Réponse #4 le: 20 novembre 2019 à 14:55:34 »
Pas de souçis je dis ça surtout pour toi en fait, car probablement que sur le forum adapté tu auras souvent de meilleures réponses.


Dans ce cas regarde également si c'est possible d'installer ce qui faut pour python2.7 mais comme ça va vite devenir déprécié je te conseille de faire en sorte que ça tourne sous py3.
Mess  with the bests.
Die like the rest.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1441
  • +100/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : [Résolu] | gnuradio
« Réponse #5 le: 20 novembre 2019 à 16:25:35 »
Ah ben c'est déjà ça... Par contre avec apt depends ou apt show, il dit que ça fonctionne avec python3... Donc ça m'étonne pas que si tu le fais tourner avec python2.7, ça ne fonctionne pas ou que tu n'est pas tout... Et epluches bien tout les dependances que j'ai copié dans mon message, il doit t'en manquer une.

Tchao A+
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
A l'époque c'était système_D (Comme démerdes-toi!)
Anti GAFAM - Brûlons les tous!