Auteur Sujet: [Résolu] | Problème d'installation des logiciels natifs  (Lu 1446 fois)

0 Membres et 2 Invités sur ce sujet

Hors ligne labdac

  • Nouvel inscrit
  • Messages: 5
  • +0/-0
Bonsoir,
J'ai une petite question sur un phénomène que je ne comprend pas ..
J'ai regardé un peu partout sur le net mais je n'ai pas trouvé de problème semblable.
Le problème ce pose sur machine physique et machine virtuelle

Au moment de l'installation tout ce déroule bien jusqu'au moment ou l'on doit installer les logiciels de bases.
Je vous met une photo du problème

Je n'ai jamais rencontré ce problème jusqu'à présent
Le pc est un MSI GL62M est l'image de kali est celle-ci "kali-linux-2020-1b-installer-amd64.iso" téléchargée avec le torrent officiel kali

Merci d'avance au temps passé pour me répondre
« Modifié: 11 mai 2020 à 11:20:11 par ZeR0-@bSoLu »

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2838
  • +162/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Problème d'installation des logiciels natifs
« Réponse #1 le: 10 mai 2020 à 21:13:14 »
Salut,

Ce problème n'a rien avoir avec kali en soit mais une simple installation de linux, ce n'est donc pas le bon forum pour poser ce genre de question... ce n'est pas un forum helpdesk pour installer linux...

M'enfin... je vais quand même essayer de t'aiguiller même si on a du déjà traiter des sujets similaires au moins 50 fois déjà sur le forum.

As-tu :
-Vérifié la charge de l'iso ?
-Vérifié que tu es bien connecté à internet pour installer des paquets ?
-Vérifié que tu n'a pas juste fait une fausse manip cela arrive parfois.
-Vérifié que tu savais ce que tu faisais lors de l'install ?
-Essayé de sauter cette étape tout simplement ? et d'installer tes paquets après ?


P.S : si tu pouvais à l'avenir réduire la taille de tes images et ou les mètrent  en PJ plutôt si tu veux garder cette taille car c'est difficilement lisible ainsi :) je t'ai fait la modif moi même pour cette fois ci :)
« Modifié: 10 mai 2020 à 21:20:52 par ZeR0-@bSoLu »
Mess  with the bests.
Die like the rest.

Hors ligne labdac

  • Nouvel inscrit
  • Messages: 5
  • +0/-0
Re : Problème d'installation des logiciels natifs
« Réponse #2 le: 10 mai 2020 à 21:20:40 »
Merci de ta réponse,
Effectivement je n’ai jamais ce problème jusqu’à maintenant...
L’iso est mis sur une clé avec Rufus et la vérification est bonne
Fausse manip je pense pas j’ai déjà essayé 2 fois
Le pc est connecté à internet par câble et télécharge bien
Si je saute cette étape le pc boot bien mais uniquement en terminal,
quand j’installe les paquets à la main je me retrouve avec un écran noir au redémarrage

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1559
  • +110/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : Problème d'installation des logiciels natifs
« Réponse #3 le: 10 mai 2020 à 22:55:23 »
Si tu as fais la clé avec rufus, cela peut venir de là... Car rufus délire grave maintenant! Donc, ta clé mal faite! Utilises plutôt balena-etcher ou mieux, fais ta clé avec dd. Avec dd tu sera sûr qu'elle est bien faite.
As-tu controlé la charge de l'iso? Ou re-téléchargé? 

As-tu essayé de débrancher ta clé, et la remettre (a l'arrache), ou changer de mirror??

Si au boot tu as un tty, tu peux faire tes maj, ce qui pourrait resoudre le soucis. (Sinon, "install des drivers")
Si ça ne le resoud pas, et que tu as un ecran noir, c'est sûrement un soucis de drivers, il te faut donc désactiver la cg depuis grub lors du boot (en tapant e puis nomodeset) et installer tes drivers aprés, une fois que tu auras la session... Fais dejà ça, et on improvise aprés...

Edit: J'avais pas vu, tu as controlé l'iso et installe en eth, dejà, ça c'est good. L'install en eth est un bon reflexe, par contre rufus a ma connaissance (je ne l'utilise plus) foire trés souvent.

Ps: merci, j'ai chopé un torticolis en regardant l'image...  ;D ;D :P
Voilà mon opinion sur le sujet!  8)
« Modifié: 20 mai 2020 à 07:06:57 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!

Hors ligne labdac

  • Nouvel inscrit
  • Messages: 5
  • +0/-0
Re : Re : Problème d'installation des logiciels natifs
« Réponse #4 le: 11 mai 2020 à 02:22:13 »
Si tu as fais la clé avec rufus, cela peut venir de là... Ta clé mal faite! Utilises plutôt balena-etcher ou mieux, fais ta clé avec dd. Avec dd tu sera sûr qu'elle est bien faite.
As-tu controlé la charge de l'iso? Ou re-téléchargé? 

As-tu essayé de débrancher ta clé, et la remettre (a l'arrache), ou changer de mirror??

Si au boot tu as un tty, tu peux faire tes maj, ce qui pourrait resoudre le soucis. (Sinon, "install des drivers")
Si ça ne le resoud pas, et que tu as un ecran noir, c'est sûrement un soucis de drivers, il te faut donc désactiver la cg depuis grub lors du boot (en tapant e puis nomodeset) et installer tes drivers aprés, une fois que tu auras la session... Fais dejà ça, et on improvise aprés...

Edit: J'avais pas vu, tu as controlé l'iso et installe en eth, dejà, ça c'est good. L'install en eth est un bon reflexe, par contre rufus a ma connaissance (je ne l'utilise plus) foire trés souvent.

Voilà mon opinion sur le sujet!  8)



Merci pour vos réponses,
J’ai refait ma clé usb balena et même problème
J’ai donc sauté l’etape pendant l’installation,
Au démarrage je me retrouve donc en console

J’installe par la console xfce4, tout ce passe bien mais au reboot, le système démarre normalement (sans arriver jusqu’au bureau) puis marque power off et se coupe ...

La clé est normalement bonne avec le nouveau logiciel, je vais essayer avec un iso un peu plus ancien pour voir si ça fonctionne

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1559
  • +110/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : Problème d'installation des logiciels natifs
« Réponse #5 le: 11 mai 2020 à 02:39:47 »
Pourquoi pendant l'install tu ne mets pas direct le bureau + le metapackage avec des outils?? Je te conseil de faire cela.

Pour xfce: (s'il est déjà mais mal installé, tu rajoutes un '--purge -- reinstall' a ma commande 'install')
sudo apt install kali-desktop-xfce lightdm xfce4 xfce4-places-plugin xfce4-goodies
update-alternatives --config x-session-manager
Penses a l'update-alternatives, au cas ou...

Ensuite quand tu boot, si il y a un soucis, a la fenêtre pour se logger, tu ouvres un tty et tu fais d'abord tes majs.
Tu relances, et Si ça bug, avec ecran noir et curseur en haut, tu devras démarrer sans la CG en éditant ("e") sur grub et en mettant "nomodeset" à la place de "quiet".
Multiboot avec un windobe?? Ou pas?? Quelle type d'install?? manuelle? /boot a part? 1 ou 2 partitions? Table de partitions en ms-dos ou efi?
J'attends tes précisions.

Ps: Si tu as un Linux sous la main, fais ta clé avec dd, au moins tu seras sûr de ton coup...
- Pour changer de mirroir, faut faire quit, dés que l'install foire, pour qu'il t'affiche la chronologie des étapes, et il y a une ligne "changer de miroir" ou "sélectionner le miroir"
Snk  8)
« Modifié: 11 mai 2020 à 03:42:41 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2838
  • +162/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Problème d'installation des logiciels natifs
« Réponse #6 le: 11 mai 2020 à 08:09:14 »
Tu as dis que la vérification de l'iso est bonne, mais tu parles du fait que rufus le monte bien ou tu parles effectivement de la charge de l'iso que tu as au préalable comparé avec la charge fournit sur le site ?

Le mieux serait que tu montes ta clé avec dd directement, de plus si tu as le même problème avec balena etcher, es-tu sur que ta clé usb est bien formatée et fonctionne correctement ?

Mess  with the bests.
Die like the rest.

Hors ligne labdac

  • Nouvel inscrit
  • Messages: 5
  • +0/-0
Re : Problème d'installation des logiciels natifs
« Réponse #7 le: 11 mai 2020 à 11:13:17 »
Merci beaucoup pour vos retours  ;)

Après avoir passé une partie de la nuit il semble que mon pc est un problème avec xfce4 ... j’ai installé à la place lxde et ça fonctionne très bien !
C’est assez entrange sur les autres machines ça fonctionne bien xfce pourtant
J’essaye d’installer la prochaine

C'est un peu différent avec lxde mais pourquoi pas après tout !

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2838
  • +162/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Problème d'installation des logiciels natifs
« Réponse #8 le: 11 mai 2020 à 11:20:00 »
sinon tu peux juste reconfigurer xfce comme te l'a expliqué snk.

Je passe le sujet en résolu,  je pense pas que ton pc soit en cause pour le coup xfce est léger.


Mess  with the bests.
Die like the rest.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1559
  • +110/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : [Résolu] | Problème d'installation des logiciels natifs
« Réponse #9 le: 20 mai 2020 à 07:01:11 »
!!==> Ah en fait, si ça ça trouve, tu as ce bug:
Lightdm te demande de te logger, et au lieu de lancer xfce4, l'ecran se bloque devient noir avec une toute petite croix en haut a gauche...
Si c'est bien ça, il faut ouvrir un tty, te logger dessus, et relancer lightdm ("sudo service lightdm restart") pour enfin te relogger (une deuxième fois)... Et là, normalement, xfce4 se lance bien.  ;)

Tu peux essayer aussi de checker les 'update-alternatives', '--config x-window-manager' et '--config x-session-manager' avec startxfce4 coché en priorité...

Si tu as installé lxde, qui est très bien en plus, tu peux rajouter facilement xfce pour tester.

Sur ce, A+  8)
Snk
« Modifié: 29 mai 2020 à 19:25:59 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!