Auteur Sujet: [Résolu] | Soucis avec ma Awus1900  (Lu 2006 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne hashirama

  • Membre Junior
  • *
  • Messages: 13
  • +0/-0
[Résolu] | Soucis avec ma Awus1900
« le: 15 juillet 2020 à 00:22:05 »
Bonjour voilà j'ai un petit soucis avec ma carte wifi Awus1900, il y a encore 1 mois elle fonctionnait sans aucuns soucis, je pouvais la mettre en mode monitor avec airmon-ng, puis le scan avec airodump etc
mais là depuis quelque temps, impossible de passer en mode monitor avec airmon-ng, il m'affiche un message d'erreur, il me demande de lancer airmon-ng check kill ..... alors que je le lance avant meme d'essayer de passer en mode monitor, je vous mettrai le screen en bas, du coup j'essaye de passer en mode manuel, là ok j'arrive à passer en mode monitor mais par contre aucun scan airodump ne s'affiche
je précise que la awus1900 est bien branchée en usb 3.0 et que les drivers sont biens installés, et comme je l'ai dis avant elle fonctionnait sans soucis.

du coup j'ai branché une awus036nha et là aucuns problèmes, tout se lance correctement.

je cherche sur internet aussi, si des gens ont le meme soucis.
« Modifié: 21 juillet 2020 à 19:28:52 par ZeR0-@bSoLu »

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2919
  • +167/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Soucis avec ma Awus1900
« Réponse #1 le: 15 juillet 2020 à 06:53:07 »
Salut,

Si t'a un problème avec ta carte je te conseille d'aller voir sur un forum réservé à ça pour le coup.

De plus je pense qu'on a répondu à ce genre de problème X fois sur le forum normalement tu devrais trouver avec la barre de recherche.. ;)

Mais bon comme je suis sympa je vais répêter encore une fois

Voici déjà les points à regarder :

-ton câble (l'USB qui connecte ta carte, tu as essayé de changer de cable pour voir ?)
-rfkill (regarde tout simplement si ta carte est rfkill ou pas)

rfkill list
-Si tu es sous VM es ce que tu as bien branché la carte dans les options ?
-As tu essayé de réinstaller les drivers ?
-As tu essayé de passer ta carte en monitor à la main sans utiliser airmon ? voir si le problème viens pas d'une version récente de airmon ? 
-Vérifie que tu es bien en usb 3

lsusb | grep Realtek
et ensuite:

lsusb -D /dev/bus/usb/"numéro du bus"/"numéro du device" | grep bcdUSB
-t'a vérifier sur google si c'est un problème connu ? ( typiquement... : https://github.com/mfruba/kernel/issues/13 ou encore sur le site de aircrack... : https://forum.aircrack-ng.org/index.php?topic=477.0  ) --> Tu as déjà testé leurs solutions ?
 


Tiens nous au courant
« Modifié: 15 juillet 2020 à 07:20:23 par ZeR0-@bSoLu »
Mess  with the bests.
Die like the rest.

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3799
  • +266/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : Soucis avec ma Awus1900
« Réponse #2 le: 15 juillet 2020 à 09:04:46 »
Tu dois stopper le service network-manager manuellement, sinon, il se relance tout seul, c'est probablement la cause de ton souci.

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2919
  • +167/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Soucis avec ma Awus1900
« Réponse #3 le: 15 juillet 2020 à 09:24:48 »
En effet ça peut être ça aussi merci de la précision :D
Mess  with the bests.
Die like the rest.

En ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1597
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : Soucis avec ma Awus1900
« Réponse #4 le: 17 juillet 2020 à 00:32:35 »
Pareil, stopper network-manager avant est obligatoire pour eviter les conflits et les soucis en mode monitor. Sinon, il te faut purger et ré-installer le paquet avec les drivers Realtek, si tu l'avais fais depuis les dépôts, ou mieux, manuellement depuis le git d'aircrack-ng... ;) A la limite, utiliser dkms pour recompiler car tu as sûrement un nouveau noyau qui s'est installé suite a une mise à jour.

Et au fait, avec ces drivers, c'est mieux d'utiliser 'iw' au lieu de 'iwconfig' pour passer en mode monitor (eviter 'airmon-ng' car c'est foireux), ainsi que 'ip' a la place de 'ifconfig' pour mettre l'interface en down|up... (Ce qui est précisé dans le git!  Tu ferais bien d'aller lire tout ça calmement et refaire l'installation proprement ;) ) Avec la fonction recherche du forum, tu aurais trouvé plusieurs tutos, qui t'aurait expliqué tout ça...  :P

=> https://github.com/aircrack-ng/rtl8812au  pour RTL8812AU/21AU and RTL8814AU.
https://www.kali-linux.fr/forum/index.php/topic,298.msg24219.html#msg24219
ou https://www.kali-linux.fr/forum/index.php/topic,6958.msg32218.html#msg32218
ou encore, le test complet + install toutes distribs:  https://www.kali-linux.fr/forum/index.php/topic,3777.msg19252.html#msg19252

Tchao A+  8)
Snk
« Modifié: 17 juillet 2020 à 01:58:30 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne hashirama

  • Membre Junior
  • *
  • Messages: 13
  • +0/-0
Re : Soucis avec ma Awus1900
« Réponse #5 le: 18 juillet 2020 à 01:03:40 »
merci pour vos réponses, je vais jeter un oeil à ça dimanche, en plus j'ai reçu ma nouvelle awus1900 pour mon bureau  :D

je vous tiendrai au courant

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2919
  • +167/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Soucis avec ma Awus1900
« Réponse #6 le: 19 juillet 2020 à 17:17:59 »
ça marche tiens nous au courant.
Mess  with the bests.
Die like the rest.

Hors ligne hashirama

  • Membre Junior
  • *
  • Messages: 13
  • +0/-0
Re : Soucis avec ma Awus1900
« Réponse #7 le: 21 juillet 2020 à 19:08:36 »
Bonjour à tous, alors c'est bon le soucis de ma awus1900 a été réglé  :D j'ai installé kali sur mon pc de bureau, et la bas tout fonctionne nickel, donc le soucis ne venait pas de ma carte wifi, mais de kali installé sur mon pc à la maison, en rentrant j'ai supprimé kali et réinstallé, et là tout fonctionne nickel.

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2919
  • +167/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Soucis avec ma Awus1900
« Réponse #8 le: 21 juillet 2020 à 19:28:36 »
Simple comme bonjour, parfait réglé :)
Mess  with the bests.
Die like the rest.

En ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1597
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : [Résolu] | Soucis avec ma Awus1900
« Réponse #9 le: 21 juillet 2020 à 20:03:48 »
Virer le paquet incriminé et le ré-installer aurait surement suffit, mais bon... Tant que ça fonctionne. :)
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 2919
  • +167/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : [Résolu] | Soucis avec ma Awus1900
« Réponse #10 le: 21 juillet 2020 à 20:09:29 »
Et/ou le driver incriminé :)
Mess  with the bests.
Die like the rest.