Auteur Sujet: [Résolu] | Installation package metasploit-framework_6.0.34-0kali1_amd64.deb  (Lu 568 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne leon-pat
  • Nouvel inscrit
  • Messages: 5
  • +0/-0
Bonjour,

Lors de l'installation du package metasploit-framework_6.0.34-0kali1_amd64.deb sur une distribution Kali toute fraiche j'ai l'erreur suivante :

sudo apt-get install metasploit-framework
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Suggested packages:
  java7-runtime-headless clamav clamav-daemon
The following NEW packages will be installed:
  metasploit-framework
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
148 not fully installed or removed.
Need to get 0 B/130 MB of archives.
After this operation, 399 MB of additional disk space will be used.
(Reading database ... 52703 files and directories currently installed.)
Preparing to unpack .../metasploit-framework_6.0.34-0kali1_amd64.deb ...
Unpacking metasploit-framework (6.0.34-0kali1) ...
dpkg: error processing archive /var/cache/apt/archives/metasploit-framework_6.0.34-0kali1_amd64.deb (--unpack):
 unable to open '/usr/share/metasploit-framework/data/eicar.com.dpkg-new': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/metasploit-framework_6.0.34-0kali1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ai-je raté quelque chose ?

C'est la deuxième tentative d'installation les 148 packages non complètement installés correspondent aux dépendances.

Merci.
« Modifié: 22 mars 2021 à 20:56:44 par ZeR0-@bSoLu »

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1675
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #1 le: 16 mars 2021 à 06:09:37 »
Hello  :)

https://pkg.kali.org/pkg/metasploit-framework, il est bien présent pourtant... Je dirais même, qu'il est sur un Kali d'origine!? (a moins que tu es installé une version light??)
Verifies quand même:
whereis metasploit-framework
which msfconsole

Je serais toi, je recommencerais ça, tranquillou...
Le '148 not fully installed or removed' te dit qu'il y a eu un soucis lors de ta première installation... Donc un 'dpkg-reconfigure metasploit-framework' ou un '--configure -a', s'impose!!
sudo dpkg --configure -a && sudo apt install -fy
sudo apt purge metasploit-framework
sudo apt clean && sudo apt autoclean && sudo apt autoremove --purge -y

Mets ton OS a jour, avant, et ré-install au propre...
sudo apt update && sudo apt dist-upgrade -y
sudo apt install metasploit-framework

Y'a pas de raison que ça ne fonctionne pas, si ton install est propre et ton système a jour...

Tchao, A+
Snk  8)
« Modifié: 16 mars 2021 à 06:16:00 par Snk »
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 3126
  • +174/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #2 le: 16 mars 2021 à 09:07:27 »
Bonjour,

Je t'invite le prochain coup à utiliser les balises codes pour les retour terminal c'est quand même plus lisible.

Citer
/usr/share/metasploit-framework/data/eicar.com.dpkg-new :  No such file or directory

Bah il est juste la ton problème. tu as mis à jour ton système avant ? Tu as tout simplement essayé de faire un

dpkg --configure -a
Si tu utilises debian depuis 2000 tu dois déjà avoir vu ce genre d'erreur j'imagine que tu as essayé d'autre manip' avant de poster sur le forum ? lesquelles dans ce cas ? 

Tu as regarde aussi sur le git s'il y a un signalement de bug ?
« Modifié: 16 mars 2021 à 09:37:41 par ZeR0-@bSoLu »
Mess  with the bests.
Die like the rest.

Hors ligne leon-pat
  • Nouvel inscrit
  • Messages: 5
  • +0/-0
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #3 le: 22 mars 2021 à 19:08:51 »
Bonjour,

Désolé pour le manque de réactivité par rapport à vos réponses mais j'ai été monopolisé par des problèmes familiaux.

Donc j'ai désinstallé à nouveau le package, fait une mise à jour de l'OS puis une nouvelle tentative d'installation et j'ai le même problème.

Le package est bien dans /var/cache/apt/archives/
whereis metasploit-framework   
Citer
[/var/cache/apt/archives]

J'ai fait :
sudo dpkg -i /var/cache/apt/archives/metasploit-framework_6.0.36-0kali1_amd64.deb
Citer
(Reading database ... 52703 files and directories currently installed.)
Preparing to unpack .../metasploit-framework_6.0.36-0kali1_amd64.deb ...
Unpacking metasploit-framework (6.0.36-0kali1) ...
dpkg: error processing archive /var/cache/apt/archives/metasploit-framework_6.0.36-0kali1_amd64.deb (--install):
 unable to open '/usr/share/metasploit-framework/data/eicar.com.dpkg-new': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/metasploit-framework_6.0.36-0kali1_amd64.deb

Une petite précision je fais tourner Kali en tant que sous-système windows 10 mais logiquement cela ne devrait pas avoir d'impact.

J'ai essayé avec le package metasploit-framework_6.0.35-0kali1_amd64.deb mais même problème.

Je vais monter une VM sous HyperV pour vérifier si j'ai le même problème.

Merci

Pat


En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 3126
  • +174/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #4 le: 22 mars 2021 à 19:15:31 »
Bonsoir,

Quid de la commande que l'ont t'a dit de tester ?

Après une simple recherche google : https://github.com/microsoft/WSL/issues/3459

Il y a pleins de solutions à ton problèmes trouvable sur le net, les as tu essayé ?

Dans ce cas pourquoi ne pas demander sur un forum dédié à windows ? ici on traite de cybersécurité on ne conseille pas d'utiliser WSL de ce fait, car c'est trop compliqué pour faire des configs, pour qu'au final cela soit remplie de bugs.

Installe une VM sous virtualbox, HYperV est pas spécialement mieux que WSL selon les cas. Ou alors dualboot.

WSL c'est windows qui le développe donc essaye de faire des recherches sur des forums dédies à ça si tu ne trouves pas sur google je pense :)

Ultimement tu peux juste essayer de simplement ajouter le fichier demandé par ton terminal ?
« Modifié: 22 mars 2021 à 19:25:35 par ZeR0-@bSoLu »
Mess  with the bests.
Die like the rest.

Hors ligne leon-pat
  • Nouvel inscrit
  • Messages: 5
  • +0/-0
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #5 le: 22 mars 2021 à 19:36:22 »
Bonsoir,

J'ai bien passé toutes les commandes indiquées (je les avais déjà effectuées avant de poster ma demande) mais sans succès.

Oui j'avais vu ce problème remonté au sujet de windows defender, j'ai désactivé temporairement pour l'installation mais j'ai toujours la même erreur.

Je vais voir sur un forum dédié à windows .

Merci

Pat

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 3126
  • +174/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #6 le: 22 mars 2021 à 19:38:26 »
D'acc dans ce cas je peux te conseille d'essayer sur Virtualbox en attendant :)

Même en terme de config c'est plus simple :)

Bien à toi
Mess  with the bests.
Die like the rest.

Hors ligne Snk

  • Modérateur
  • Membre Elite
  • *****
  • Messages: 1675
  • +112/-1
  • Multiboot Linux - Kali en Amateur - python(A)
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #7 le: 22 mars 2021 à 20:13:25 »
Reste la soluce d'ajouter une ligne a ton sources.list.d:
deb http://downloads.metasploit.com/data/releases/metasploit-framework/apt lucid main

Comme on fait sur debian ou xubuntu...  ;)
Mais pas sûr que ça fonctionne avec wsl...
A l'époque c'était système_D (Comme démerdes-toi!)
On ne gagne pas sa Liberté , On choisi de la prendre!
Membre du P.L.F, Bill Gate$ suck'$.
Anti GAFAM - Brûlons les tous!
Eux, c'est les pommes, et vous les poires...

Hors ligne leon-pat
  • Nouvel inscrit
  • Messages: 5
  • +0/-0
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #8 le: 22 mars 2021 à 20:55:40 »
Bon j'ai finalement trouvé le problème, on a un anti-virus d'entreprise qui est complétement transparent et silencieux, j'ai demandé à l'admin si il avait des remontées quand j'installe le package et effectivement il y a un blocage mais je ne le voyais pas sur mon poste  >:(

Donc je vais passer sur une VM ce sera plus simple.

Merci

En ligne ZeR0-@bSoLu

  • Administrateur
  • Membre Elite
  • *****
  • Messages: 3126
  • +174/-5
  • Pentest - Arch - Python - Kali
    • Kali-fr
Re : Installation package metasploit-framework_6.0.34-0kali1_amd64.deb
« Réponse #9 le: 22 mars 2021 à 20:56:31 »
Parfait problème résolu :) merci pour ton retour :)

Cela fait sens vu que le fichier manquant est le fichier pour vérifier si l'av fonctionne bien ;) (fichier ECAR)
Mess  with the bests.
Die like the rest.