Auteur Sujet: [en cours]Problème interface wifi avec wifite  (Lu 7966 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Jod

  • Membre Junior
  • *
  • Messages: 36
  • +3/-0
[en cours]Problème interface wifi avec wifite
« le: 30 juillet 2014 à 23:38:03 »
Bonjour,

j'ai récemment fait une requête pour pouvoir utiliser uniquement mon adaptateur usb sans fil pour ne pas prendre le wifi qui est intégrer à mon PC.

La j'essaie de jouer avec wifite mais quand je le démarre dans le terminal en tapant :

wifite
wifite démarre mais il me dit

no wireless interface were found
you need to plug in a wifi device or install driver

Pourtant, je peu me connecter sur iceweasel et téléchager les paquets dispo dans "Ajouter/Supprimer des paquets" avec mon adaptateur (wlan1) pendant que le wifi (wlan0) est inactif !

Si un Kalucien aurai une idée, je serai preneur :)

Merci
« Modifié: 31 juillet 2014 à 09:15:29 par admin »

Hors ligne Jod

  • Membre Junior
  • *
  • Messages: 36
  • +3/-0
Re : Problème interface wifi avec wifite
« Réponse #1 le: 31 juillet 2014 à 00:11:22 »
Je tien à préciser que si je tape :
ifcongif
J'ai eth0, eth0:avahi et lo (je sais pas c'est quoi sa eth0:avahi)

Si je veux ajouter un appareil usb à ma machine virtuel, c'est impossible, il n'apparaisse pas sur virtualbox mais ils sont bien monter sur mon système hôte Debian Wheezy, chose que je trouve quand même bizarre car l'extension est bien et bel installé et quand j'était sous ubuntu je n'avais pas se problème :s
« Modifié: 31 juillet 2014 à 00:15:28 par Jod »

Hors ligne admin

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 1711
  • +74/-3
    • Communauté FR de Kali-linux
Re : Problème interface wifi avec wifite
« Réponse #2 le: 31 juillet 2014 à 09:15:13 »
Que donne :

ifconfig -a

Hors ligne Jod

  • Membre Junior
  • *
  • Messages: 36
  • +3/-0
Re : [en cours]Problème interface wifi avec wifite
« Réponse #3 le: 31 juillet 2014 à 14:36:21 »
J'ai cacher les premières lignes de chaque résultat, adresse IP et MAC :

eth0      Link encap:Ethernet  HWaddr 08:00:27:a7:d7:ed 
          inet adr:192.XXX.X.XX  Bcast:192.XXX.X.XXX  Masque:255.XXX.XXX.X
          adr inet6: fe80::a00:27ff:fea7:d7ed/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:826 (826.0 B)  TX bytes:2058 (2.0 KiB)

lo        Link encap:Boucle locale 
          inet adr:127.X.X.X  Masque:255.X.X.X
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:1200 (1.1 KiB)  TX bytes:1200 (1.1 KiB)

Et je rajoute, que le eth0 est bien et bel mon adaptateur wifi Alfa, mais sur Kali il est détecter comme une connexion ethernet et non wifi :s
Avant de passer sous Debian Wheezy, j'était sous Ubuntu et je pouvais monter mes ports usb sur ma machine virtuel depuis les options de configuration de VirtualBox, mais depuis le passage sous Debian, même avec le pack d'extension de virtualbox, il m'est impossible de les monters sur les machines, aucun périphériques détecté depuis virtualbox

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3793
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : [en cours]Problème interface wifi avec wifite
« Réponse #4 le: 31 juillet 2014 à 18:05:35 »
Dans une VM on utilise un dongle USB Wifi (séparé, pas celui utilisé pour te connecter depuis ton windows)  si tu veux avoir une interface sans fil valide.

Lire la doc + réfléchir = Win \o/

Hors ligne Jod

  • Membre Junior
  • *
  • Messages: 36
  • +3/-0
Re : [en cours]Problème interface wifi avec wifite
« Réponse #5 le: 31 juillet 2014 à 18:16:07 »
Salut Coyotus, c'est pour sa que je me suis acheter un adaptateur Alpha, le problèeme est, que je ne peu pas monter l'adaptateur dans ma machine, elle est bien détecter sur Debian, mais dans virtualbox on me dit qu'il ni a aucun périphérique usb détecter quand tout mes appareil usb sont bien monter et présent depui l'interface debian !

Quand j'était sous Ubuntu je n'avais pas se problème !
et mon wlan1 (adaptateur alpha) est bien sélectionner dans le panneau de config de VirtualBox

Hors ligne coyotus

  • Contributeur de Kali-linux.fr
  • Membre Elite
  • *****
  • Messages: 3793
  • +264/-30
  • IN GNU WE TRUST
    • Groupe d'Utilisateurs de GNU/Linux...
Re : [en cours]Problème interface wifi avec wifite
« Réponse #6 le: 31 juillet 2014 à 18:39:52 »
Tu devrais la voir dans lsusb alors

Hors ligne Jod

  • Membre Junior
  • *
  • Messages: 36
  • +3/-0
Re : [en cours]Problème interface wifi avec wifite
« Réponse #7 le: 31 juillet 2014 à 18:44:57 »
Depuis Kali et son terminal, en tapant lsusb j'obtien ceci :
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Il n'apparaît pas, il considère la connexion pour une connexion ethernet, et non wifi