Auteur Sujet: [réglé] script routeur mikrotik  (Lu 8672 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne yves02

  • Membre Junior
  • *
  • Messages: 18
  • +0/-0
[réglé] script routeur mikrotik
« le: 13 août 2014 à 11:57:22 »
bonjour

Svp quelqu'un peut il me trouver un exemple de script sur un routeur mikrotik ??

merci d'avance
« Modifié: 20 août 2014 à 11:22:13 par admin »

Hors ligne n0D

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 147
  • +7/-0
  • HACK THE PLANET !
Re : script routeur mikrotik
« Réponse #1 le: 13 août 2014 à 12:44:34 »
Ca réponds a ton attente ?

Citer
#####################
### Configuration ###
#####################

# Envoyer l'IP publique a l'adresse email suivante
:local MonEmail "mon@email"

# DynDNS Auth
:local DynDNSUsername "votrenomdedomaine.tld-sousdomaine";
:local DynDNSPassword "motdepassedyndnsovh";

# DynDNS Hostname
:local DynDNSHostname "sousdomaine.nomdedomaine.tld";

# DynDNS Service Provider
:local DynDNSServiceProvider "www.ovh.com";

# Method to retrieve your public IP (interface or web)
:local GetPublicIpFrom "interface";

# "web": will get your IP from a web page
:local GetPublicIpFromWebUrl "http://www.votresiteweb.tld/monip.php";

# "interface": will get the IP of your WAN interface
:local GetPublicIpFromInterfaceName "ether1-gateway";

##########################
### Retrieve public IP ###
##########################

# LastPublicIP contain the public IP shown from the last previous run of this script
:global LastPublicIP;
:local DynDNSUrl;
:local CurrentPublicIP;

# Retrieve public IP from the web
:if ($GetPublicIpFrom = "web") do={
   /tool fetch dst-path="/publicIP.txt" url=$GetPublicIpFromWebUrl;
   :set CurrentPublicIP [/file get publicIP.txt contents];
   :file remove publicIP.txt;
}

# Retrieve public IP from the WAN interface
:if ($GetPublicIpFrom = "interface") do={
   :set CurrentPublicIP [/ip address get [find interface=$GetPublicIpFromInterfaceName] address];
   :set CurrentPublicIP [:pick $CurrentPublicIP 0 [:find $CurrentPublicIP "/" -1]];
}

#######################
### Updating DynDNS ###
#######################

# Check if public IP as changed
:if ($LastPublicIP != $CurrentPublicIP) do={

#    Update DynDNS with the new IP
   :set DynDNSUrl ("http://".$DynDNSUsername.":".$DynDNSPassword."@".$DynDNSServiceProvider."/nic/update?system=dyndns&hostname=".$DynDNSHostname."&myip=".$CurrentPublicIP."&wildcard=no");
   /tool fetch url=$DynDNSUrl dst-path="/dyndns.txt";

#   :delay 1;

#   Read result
   :local result [/file get dyndns.txt contents];
   :file remove dyndns.txt;
   :local resultCode [:pick $result 0 [:find $result " " -1]];

#   "good" mean "DynDNS updated successfully and IP was a new IP"
   :if ($resultCode="good") do={
      :log info ("DynDNS-OVH: OK (!! New IP !! => ".$CurrentPublicIP.")");      
      :set LastPublicIP $CurrentPublicIP;
      /tool e-mail send to="$MonEmail" subject="New Public IP" body="$CurrentPublicIP";
   }

#   "nochg" mean "DynDNS already up-to-date (same IP last before)"
   :if ($resultCode="nochg") do={
      :log info ("DynDNS-OVH: OK (already up-to-date => ".$CurrentPublicIP.")");      
      :set LastPublicIP $CurrentPublicIP;
   }

#   Others cases / error
   :if (($resultCode!="good") && ($resultCode!="nochg")) do={
      :log info ("DynDNS-OVH: PAS OK (RawResult: ".[:pick $result 0 ([:len $result] - 1) ].")");
   }
} else={
   :log info ("DynDNS-OVH: OK (Nothing to do => ".$CurrentPublicIP.")");
}

"Vi Veri Veniversum Vivus Vici"

Hors ligne n0D

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 147
  • +7/-0
  • HACK THE PLANET !
Re : script routeur mikrotik
« Réponse #2 le: 13 août 2014 à 12:55:12 »
Voici la suite,
Configuration du script de mise à jour du DynHOST d’OVH pour Router OS

Vous devrez configurer plusieurs éléments au tout début de ce script :
 

1 # DynDNS Auth
2:local DynDNSUsername "votrenomdedomaine.tld-sousdomaine";
3:local DynDNSPassword "motdepassedyndnsovh";


•DynDNSUsername : mettre l’identifiant DynHOST créé chez OVH qui est en général au format suivant : votrenomdedomaine.tld-sousdomaine
•DynDNSPassword : mettre le mot de passe correspondant à l’identifiant DynHOST créé chez OVH

1 # DynDNS Hostname
2:local DynDNSHostname "sousdomaine.nomdedomaine.tld";


•DynDNSHostname : mettre le sous-domaine au format suivant : sousdomaine.nomdedomaine.tld

1 # Method to retrieve your public IP (interface or web)
2:local GetPublicIpFrom "interface";
3
4# "web": will get your IP from a web page
5:local GetPublicIpFromWebUrl "http://www.votresiteweb.tld/monip.php";
6
7# "interface": will get the IP of your WAN interface
8:local GetPublicIpFromInterfaceName "ether1-gateway";


 
 
•GetPublicIpFrom : ◦“interface” : indique au script de récupérer l’adresse IP d’une interface du routeur en tant qu’adresse IP sur laquelle pointer le sous-domaine (cas d’un routeur directement connecté à Internet) ◾GetPublicIpFromInterfaceName : indiquer le nom de l’interface oqui est directement connecté à Internet (en général : au modem câble ou au routeur DSL)

◦“web” : indique au script d’interroger une page Web afin de connaître l’adresse IP publique sur laquelle pointer le sous-domaine (cas d’un routeur qui n’est pas directement connecté à Internet) ◾GetPublicIpFromWebUrl : indiquer l’adresse du script permettant au routeur de connaître son adresse IP publique (cas voir un exemple du contenu de ce script ci-dessous)


Exemple de script PHP permettant de connaître l’adresse IP publique de son routeur

Voici un simple exemple pour le script “monip.php” (qui doit donc être hébergé sur un serveur qui permet l’exécution de scripts PHP)

Script qui affiche l'adresse IP du visiteur

PHP

1<?php
2:header("Content-Type: text/plain");
3:echo $_SERVER["REMOTE_ADDR"];
4:?>




https://www.letitux.com/routeur-os-mikrotik/2012/09/30/script-de-mise-a-jour-du-dynhost-dovh-router-os.html  <--  :)
 
"Vi Veri Veniversum Vivus Vici"

Hors ligne yves02

  • Membre Junior
  • *
  • Messages: 18
  • +0/-0
Re : script routeur mikrotik
« Réponse #3 le: 19 août 2014 à 10:58:16 »
trop cool @D3F4L7... ;)

merci bcp  8)

Hors ligne n0D

  • Contributeur de Kali-linux.fr
  • Membre régulier
  • *****
  • Messages: 147
  • +7/-0
  • HACK THE PLANET !
Re : script routeur mikrotik
« Réponse #4 le: 19 août 2014 à 16:11:31 »
De rien  ;)
"Vi Veri Veniversum Vivus Vici"