Auteur Sujet: [réglé] au sujet de msfconsole  (Lu 7255 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Guiome

  • Membre Junior
  • *
  • Messages: 10
  • +0/-0
[réglé] au sujet de msfconsole
« le: 17 août 2014 à 18:41:54 »
Bonjour a tous
Depuis quelque mois je tourne sur Kali Linux et decouvre Metasploit mais depuis la derniere mise a jour de nouvelle chose me sont apparus quand je lance la commande msfconsole et metasploit mais beaucoup plus de temps a souvrir:

root@kali:~# msfconsole
/usr/share/metasploit-framework/config/boot.rb:4: warning: already initialized constant GEMFILE_EXTENSIONS
You did not specify how you would like Rails to report deprecation notices for your production environment, please set config.active_support.deprecation to :notify at config/environments/production.rb
[-] WARNING! The following modules could not be loaded!
[-]    /opt/metasploit/apps/pro/metamodules/firewall_egress/modules/auxiliary/metamodule/firewall_egress.rb: NameError uninitialized constant Msf::Pro::Task
ensuite j'ai le fameux dessin de demarage metasploit et tous se qui s en suis

Ma question est :
Est ce normal se qui est ecrit et quoi faire pour y remedié ?
Merci de vos reponse par avance
« Modifié: 23 août 2014 à 00:15:50 par admin »

Hors ligne Teeknofil

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 368
  • +28/-6
    • https://www.youtube.com/watch?v=R-zrnglcNuA&list=PLeu60bO1b61HE25L8Sz-cC7xjFupaSuWc
Re : au sujet de msfconsole
« Réponse #1 le: 20 août 2014 à 05:36:35 »
Ton problème vient de Ruby, metasploit est codé avec Ruby et le message d'erreur d'indique que tu a un problème avec le module firewall_egress.rb.

Si tu a modifier le code source il faut que tu mette l'ancien fichier en téléchargeant le fichier depuis les dépôts, si tu es codeur alors débug ton code source. Mais avant pour faire plus simple fait une mise à jour.

msfupdate
Si la mise à jour ne fonctionne pas, va sur git hub télécharger le fichier firewall_egress.rb et met le dans le répertoire /opt/metasploit/apps/pro/metamodules/firewall_egress/modules/auxiliary/metamodule/

Si cela répare pas le problème alors c'est soit un bug de metasploit ou ta version de ruby qui un bug ou qui est pas à jour ( je sais pas quelle version de ruby utilise metasploit, soit la derniere ou un plus ancien, va voir la doc)
Hacking Debutant - Black Hat Ackademy : https://www.udemy.com/draft/2365526/?couponCode=PROMOTION

Hors ligne Guiome

  • Membre Junior
  • *
  • Messages: 10
  • +0/-0
Re : au sujet de msfconsole
« Réponse #2 le: 20 août 2014 à 15:16:50 »
Merci pour l'information je vais regardé tous cela, je n'es rien modifié c'est suite a la mise a jour de Metasploit que j'ai eu ce message, j'ai essayé msfupdate aucune mise a jour, j'ai meme réinstalli Kali completement et meme problème

dans mon depot source.list j'ai ceci :

deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-fr$
deb http://repo.kali.org/kali kali-bleeding-edge main
deb-src http://repo.kali.org/kali kali-bleeding-edge main

est se que c'est du un un depot qui peux posé problème en aillant fais une mauvaise mis a jour ...

Hors ligne Guiome

  • Membre Junior
  • *
  • Messages: 10
  • +0/-0
Re : au sujet de msfconsole
« Réponse #3 le: 21 août 2014 à 02:03:23 »
j'ai réinstaller kali 1.0.7 sans faire aucune MAJ msfconsole aucun message comme enoncé au debut
et dans mon sources.list jai mis que 2 depot
## Dépots officiel
deb http://http.kali.org/kali kali main contrib non-free

## Security updates
deb http://security.kali.org/kali-security kali/updates main contrib non-free

je vais effectuez les mise a jours


apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été conservés :
  beef-xss kali-linux kali-linux-full
Les paquets suivants seront mis à jour :
  apache2 apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common apt
  apt-utils armitage automater base-files chkrootkit cups-bsd cups-client
  cups-common dbus dbus-x11 dnsrecon dpkg dpkg-dev exploitdb extlinux
  fern-wifi-cracker firmware-adi firmware-atheros firmware-bnx2 firmware-bnx2x
  firmware-brcm80211 firmware-intelwimax firmware-ipw2x00 firmware-ivtv
  firmware-iwlwifi firmware-libertas firmware-linux firmware-linux-free
  firmware-linux-nonfree firmware-myricom firmware-netxen firmware-qlogic
  firmware-ralink firmware-realtek ghost-phisher gnupg gpgv
  icedtea-6-jre-cacao icedtea-6-jre-jamvm icedtea-7-jre-jamvm iceweasel
  intel-microcode iodine kali-linux-sdr kali-menu krb5-locales
  libapache2-mod-php5 libapt-inst1.5 libapt-pkg4.12 libavcodec53 libavdevice53
  libavformat53 libavutil51 libc-bin libc-dev-bin libc6 libc6-dev libc6-i686
  libcups2 libcupsimage2 libdbi-perl libdbus-1-3 libdpkg-perl
  libgnutls-openssl27 libgnutls26 libgpgme11 libgssapi-krb5-2 libgssrpc4
  libjpeg-progs libjpeg8 libk5crypto3 libkadm5clnt-mit8 libkadm5srv-mit8
  libkdb5-6 libkrb5-3 libkrb5support0 liblzo2-2 libmapi0 libmapiadmin0
  libmozjs24d libmysqlclient18 libnss3 libnss3-1d libocpf0 libopenobex1
  libopenobex1-dev libpostproc52 libssl-dev libssl-doc libssl1.0.0 libswscale2
  libxml2 libxml2-dev libxml2-utils linux-image-3.14-kali1-686-pae
  linux-libc-dev locales locales-all metasploit metasploit-framework mitmproxy
  mobile-broadband-provider-info multiarch-support mysql-client-5.5
  mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5
  openchangeclient openjdk-6-jdk openjdk-6-jre openjdk-6-jre-headless
  openjdk-6-jre-lib openjdk-7-jdk openjdk-7-jre openjdk-7-jre-headless
  openssh-client openssh-server openssl php5 php5-cli php5-common php5-mysql
  python-libxml2 python-lxml python-reportbug python-scapy recon-ng reportbug
  responder ruby-eventmachine ruby-json ruby-msgpack ruby-rack-protection
  ruby-sinatra ruby-tilt spidermonkey-bin sslsplit syslinux syslinux-common
  tzdata tzdata-java w3af w3af-console wireless-regdb wpasupplicant
  xulrunner-24.0 yersinia
154 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de prendre 588 Mo dans les archives.
Après cette opération, 148 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] 

Apres cela je vous dirais si j'ai denouveau cette erreur

etensuite je ferais dist-upgrade et  jevous redirais ou cela en es

( je ne peux pas etre plus precis sur mes manip )

Hors ligne Guiome

  • Membre Junior
  • *
  • Messages: 10
  • +0/-0
Re : au sujet de msfconsole
« Réponse #4 le: 21 août 2014 à 04:39:07 »
Après la 1ere etape de mise a jour toujour pas de probleme
je vais essayé avec dist-upgrade maintenant

apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  beef-xss-bundle
Les NOUVEAUX paquets suivants seront installés :
  gdisk hashid libhttp-parser2.1 python3 python3-minimal python3.2
  python3.2-minimal ruby-ansi ruby-atomic ruby-buftok ruby-dataobjects
  ruby-dataobjects-mysql ruby-dataobjects-postgres ruby-dataobjects-sqlite3
  ruby-dm-core ruby-dm-do-adapter ruby-dm-migrations ruby-dm-sqlite-adapter
  ruby-em-websocket ruby-equalizer ruby-execjs ruby-faraday ruby-http
  ruby-http-parser.rb ruby-librex ruby-libv8 ruby-memoizable
  ruby-msfrpc-client ruby-multipart-post ruby-naught ruby-parseconfig ruby-ref
  ruby-rubyzip ruby-simple-oauth ruby-therubyracer ruby-thread-safe
  ruby-twitter ruby-uglifier
Les paquets suivants seront mis à jour :
  beef-xss kali-linux kali-linux-full
3 mis à jour, 38 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 4 570 ko/14,5 Mo dans les archives.
Après cette opération, 308 Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ?


Je vous tien au courant

Hors ligne Guiome

  • Membre Junior
  • *
  • Messages: 10
  • +0/-0
Re : au sujet de msfconsole
« Réponse #5 le: 21 août 2014 à 05:06:47 »
apres dist-upgrade toujour aucune erreur je n'es plus aucune mise a jour a effectué

cela devais venir dune mise a jour d'un des autre depos dans sources.list

je sais pas si vous pouvez marqué resolu car on sais toujours pas d ou venais le probleme

Merci

Hors ligne nonsolum

  • Membre régulier
  • **
  • Messages: 132
  • +7/-6
Re : au sujet de msfconsole
« Réponse #6 le: 21 août 2014 à 12:40:44 »
Bonjour,

J'ai exactement le même problème suite à la dernière mise à jour de kali et metasploit.
Mais apparemment nous ne sommes pas les seuls:

https://community.rapid7.com/thread/5006

Il semblerait que tous ceux qui ont procédé à la mise à jour en question soient impactés.
Et les développeurs de Metasploit sont sur le coup.

Pour ma part je n'ai pas jonglé avec les mises à jour considérant que s'interdire les mises à jour de Metasploit est particulièrement handicapant.
J'ai installé la dernière version de kali 1.0.9-amd64 et j'ai trouvé, en l'état, le même problème .
Il s'agit semble-t-il d'un bug lié à la nouvelle version.


« Modifié: 21 août 2014 à 13:18:46 par nonsolum »

Hors ligne Guiome

  • Membre Junior
  • *
  • Messages: 10
  • +0/-0
Re : au sujet de msfconsole
« Réponse #7 le: 21 août 2014 à 14:28:02 »
Ah ok  merci pour l'info ca me rassure c'est pas du a une erreur de ma part

Hors ligne nonsolum

  • Membre régulier
  • **
  • Messages: 132
  • +7/-6
Re : au sujet de msfconsole
« Réponse #8 le: 21 août 2014 à 17:07:45 »
Tout est OK pour moi maintenant.
Une mise à jour de Metasploit datant de ce jour semble  avoir réglé le problème.
Si tel est le cas, merci aux developpeurs de Metasploit et bravo pour leur réactivité

Hors ligne Teeknofil

  • Contributeur de Kali-linux.fr
  • Membre sérieux
  • *****
  • Messages: 368
  • +28/-6
    • https://www.youtube.com/watch?v=R-zrnglcNuA&list=PLeu60bO1b61HE25L8Sz-cC7xjFupaSuWc
Re : [réglé] au sujet de msfconsole
« Réponse #9 le: 01 septembre 2014 à 18:04:35 »
Oui, c'est comme je l'avais dit mais l'erreur venait du Staf de Kali et Metasploit.
J'ai eu la même erreur et avant-hier il y a eu une mises à jour de Kali, donc tout doit être réglé. Tant mieux car mon bidouillage n'était pas terrible et ça aurait était compliquer à partager.

Si le problème persiste chez quelqu'un taper ces commandes:

# apt-get remove metasploit-framework && rm -fr /opt/metasploit &&  apt-get purge metasploit-framework

# apt-get update && apt-get upgrade && apt-get dist-upgrade

# apt-get install metasploit metasploit-framework
Hacking Debutant - Black Hat Ackademy : https://www.udemy.com/draft/2365526/?couponCode=PROMOTION