Installer Open-vpn sous kali-linux

openvpntech_logo_rounded_antialiased

Afin de bénéficier d’un client VPN robuste permettant l’utilisation d’un tunnel VPN SSL, je vous propose ici un tutoriel permettant d’installer et d’utiliser OpenVPN sous Kali linux.

Pour commencer, nous allons ajouter les dépôts nécessaires à l’installation de paquets permettant d’utiliser des tunnels à destination d’un serveur OpenVPN.

  • Recopier les commandes suivantes dans un invite de commande (shell) disposant des droits « root ».

1/ Mis à jour des sources de dépôts des paquets GNU/Linux :

echo "deb http://ftp.fr.debian.org/debian wheezy main" >> /etc/apt/sources.list
apt-get update

2/ Installation des paquets nécessaires :

apt-get -y install network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome network-manager-strongswan network-manager-vpnc network-manager-vpnc-gnome

A l’issue de l’installation des paquets, le service « network-manager » a redémarré pour prendre en compte ses nouvelles fonctionnalités.

Votre Kali linux est déjà prêt à être configuré pour utiliser une connexion VPN (OpenVPN mais aussi IPSEC avec IKE en version 2, PPTP et pour finir VPNC (un type de VPN Cisco).

Vous pouvez désormais vous connecter à votre serveur Open VPN comme par exemple décrit sur ce tutoriel décrivant l’utilisation du serveur VPN Hide My Ass.

Email this to someoneShare on FacebookTweet about this on TwitterShare on Google+Share on LinkedIn

5 commentaires à propos de “Installer Open-vpn sous kali-linux

  1. Aprés avoir suivis ton Tuto à la lettre un message d’erreur s’affiche : « Package network-manager-strongswan is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source. »

  2. Hi

    [email protected]:~# echo « deb http://ftp.fr.debian.org/debian wheezy main » >> /etc/apt/sources.list
    [email protected]:~# apt-get update
    Ign:1 http://ftp.fr.debian.org/debian wheezy InRelease
    Hit:2 http://ftp.fr.debian.org/debian wheezy Release
    Reading package lists… Done
    W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:7
    W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:7
    W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:7
    W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:7
    W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:7
    W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:7
    W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:7
    W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:7

    I’m after the above steps

    I want to get the software
    I came across the following error —>>

    apt-get -y install network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome network-manager-strongswan network-manager-vpnc network-manager-vpnc-gnome
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    network-manager-pptp : Depends: pptp-linux but it is not going to be installed
    Depends: ppp (>= 2.4.5) but it is not going to be installed
    Depends: ppp (= 2.15.1) but it is not going to be installed
    Depends: libgnome2-0 (>= 2.17.3) but it is not going to be installed
    Depends: libgnomeui-0 (>= 2.22.0) but it is not going to be installed
    Depends: liborbit2 (>= 1:2.14.10) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    [email protected]:~# uname -a
    Linux 4.3.0-kali1-686-pae #1 SMP Debian 4.3.3-5kali4 (2016-01-13) i686 GNU/Linux

    please help me!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*