Installer Kali Linux 2.0 dans Debian 8

Dans ce tutoriel je vais vous montrer comment installer les outils de Kali Linux version 2.0 dans Debian 8. Kali Linux a bon être une pointure dans les distributions de pentesting, elle reste pauvre en utilitaire système et autres logiciel indispensable. Pour s’épargner beaucoup d’installations de logiciels annexes il peut être intéressant d’installer Debian en premier pour avoir des outils comme libre Office, Gimp, gedit, gconf, un graveur d’image iso et etc.

Pour suivre ce tutoriel il faut que vous soyer connecter en tant qu’utilisateur root.

[email protected]:~$ su
 Mot de passe : xxxxxxxxxxxx

Commencer par faire la mise à jour de Debian 8.

[email protected]:/home/teeknofile# apt-get update -y && sudo apt-get upgrade -y && 
sudo apt-get -y dist-upgrade

Sur une installation propre et standard de Kali Linux, vous devriez avoir les entrées suivantes présentes dans le fichier sources.list.

## Kali Linux
deb http://http.kali.org/kali sana main non-free contrib 
deb-src http://http.kali.org/kali sana main non-free contrib 
## Security updates
deb http://security.kali.org/kali-security sana/updates main contrib non-free 
deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

 

Pour ajouter les sources taper cette commandes dans votre terminal et copier les dépôts ci-dessus.

[email protected]:/home/teeknofile# nano /etc/apt/sources.list

Tous les dépôts ajoutés au fichier sources Liste altéreront votre distribution de Kali Linux. Les dépôts de Kali Linux sont synchronisé plusieurs fois par jour avec ceux de Debian. Il est donc inutile d’ajouter en plus les sources Debian car cela provoquerait des conflits. Commenter les dépôts Debian avec des #.

#deb http://ftp.fr.debian.org/debian/ jessie main
#deb-src http://ftp.fr.debian.org/debian/ jessie main
#deb http://security.debian.org/ jessie/updates main
#deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
#deb http://ftp.fr.debian.org/debian/ jessie-updates main
#deb-src http://ftp.fr.debian.org/debian/ jessie-updates main

Inutiles de les effacées car elles peuvent toujours servir pour vous dépanner un jour on ne sait jamais. Enregistrer et fermer (CTRL X pour Quitter et O pour sauvegarder et terminé par entrée). Maintenant il faut installer la clé archive Kali Linux.

[email protected]:/home/teeknofile# apt-get update
[email protected]:/home/teeknofile# apt-get install kali-archive-keyring

Il faut faire une mise à jour complète. Vous pouvez aller boire un café car l’installation est assez longue et je vous conseille de le faire deux fois pour être sûr que la mise à jour soit bien prise en charge.

Mais avant si vous voulez garder le thème de Debian 8 il faut exclure un paquet de la mise à jour de Kali Linux.

[email protected]:/home/teeknofile# aptitude hold desktop-base #(facultafif)
[email protected]:/home/teeknofile# apt-get update -y && apt-get upgrade -y 
&& apt-get -y dist-upgrade

Redémarrer votre PC. Si vous voulez installer tous les paquets et transformer votre Debian en Kali Linux pour avoir les avantages des deux distributions il faut installer les paquets Kali-Linux. Vous pouvez en copiant et collant cette commande dans votre terminal transformerez votre Debian en Kali Linux.

[email protected]:/home/teeknofile# apt-get install kali-linux-all kali-linux-full kali-menu

Vous pouvez aller boire un autre café car l’installation est assez longue mais attention à l’excès de caféine. L’installation terminée, il vous restera plus qu’à redémarrer.

Après le redémarrage nettoyer les anciens paquets en tapant :

apt-get autoremove --purge

Pour utiliser les outils de Kali Linux il vous faudra utiliser une session root.  Votre autre compte vous sera utile pour des utilisations plus courantes de votre PC.

Email this to someoneShare on FacebookTweet about this on TwitterShare on Google+Share on LinkedIn

11 commentaires à propos de “Installer Kali Linux 2.0 dans Debian 8”

  1. Bonjour
    J’ai suivi ce tuto pour mettre kali sur une debian 8.2 fraîchement installée ce matin
    depuis j’ai ce message d’erreur :
    W: Erreur de GPG : http://security.kali.org sana/updates InRelease : Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY ED444FF07D8D0BF6
    W: Erreur de GPG : http://http.kali.org sana InRelease : Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY ED444FF07D8D0BF6

    ainsi qu’une « histoire » de paquets cassés…

    au pire, je vire tout et je réinstalle, il n’y a pas de données à sauvegarder, mais je préférerais comprendre quand même…Je ne parviens pas à trouver non plus comment réparer les paquets cassés :

    en faisant : aptitude search ~b en root le résultat est :
    pB xserver-xorg-video-siliconmotio – X.Org X server — SiliconMotion display dr

    si je tente de désinstaller X.Org etc, ça risque de tout casser un peu plus ?

    Merci

  2. Suite :
    Si je fais : apt-get install kali-linux-all kali-linux-full kali-menu
    Lecture des listes de paquets… Fait
    Construction de l’arbre des dépendances
    Lecture des informations d’état… Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l’impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n’ont pas encore
    été créés ou ne sont pas sortis d’Incoming.
    L’information suivante devrait vous aider à résoudre la situation :

    Les paquets suivants contiennent des dépendances non satisfaites :
    kali-linux-all : Dépend: kali-linux-forensic mais ne sera pas installé
    Dépend: kali-linux-gpu mais ne sera pas installé
    Dépend: kali-linux-pwtools mais ne sera pas installé
    Dépend: kali-linux-rfid mais ne sera pas installé
    Dépend: kali-linux-sdr mais ne sera pas installé
    Dépend: kali-linux-top10 mais ne sera pas installé
    Dépend: kali-linux-voip mais ne sera pas installé
    Dépend: kali-linux-web mais ne sera pas installé
    Dépend: kali-linux-wireless mais ne sera pas installé
    Dépend: veil-catapult mais ne sera pas installé
    kali-linux-full : Dépend: kali-linux mais ne sera pas installé
    Dépend: kali-linux-sdr mais ne sera pas installé
    Dépend: acccheck mais ne sera pas installé
    Dépend: bluelog mais ne sera pas installé
    Dépend: clang mais ne sera pas installé
    Dépend: enum4linux mais ne sera pas installé
    Dépend: golismero mais ne sera pas installé
    Dépend: passing-the-hash mais ne sera pas installé
    Dépend: powerfuzzer mais ne sera pas installé
    Dépend: vega mais ne sera pas installé
    Dépend: winexe mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

    merci 🙂

  3. Bonjour,

    testé et erreur sur la fin :

    apt-get install kali-linux-all kali-linux-full kali-menu
    Lecture des listes de paquets… Fait
    Construction de l’arbre des dépendances
    Lecture des informations d’état… Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l’impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n’ont pas encore
    été créés ou ne sont pas sortis d’Incoming.
    L’information suivante devrait vous aider à résoudre la situation :

    Les paquets suivants contiennent des dépendances non satisfaites :
    kali-linux-all : Dépend: kali-linux-forensic mais ne sera pas installé
    Dépend: kali-linux-gpu mais ne sera pas installé
    Dépend: kali-linux-pwtools mais ne sera pas installé
    Dépend: kali-linux-rfid mais ne sera pas installé
    Dépend: kali-linux-sdr mais ne sera pas installé
    Dépend: kali-linux-top10 mais ne sera pas installé
    Dépend: kali-linux-voip mais ne sera pas installé
    Dépend: kali-linux-web mais ne sera pas installé
    Dépend: kali-linux-wireless mais ne sera pas installé
    Dépend: veil-catapult mais ne sera pas installé
    kali-linux-full : Dépend: kali-linux mais ne sera pas installé
    Dépend: kali-linux-sdr mais ne sera pas installé
    Dépend: acccheck mais ne sera pas installé
    Dépend: beef-xss mais ne sera pas installé
    Dépend: bluelog mais ne sera pas installé
    Dépend: clang mais ne sera pas installé
    Dépend: enum4linux mais ne sera pas installé
    Dépend: golismero mais ne sera pas installé
    Dépend: passing-the-hash mais ne sera pas installé
    Dépend: powerfuzzer mais ne sera pas installé
    Dépend: sparta mais ne sera pas installé
    Dépend: vega mais ne sera pas installé
    Dépend: winexe mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

    ?? :/

  4. Bonjour,

    J’ai un soucis quand je fais la dernière commande : apt-get install kali-linux-all kali-linux-full kali-menu.

    Je reçoit le message suivant :

    Les paquets suivants contiennent des dépendances non satisfaites :
    kali-linux-all : Dépend: kali-linux-forensic mais ne sera pas installé
    Dépend: kali-linux-gpu mais ne sera pas installé
    Dépend: kali-linux-pwtools mais ne sera pas installé
    Dépend: kali-linux-rfid mais ne sera pas installé
    Dépend: kali-linux-sdr mais ne sera pas installé
    Dépend: kali-linux-top10 mais ne sera pas installé
    Dépend: kali-linux-voip mais ne sera pas installé
    Dépend: kali-linux-web mais ne sera pas installé
    Dépend: kali-linux-wireless mais ne sera pas installé
    Dépend: veil-catapult mais ne sera pas installé
    kali-linux-full : Dépend: kali-linux mais ne sera pas installé
    Dépend: kali-linux-sdr mais ne sera pas installé
    Dépend: acccheck mais ne sera pas installé
    Dépend: beef-xss mais ne sera pas installé
    Dépend: enum4linux mais ne sera pas installé
    Dépend: passing-the-hash mais ne sera pas installé
    Dépend: sparta mais ne sera pas installé
    Dépend: vega mais ne sera pas installé
    Dépend: winexe mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

    Je ne sais plus quoi faire, je suis sous debian 8 jessie

  5. Lancer un apt-get upgrade suivie d’un apt-get dist-upgrade avec les dépots Kali dans une Debian est une bonne façon de cassé ses librairies… Bref de casser sa distro.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*

Time limit is exhausted. Please reload CAPTCHA.